cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
2499
Views
4
Helpful
5
Replies

moving devices of network subnet to new location

jcowtan
Level 1
Level 1

I am moving a subnet to a new physical location. However, there a re a number of servers and I would like to minimize the exposure of an outages.

Can I "move" a device from the current subnet, install it at the new location and enter a routing statement to point to the address of the device using a 32 bit mask? When all the devices are moved, I would move the definition of the subnet.

Can I have components of a subnet in different locations?

1 Accepted Solution

Accepted Solutions

You don't need to change anything on the server The router when configured for LAM, it will expect mobile stations on the subnet, therefore it will respond with its own MAC address.

Have a look at this:

Rack1R5#sh run int e0/0

Building configuration...

Current configuration : 92 bytes

!

interface Ethernet0/0

ip address 10.1.1.1 255.255.255.0

ip mobile arp

half-duplex

end

Rack1R5#sh arp

Protocol Address Age (min) Hardware Addr Type Interface

Internet 10.1.1.1 - 0001.9691.d280 ARPA Ethernet0/0

Internet 204.12.1.10 1 0008.0dee.4067 ARPA Ethernet0/0

This host of address 204.12.1.10 with DG 204.12.1.4 has moved to another router with e0/0 10.1.1.1 the host can ping the local router.

Rack1R5#

router ospf 1

redistribute mobile metric 1 subnets

Now let's have a look at the remote router routing table, which has 204.12.1.0/24 subnet configured on its LAN interface.

Rack1R4#sh run int e0

Building configuration...

Current configuration : 64 bytes

!

interface Ethernet0

ip address 204.12.1.4 255.255.255.0

end

sh ip ro

....

Gateway of last resort is not set

204.12.1.0/24 is variably subnetted, 2 subnets, 2 masks

C 204.12.1.0/24 is directly connected, Ethernet0

O E2 204.12.1.10/32 [110/1] via 162.1.45.5, 00:02:41, Serial1

Rack1R4#ping 204.12.1.10

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 204.12.1.10, timeout is 2 seconds:

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 36/40/56 ms

Rack1R4#

As you can see the router sees the remote host with a /32 subnet and can reach it even though it is on another network across a WAN link.

Therefore in answer to your first question you don't need to change anything on the servers, just move them as they are, configure the new router with the ip mobile arp command, redistribute the mobile routes in EIGRP with the metrics you use and you are done.

2. Correct in all statements. Don't forget to remove the EIGRP network statement from the old router and add it to the new one...

HTH

E.

View solution in original post

5 Replies 5

ekiriakos
Level 1
Level 1

Hi,

If I understand you correctly you want to move a server with it's existing address to a another location without changing it's address until all hosts are migrated?

If this is the case you can use local-area mobility, assuming you are running one of the two recommended protocols for this feature such as eigrp or ospf.

Say your server has an address 10.1.1.1/24 and you are moving it to subnet 10.1.2.0/24. As an example:

int f0/0

ip addre 10.1.2.2 255.255.255.0

ip mobile arp

Then under your routing protocol, redistribute mobile and the server address will appear as a /32 in others routers routing table.

Here is also a link to help you understand the command.

http://www.cisco.com/univercd/cc/td/doc/product/software/ios123/123cgcr/ipras_r/ip1_i2g.htm#wp1078546

You can also apply security with an access group etc.

i.e

access-list 10 permit 10.1.1.1

interface f0/0

ip addr ......

ip mobile arp access-group 10

HTH

E.

Great information. We are using EIGRP.

I have been reviewing this and have a few questions.

1. If I a move a server to the new subnet configured with ip mobile arp, how does the server learn the default route of the new subnet interface? Do I have to add that gateway to the server configuration?

2. I have ~12 servers to move to the new location. When all have been moved and I no longer need the subnet interface at the old location, then all I have to do is:

a) delete the old subnet interface;

b) change "new" interface subnet to old subnet and;

c) delete ip mobile arp statements.

Now I have moved subnet to new location. Am I correct?

You don't need to change anything on the server The router when configured for LAM, it will expect mobile stations on the subnet, therefore it will respond with its own MAC address.

Have a look at this:

Rack1R5#sh run int e0/0

Building configuration...

Current configuration : 92 bytes

!

interface Ethernet0/0

ip address 10.1.1.1 255.255.255.0

ip mobile arp

half-duplex

end

Rack1R5#sh arp

Protocol Address Age (min) Hardware Addr Type Interface

Internet 10.1.1.1 - 0001.9691.d280 ARPA Ethernet0/0

Internet 204.12.1.10 1 0008.0dee.4067 ARPA Ethernet0/0

This host of address 204.12.1.10 with DG 204.12.1.4 has moved to another router with e0/0 10.1.1.1 the host can ping the local router.

Rack1R5#

router ospf 1

redistribute mobile metric 1 subnets

Now let's have a look at the remote router routing table, which has 204.12.1.0/24 subnet configured on its LAN interface.

Rack1R4#sh run int e0

Building configuration...

Current configuration : 64 bytes

!

interface Ethernet0

ip address 204.12.1.4 255.255.255.0

end

sh ip ro

....

Gateway of last resort is not set

204.12.1.0/24 is variably subnetted, 2 subnets, 2 masks

C 204.12.1.0/24 is directly connected, Ethernet0

O E2 204.12.1.10/32 [110/1] via 162.1.45.5, 00:02:41, Serial1

Rack1R4#ping 204.12.1.10

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 204.12.1.10, timeout is 2 seconds:

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 36/40/56 ms

Rack1R4#

As you can see the router sees the remote host with a /32 subnet and can reach it even though it is on another network across a WAN link.

Therefore in answer to your first question you don't need to change anything on the servers, just move them as they are, configure the new router with the ip mobile arp command, redistribute the mobile routes in EIGRP with the metrics you use and you are done.

2. Correct in all statements. Don't forget to remove the EIGRP network statement from the old router and add it to the new one...

HTH

E.

LAM is a good choice for this as stated. I have used is many times. Make sure you have 'proxy-arp' on on the interface you are configuring it for. If you have 'no ip proxy-ary' on the interface, LAM will not work.

I am trying to setup Local Area Mobility without any luck. I have followed the directions on the setup of the LAM with the access lists etc. And added the ip proxy-arp. I did a show arp command on the remote router and shows up in the list.

I can not ping it from the remote router or from the main router.

Is there something I can do to locate the problem.

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community: