Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

MS Callback Between a Router and a Windows PC

I have setup the following 1720 router for Async (Pstn) callback to use with a windows PC dial-in.

Although I followed all the steps mentioned in the Cisco configuration example:

http://www.cisco.com/en/US/tech/tk801/tk36/technologies_configuration_example09186a0080094338.shtml

(Asynchronous/Modem Technology - Configuring MS Callback Between a Router and a Windows PC)

I cannot make it work. Router answers and I am connected but no callback attempt is initiated!!!

Any ideas why?

Regards.

!

version 12.2

service timestamps debug datetime msec localtime

service timestamps log datetime localtime

service password-encryption

!

hostname PLA1RAS

!

logging buffered 4096 debugging

enable password 7 XXXXXXXX

!

username test1 callback-dialstring <phone> password 0 test

username test2 <phone> password 0 test

memory-size iomem 15

aaa new-model

!

!

aaa authentication login default enable

aaa authentication login NO_AUTHEN none

aaa authentication login use-local local

aaa authentication ppp default local

aaa session-id common

ip subnet-zero

no ip domain lookup

!

ip audit notify log

ip audit po max-events 100

!

isdn switch-type basic-net3

chat-script callback ABORT ERROR ABORT BUSY "" "ATZ" OK "ATDT \T" TIMEOUT 60 CONNECT \c

chat-script offhook "" "ATH1" OK

!

!

!

interface FastEthernet0

description connected to EthernetLAN

ip address 192.168.0.1 255.255.255.0

speed auto

no keepalive

no cdp enable

!

interface Serial0

physical-layer async

no ip address

encapsulation ppp

ip tcp header-compression passive

dialer in-band

dialer rotary-group 1

dialer-group 1

async mode interactive

no keepalive

!

interface Serial1

physical-layer async

no ip address

encapsulation ppp

ip tcp header-compression passive

dialer in-band

dialer rotary-group 1

dialer-group 1

async mode interactive

no keepalive

!

interface Dialer1

description connected to Dial-inPCs(modem)

ip unnumbered FastEthernet0

encapsulation ppp

ip tcp header-compression passive

dialer in-band

dialer-group 1

peer default ip address pool IP_POOL

no cdp enable

ppp max-bad-auth 3

ppp callback accept

ppp authentication chap pap

!

ip local pool IP_POOL 192.168.0.3 192.168.0.5

ip classless

no ip http server

!

!

dialer-list 1 protocol ip permit

no cdp run

!

line con 0

line 1 2

flush-at-activation

script modem-off-hook offhook

script callback callback

login authentication use-local

modem InOut

modem autoconfigure discovery

transport input all

autoselect during-login

autoselect ppp

stopbits 1

speed 115200

flowcontrol hardware

line aux 0

line vty 0 4

!

1 ACCEPTED SOLUTION

Accepted Solutions
Silver

Re: MS Callback Between a Router and a Windows PC

Since we are using AAA in the config we have to use " aaa authorization network default local " in the config since callback is acknowledged in the authorization.

Thanks, Mak.

6 REPLIES
Silver

Re: MS Callback Between a Router and a Windows PC

Need to add the callback commands under the physical interface too.

Thanks, Mak.

Cisco Employee

Re: MS Callback Between a Router and a Windows PC

Just to add, The reason why we need to have that command under physical intreface is because the "Callback" is negotiated during LCP with physical interface before it is punted to dialer interface. So we need that command there.

Now with that command, if callback still dosen't work, we need to see the debug for following

debug dialer

debug callback

debug ppp cbcp

debug ppp nego

debug ppp auth

debug aaa authorization

New Member

Re: MS Callback Between a Router and a Windows PC

Thanks for the tip.. I did not noticed it. :-(

Now here is a part of the debugging messages I get. The interesting is that test1 user is not authorised for callback!!!

> Apr 5 16:22:51.621: Se0 DDR: Authenticated host test1 with no matching dialer map

>Apr 5 16:22:51.621: Se0 CHAP: O SUCCESS id 5 len 4

>Apr 5 16:22:51.621: Se0 MCB: Start

>Apr 5 16:22:51.621: Se0 MCB: Callback not authorized for this user test1

Any ideas? Here is a copy of all the debug messages

Apr 5 16:22:15.132: AAA/AUTHOR: config command authorization not enabled

Apr 5 16:22:15.132: AAA/AUTHOR: config command authorization not enabled

Apr 5 16:22:16: %SYS-5-CONFIG_I: Configured from console by vty1 (192.168.0.3)

Apr 5 16:22:20.816: Se0 LCP: I TERMREQ [Open] id 9 len 16 (0x05592D1E003CCD7400000000)

Apr 5 16:22:20.816: Se0 LCP: O TERMACK [Open] id 9 len 4

Apr 5 16:22:20.816: Se0 PPP: Sending Acct Event[Down] id[169]

Apr 5 16:22:20.820: Se0 IPCP: Remove link info for cef entry 192.168.0.3

Apr 5 16:22:20.820: Se0 IPCP: State is Closed

Apr 5 16:22:20.820: Se0 PPP: Phase is TERMINATING

Apr 5 16:22:20.820: Di1 IPCP: Remove route to 192.168.0.3

Apr 5 16:22:21: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0, changed state to down

Apr 5 16:22:22.824: Se0 LCP: TIMEout: State TERMsent

Apr 5 16:22:22.824: Se0 LCP: State is Closed

Apr 5 16:22:22.824: Se0 PPP: Phase is DOWN

Apr 5 16:22:22.824: Se0 PPP: Phase is ESTABLISHING, Passive Open

Apr 5 16:22:22.824: Se0 LCP: State is Listen

Apr 5 16:22:24: %LINK-5-CHANGED: Interface Serial0, changed state to reset

Apr 5 16:22:24.725: Se0 LCP: State is Closed

Apr 5 16:22:24.725: Se0 PPP: Phase is DOWN

Apr 5 16:22:29: %LINK-3-UPDOWN: Interface Serial0, changed state to down

Apr 5 16:22:39.725: Se0 DDR: re-enable timeout

Apr 5 16:22:50: %LINK-3-UPDOWN: Interface Serial0, changed state to up

Apr 5 16:22:50.317: Se0 DDR: Dialer statechange to up

Apr 5 16:22:50.317: Se0 DDR: Dialer received incoming call from

Apr 5 16:22:50.317: Se0 PPP: Using dialer call direction

Apr 5 16:22:50.317: Se0 PPP: Treating connection as a callin

Apr 5 16:22:50.317: Se0 PPP: Phase is ESTABLISHING, Passive Open

Apr 5 16:22:50.317: Se0 LCP: State is Listen

Apr 5 16:22:51.313: Se0 LCP: I CONFREQ [Listen] id 2 len 23

Apr 5 16:22:51.313: Se0 LCP: ACCM 0x00000000 (0x020600000000)

Apr 5 16:22:51.313: Se0 LCP: MagicNumber 0x6903348F (0x05066903348F)

Apr 5 16:22:51.313: Se0 LCP: PFC (0x0702)

Apr 5 16:22:51.313: Se0 LCP: ACFC (0x0802)

Apr 5 16:22:51.313: Se0 LCP: Callback 6 (0x0D0306)

Apr 5 16:22:51.317: AAA/AUTHOR (0000016C): Method list id=0 not configured. Skip author

Apr 5 16:22:51.321: Se0 PPP: Authorization NOT required

Apr 5 16:22:51.321: Se0 LCP: O CONFREQ [Listen] id 11 len 25

Apr 5 16:22:51.321: Se0 LCP: ACCM 0x000A0000 (0x0206000A0000)

Apr 5 16:22:51.321: Se0 LCP: AuthProto CHAP (0x0305C22305)

Apr 5 16:22:51.321: Se0 LCP: MagicNumber 0x119FF9B1 (0x0506119FF9B1)

Apr 5 16:22:51.321: Se0 LCP: PFC (0x0702)

Apr 5 16:22:51.321: Se0 LCP: ACFC (0x0802)

Apr 5 16:22:51.321: Se0 LCP: O CONFACK [Listen] id 2 len 23

Apr 5 16:22:51.321: Se0 LCP: ACCM 0x00000000 (0x020600000000)

Apr 5 16:22:51.325: Se0 LCP: MagicNumber 0x6903348F (0x05066903348F)

Apr 5 16:22:51.325: Se0 LCP: PFC (0x0702)

Apr 5 16:22:51.325: Se0 LCP: ACFC (0x0802)

Apr 5 16:22:51.325: Se0 LCP: Callback 6 (0x0D0306)

Apr 5 16:22:51.461: Se0 LCP: I CONFACK [ACKsent] id 11 len 25

Apr 5 16:22:51.465: Se0 LCP: ACCM 0x000A0000 (0x0206000A0000)

Apr 5 16:22:51.465: Se0 LCP: AuthProto CHAP (0x0305C22305)

Apr 5 16:22:51.465: Se0 LCP: MagicNumber 0x119FF9B1 (0x0506119FF9B1)

Apr 5 16:22:51.465: Se0 LCP: PFC (0x0702)

Apr 5 16:22:51.465: Se0 LCP: ACFC (0x0802)

Apr 5 16:22:51.465: Se0 LCP: State is Open

Apr 5 16:22:51.465: Se0 MCB: Initialize

Apr 5 16:22:51.465: Se0 MCB: Flush

Apr 5 16:22:51.465: Se0 PPP: Phase is AUTHENTICATING, by this end

Apr 5 16:22:51.465: Se0 CHAP: O CHALLENGE id 5 len 28 from "PLA1RAS"

Apr 5 16:22:51.473: Se0 LCP: I IDENTIFY [Open] id 3 len 18 magic 0x6903348F MSRASV5.10

Apr 5 16:22:51.485: Se0 LCP: I IDENTIFY [Open] id 4 len 23 magic 0x6903348F MSRAS-1-PEGASUS

Apr 5 16:22:51.613: Se0 CHAP: I RESPONSE id 5 len 27 from "test1"

Apr 5 16:22:51.613: Se0 PPP: Phase is FORWARDING, Attempting Forward

Apr 5 16:22:51.613: Se0 PPP: Phase is AUTHENTICATING, Unauthenticated User

Apr 5 16:22:51.617: Se0 PPP: Sent CHAP LOGIN Request

Apr 5 16:22:51.617: Se0 PPP: Received LOGIN Response PASS

Apr 5 16:22:51.617: Se0 PPP/AAA: Check Attr: Framed-Protocol

Apr 5 16:22:51.617: Se0 PPP/AAA: Check Attr: username

Apr 5 16:22:51.617: Se0 PPP/AAA: Check Attr: challenge

Apr 5 16:22:51.617: Se0 PPP/AAA: Check Attr: id

Apr 5 16:22:51.621: Se0 PPP/AAA: Check Attr: response

Apr 5 16:22:51.621: Se0 PPP/AAA: Check Attr: callback-dialstring

Apr 5 16:22:51.621: Se0 PPP: Phase is FORWARDING, Attempting Forward

Apr 5 16:22:51.621: Se0 PPP: Phase is AUTHENTICATING, Authenticated User

Apr 5 16:22:51.621: Se0 DDR: Remote name for test1

Apr 5 16:22:51.621: Se0 DDR: Authenticated host test1 with no matching dialer map

Apr 5 16:22:51.621: Se0 CHAP: O SUCCESS id 5 len 4

Apr 5 16:22:51.621: Se0 MCB: Start

Apr 5 16:22:51.621: Se0 MCB: Callback not authorized for this user test1

Apr 5 16:22:51.625: Se0 MCB: Newstate 0-INIT -> 2-WAIT_RESPONSE

Apr 5 16:22:51.625: Se0 PPP: O MCB Request(1) id 5 len 6

Apr 5 16:22:51.625: Se0 MCB: O 1 5 0 6 1 2

Apr 5 16:22:51.625: Se0 MCB: O Request Id 5 Callback Type None

Apr 5 16:22:51.625: Se0 PPP: Phase is CBCP

Apr 5 16:22:51.745: Se0 PPP: I MCB Response(2) id 5 len 6

Apr 5 16:22:51.745: Se0 MCB: I 2 5 0 6 1 2

Apr 5 16:22:51.745: Se0 MCB: Received response

Apr 5 16:22:51.745: Se0 MCB: Response CBK-None 1 2

Apr 5 16:22:51.745: Se0 PPP: O MCB Ack(3) id 5 len 6

Apr 5 16:22:51.745: Se0 MCB: O 3 5 0 6 1 2

Apr 5 16:22:51.749: Se0 MCB: O Ack Id 5 Callback Type None

Apr 5 16:22:51.749: Se0 MCB: No Callback negotiated; Exit

Apr 5 16:22:51.749: Se0 MCB: Flush

Apr 5 16:22:51.749: Se0 PPP: Phase is UP

Apr 5 16:22:51.749: Se0 AAA/AUTHOR/FSM: We can start IPCP

Apr 5 16:22:51.749: Se0 IPCP: O CONFREQ [Closed] id 1 len 16

Apr 5 16:22:51.749: Se0 IPCP: CompressType VJ 15 slots (0x0206002D0F00)

Apr 5 16:22:51.749: Se0 IPCP: Address 192.168.0.1 (0x03060A11BE29)

Apr 5 16:22:51.753: Se0 PPP: Process pending packets

Apr 5 16:22:51.877: Se0 CCP: I CONFREQ [Not negotiated] id 5 len 10

Apr 5 16:22:51.877: Se0 CCP: MS-PPC supported bits 0x00000001 (0x120600000001)

Apr 5 16:22:51.881: Se0 LCP: O PROTREJ [Open] id 12 len 16 protocol CCP (0x80FD0105000A120600000001)

Apr 5 16:22:51.889: Se0 IPCP: I CONFREQ [REQsent] id 6 len 28

Apr 5 16:22:51.889: Se0 IPCP: CompressType VJ 15 slots CompressSlotID (0x0206002D0F01)

Apr 5 16:22:51.893: Se0 IPCP: Address 0.0.0.0 (0x030600000000)

Apr 5 16:22:51.893: Se0 IPCP: PrimaryWINS 0.0.0.0 (0x820600000000)

Apr 5 16:22:51.893: Se0 IPCP: SecondaryWINS 0.0.0.0 (0x840600000000)

Apr 5 16:22:51.893: Se0 IPCP: Pool returned 192.168.0.3

Apr 5 16:22:51.893: Se0 AAA/AUTHOR/IPCP: no author-info for primary wins

Apr 5 16:22:51.893: Se0 AAA/AUTHOR/IPCP: no author-info for seconday wins

Apr 5 16:22:51.893: Se0 IPCP: O CONFREJ [REQsent] id 6 len 16

Apr 5 16:22:51.893: Se0 IPCP: PrimaryWINS 0.0.0.0 (0x820600000000)

Apr 5 16:22:51.897: Se0 IPCP: SecondaryWINS 0.0.0.0 (0x840600000000)

Apr 5 16:22:51.901: Se0 IPCP: I CONFACK [REQsent] id 1 len 16

Apr 5 16:22:51.901: Se0 IPCP: CompressType VJ 15 slots (0x0206002D0F00)

Apr 5 16:22:51.901: Se0 IPCP: Address 192.168.0.1 (0x03060A11BE29)

Apr 5 16:22:52.029: Se0 IPCP: I CONFREQ [ACKrcvd] id 7 len 16

Apr 5 16:22:52.029: Se0 IPCP: CompressType VJ 15 slots CompressSlotID (0x0206002D0F01)

Apr 5 16:22:52.029: Se0 IPCP: Address 0.0.0.0 (0x030600000000)

Apr 5 16:22:52.029: Se0 IPCP: O CONFNAK [ACKrcvd] id 7 len 10

Apr 5 16:22:52.029: Se0 IPCP: Address 192.168.0.3 (0x03060A11BE24)

Apr 5 16:22:52.157: Se0 IPCP: I CONFREQ [ACKrcvd] id 8 len 16

Apr 5 16:22:52.157: Se0 IPCP: CompressType VJ 15 slots CompressSlotID (0x0206002D0F01)

Apr 5 16:22:52.161: Se0 IPCP: Address 192.168.0.3 (0x03060A11BE24)

Apr 5 16:22:52.161: Se0 IPCP: O CONFACK [ACKrcvd] id 8 len 16

Apr 5 16:22:52.161: Se0 IPCP: CompressType VJ 15 slots CompressSlotID (0x0206002D0F01)

Apr 5 16:22:52.161: Se0 IPCP: Address 192.168.0.3 (0x03060A11BE24)

Apr 5 16:22:52.161: Se0 IPCP: State is Open

Apr 5 16:22:52.165: Di1 IPCP: Install route to 192.168.0.3

Apr 5 16:22:52.165: Se0 IPCP: Add link info for cef entry 192.168.0.3

Apr 5 16:22:52.165: Se0 DDR: dialer protocol up

Apr 5 16:22:52: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0, changed state to up

Apr 5 16:23:36.333: AAA/AUTHOR (0000016E): Method list id=0 not configured. Skip author

Cisco Employee

Re: MS Callback Between a Router and a Windows PC

thats the issue.. Instead of using "interface dialer 1", use individual serial interface with the following config. Basically you need to try with "no dialer in-band".

interface Serial1

ip unnumbered FastEthernet0

physical-layer async

async mode interactive

encapsulation ppp

ip tcp header-compression passive

peer default ip address pool IP_POOL

no cdp enable

ppp max-bad-auth 3

ppp callback accept

ppp authentication chap pap

with that config, its exact same as mentioned in below url..It should work.

http://www.cisco.com/en/US/products/sw/iosswrel/ps1831/products_configuration_guide_chapter09186a00800c4c58.html

Silver

Re: MS Callback Between a Router and a Windows PC

Since we are using AAA in the config we have to use " aaa authorization network default local " in the config since callback is acknowledged in the authorization.

Thanks, Mak.

New Member

Re: MS Callback Between a Router and a Windows PC

This is the final setup of my Router in case someone else wants to use it. It includes callback for both PSTN and ISDN lines. Enjoy!

!

version 12.2

service timestamps debug datetime localtime

service timestamps log datetime localtime

service password-encryption

!

hostname DIAL_IN_RAS

!

logging buffered 4096 debugging

enable secret 5

!

username isdntest callback-dialstring password 7

username pstntest callback-dialstring password 7

memory-size iomem 15

!

aaa new-model

!

!

aaa authentication login default local enable

aaa authentication login use-local local

aaa authentication ppp default local

aaa authorization network default local

aaa session-id common

ip subnet-zero

!

ip audit notify log

ip audit po max-events 100

!

isdn switch-type basic-net3

chat-script offhook "" "ATH1" OK

chat-script callback ABORT ERROR ABORT BUSY "" "ATZ" OK "ATDT \T" TIMEOUT 60 CONNECT \c

!

!

interface BRI0

no ip address

encapsulation ppp

dialer rotary-group 0

dialer-group 1

isdn switch-type basic-net3

compress mppc

no cdp enable

ppp callback accept

!

interface FastEthernet0

description connected to EthernetLAN

ip address 192.168.0.1 255.255.255.0

speed auto

no keepalive

no cdp enable

!

interface Serial0

physical-layer async

no ip address

encapsulation ppp

ip tcp header-compression passive

dialer in-band

dialer rotary-group 1

dialer-group 1

async mode dedicated

no keepalive

!

interface Serial1

physical-layer async

no ip address

encapsulation ppp

ip tcp header-compression passive

dialer in-band

dialer rotary-group 1

dialer-group 1

async mode dedicated

no keepalive

!

interface Dialer0

description connected to Dial-inPCs(ISDN)

ip unnumbered FastEthernet0

encapsulation ppp

no ip split-horizon

dialer in-band

dialer caller callback

dialer-group 1

peer default ip address pool IP_POOL

compress mppc

no cdp enable

ppp callback accept

ppp authentication chap pap

ppp multilink

!

interface Dialer1

description connected to Dial-inPCs(modem)

ip unnumbered FastEthernet0

encapsulation ppp

ip tcp header-compression passive

dialer in-band

dialer-group 1

peer default ip address pool IP_POOL

no keepalive

no cdp enable

ppp max-bad-auth 3

ppp callback accept

ppp authentication chap pap

!

ip local pool IP_POOL 192.168.0.10 192.168.0.15

ip classless

ip route 0.0.0.0 0.0.0.0

no ip http server

!

!

dialer-list 1 protocol ip permit

no cdp run

!

line con 0

line 1 2

flush-at-activation

script modem-off-hook offhook

script callback callback

login authentication use-local

modem InOut

modem autoconfigure type usr_sportster

no exec

transport input all

autoselect during-login

autoselect ppp

stopbits 1

speed 115200

flowcontrol hardware

line aux 0

line vty 0 4

!

no scheduler allocate

end

124
Views
0
Helpful
6
Replies
CreatePlease to create content