Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

MS Callback over ISDN

Hello,

I've got a 4-BRIs module on a 3640 with several dialer profile for some customers. I created a Dialer profile for a dialin access for myself with my ISDN modem on my PC.

Now I'd like to configure a MS callback between the router and the PC. But when I want to dialin, there is no callback, it's like a normal dialin connection. This is the ISDN part of my config. I think I should add somewhere map class dialer with the dialer callback-server command, but I don't want to do the callback for specific numbers, that's why I don't have any dialer string or dialer map on the dialer interface configuration:

!

username test callback-dialstring "" password <password>

!

isdn switch-type basic-net3

!

interface BRI2/0

no ip address

encapsulation ppp

dialer pool-member 1

isdn switch-type basic-net3

no cdp enable

ppp authentication chap

ppp multilink

!

interface BRI2/1

no ip address

encapsulation ppp

dialer pool-member 1

isdn switch-type basic-net3

no cdp enable

ppp authentication chap

ppp multilink

!

interface BRI2/2

no ip address

encapsulation ppp

dialer pool-member 1

isdn switch-type basic-net3

no cdp enable

ppp authentication chap

ppp multilink

!

interface BRI2/3

no ip address

encapsulation ppp

dialer pool-member 1

isdn switch-type basic-net3

no cdp enable

ppp authentication chap

ppp multilink

!

interface Dialer10

description Dialin

ip address 192.168.200.1 255.255.255.248

encapsulation ppp

no ip split-horizon

dialer pool 1

dialer remote-name test

dialer-group 2

no cdp enable

ppp callback accept

ppp authentication chap

!

dialer-list 2 protocol ip permit

!

Thanks for your help

jp

5 REPLIES
New Member

Re: MS Callback over ISDN

As you mentioned you will have to use either a static dialer map to tie a user with a callback string or use Cisco ACS as you can then allow Microsoft client to pass dial back number.

New Member

Re: MS Callback over ISDN

Hi,

If this is your complete running configuration then i doubt coz i can't see the strings generated while u connect from the modem " an auotmated string will be generated when u connect and will intialize the callback facility

Thanks

Azhar

New Member

Re: MS Callback over ISDN

Thanks for your answers,

I'll try the callback with a specific number and add a dialer string in the dialer profile.

jp

New Member

Re: MS Callback over ISDN

Hello,

I tried a basic callback config in lab with my PC and a 2500 router with IOS 12.0. I've got a problem, the PC makes the MS CALLBACK request but the router reject it (CONFREJ). I'm still not sure of my config. Can somebody tell me what's wrong with it, thanks in advance, JP

Current configuration:

!

version 12.0

service timestamps debug uptime

service timestamps log uptime

no service password-encryption

!

hostname router

!

enable password cisco

!

username test callback-dialstring 839 password 0 test

ip subnet-zero

no ip finger

isdn switch-type basic-net3

!

!

interface Ethernet0

ip address 10.71.0.15 255.255.0.0

no ip directed-broadcast

!

!

interface BRI0

no ip address

no ip directed-broadcast

encapsulation ppp

dialer pool-member 1

isdn switch-type basic-net3

ppp authentication chap

ppp multilink

!

interface Dialer1

ip address 192.168.2.2 255.255.255.248

no ip directed-broadcast

encapsulation ppp

dialer remote-name test

dialer enable-timeout 5

dialer string 839 class dial1

dialer pool 1

dialer-group 1

ppp callback accept

ppp authentication chap

!

ip classless

!

!

map-class dialer dial1

dialer callback-server username

dialer-list 1 protocol ip permit

!

line con 0

login

transport input none

line aux 0

line vty 0 4

password cisco

login

!

end

DEBUG

router#sh debug

Dial on demand:

Dial on demand events debugging is on

PPP:

PPP protocol negotiation debugging is on

PPP Callback Control Protocol debugging is on

ISDN:

ISDN events debugging is on

ISDN Q931 packets debugging is on

Callback:

Callback activity debugging is on

04:42:58: ISDN BR0: Recvd MPH_IIC_IND from L1

04:42:59: ISDN BR0: L1 is IF_ACTIVE

04:42:59: ISDN BR0: RX <- SETUP pd = 8 callref = 0x60

04:42:59: Sending Complete

04:42:59: Bearer Capability i = 0x8890

04:42:59: Channel ID i = 0x89

04:42:59: Calling Party Number i = 0x0181, '839'

04:42:59: Called Party Number i = 0x81, '886'

04:42:59: ISDN BR0: RX <- SETUP pd = 8 callref = 0x61

04:42:59: Sending Complete

04:42:59: Bearer Capability i = 0x8890

04:42:59: Channel ID i = 0x8A

04:42:59: Calling Party Number i = 0x0181, '839'

04:42:59: Called Party Number i = 0x81, '886'

04:42:59: ISDN BR0: Incoming call id = 0x2F

04:42:59: %ISDN-6-LAYER2UP: Layer 2 for Interface BR0, TEI 74 changed to up

04:42:59: ISDN BR0: received HOST_INCOMING_CALL call_id 0x2F

04:42:59: ISDN BR0: Event: Received a call from 839 on B1 at 64 Kb/s

04:42:59: ISDN BR0: Event: Accepting the call id 0x2F

04:42:59: %LINK-3-UPDOWN: Interface BRI0:1, changed state to up

04:42:59: BR0:1 PPP: Treating connection as a callin

04:42:59: BR0:1 PPP: Phase is ESTABLISHING, Passive Open

04:42:59: BR0:1 LCP: State is Listen

04:42:59: ISDN BR0: Incoming call id = 0x30

04:42:59: ISDN BR0: received HOST_INCOMING_CALL call_id 0x30

04:42:59: ISDN BR0: Event: Received a call from 839 on B2 at 64 Kb/s

04:42:59: ISDN BR0: Event: Accepting the call id 0x30

04:42:59: %LINK-3-UPDOWN: Interface BRI0:2, changed state to up

04:42:59: %ISDN-6-CONNECT: Interface BRI0:1 is now connected to 839

04:42:59: BR0:2 PPP: Treating connection as a callin

04:42:59: BR0:2 PPP: Phase is ESTABLISHING, Passive Open

04:42:59: BR0:2 LCP: State is Listen

04:42:59: L3: Multi NLCB DL_EST cid 0x2F cr 0xE0 ev 0x81 ces 1 dsl 0

04:42:59: U0_BadMsg: CC_REL_CONF sent cid 0x2F cr 0xE0 ev 0x81 ces 1 dsl 0

04:42:59: ISDN BR0: received HOST_DISCONNECT_ACK call_id 0x2F

04:42:59: %ISDN-6-CONNECT: Interface BRI0:2 is now connected to 839

04:42:59: %LINK-3-UPDOWN: Interface BRI0:1, changed state to down

04:42:59: BR0:1 LCP: State is Closed

04:42:59: BR0:1 PPP: Phase is DOWN

04:42:59: BR0:1 DDR: disconnecting call

04:42:59: ISDN BR0: TX -> CONNECT pd = 8 callref = 0xE1

04:42:59: ISDN BR0: RX <- CONNECT_ACK pd = 8 callref = 0x61

04:42:59: BR0:2 LCP: I CONFREQ [Listen] id 0 len 30

04:42:59: BR0:2 LCP: MagicNumber 0x0EF262D0 (0x05060EF262D0)

04:42:59: BR0:2 LCP: PFC (0x0702)

04:42:59: BR0:2 LCP: ACFC (0x0802)

04:42:59: BR0:2 LCP: Callback 6 (0x0D0306)

04:42:59: BR0:2 LCP: MRRU 1614 (0x1104064E)

04:42:59: BR0:2 LCP: EndpointDisc 3 00d0.592f.7e09 (0x13090300D0592F7E09)

04:42:59: BR0:2 LCP: O CONFREQ [Listen] id 17 len 32

04:42:59: BR0:2 LCP: AuthProto CHAP (0x0305C22305)

04:42:59: BR0:2 LCP: MagicNumber 0x010F555A (0x0506010F555A)

04:42:59: BR0:2 LCP: MRRU 1524 (0x110405F4)

04:42:59: BR0:2 LCP: EndpointDisc 1 Local (0x130D016E6578746972616F6E65)

04:42:59: BR0:2 LCP: O CONFREJ [Listen] id 0 len 7

04:42:59: BR0:2 LCP: Callback 6 (0x0D0306)

04:42:59: BR0:2 LCP: I CONFACK [REQsent] id 17 len 32

04:42:59: BR0:2 LCP: AuthProto CHAP (0x0305C22305)

04:42:59: BR0:2 LCP: MagicNumber 0x010F555A (0x0506010F555A)

04:42:59: BR0:2 LCP: MRRU 1524 (0x110405F4)

04:42:59: BR0:2 LCP: EndpointDisc 1 Local (0x130D016E6578746972616F6E65)

04:42:59: BR0:2 LCP: I CONFREQ [ACKrcvd] id 1 len 27

04:42:59: BR0:2 LCP: MagicNumber 0x0EF262D0 (0x05060EF262D0)

04:42:59: BR0:2 LCP: PFC (0x0702)

04:42:59: BR0:2 LCP: ACFC (0x0802)

04:42:59: BR0:2 LCP: MRRU 1614 (0x1104064E)

04:42:59: BR0:2 LCP: EndpointDisc 3 00d0.592f.7e09 (0x13090300D0592F7E09)

04:42:59: BR0:2 LCP: O CONFACK [ACKrcvd] id 1 len 27

04:42:59: BR0:2 LCP: MagicNumber 0x0EF262D0 (0x05060EF262D0)

04:42:59: BR0:2 LCP: PFC (0x0702)

04:42:59: BR0:2 LCP: ACFC (0x0802)

04:42:59: BR0:2 LCP: MRRU 1614 (0x1104064E)

04:42:59: BR0:2 LCP: EndpointDisc 3 00d0.592f.7e09 (0x13090300D0592F7E09)

04:42:59: BR0:2 LCP: State is Open

04:42:59: BR0:2 MCB: Initialize

04:42:59: BR0:2 PPP: Phase is AUTHENTICATING, by this end

04:42:59: BR0:2 CHAP: O CHALLENGE id 14 len 31 from "router"

04:42:59: BR0:2 LCP: I IDENTIFY [Open] id 2 len 18 magic 0x0EF262D0 MSRASV5.00

04:42:59: BR0:2 LCP: I IDENTIFY [Open] id 3 len 22 magic 0x0EF262D0 MSRAS-1-CONIJP

04:42:59: BR0:2 CHAP: I RESPONSE id 14 len 25 from "test"

04:42:59: BR0:2 CHAP: O SUCCESS id 14 len 4

04:42:59: %DIALER-6-BIND: Interface BR0:2 bound to profile Di1

04:42:59: BR0:2 PPP: Phase is VIRTUALIZED

04:42:59: Vi1 MCB: Initialize

04:42:59: Vi1 PPP: Phase is DOWN, Setup

04:42:59: %DIALER-6-BIND: Interface Vi1 bound to profile Di1

04:42:59: BR0:2 CCP: Packet buffered while building MLP bundle interface

04:42:59: BR0:2 IPCP: Packet buffered while building MLP bundle interface

04:42:59: %LINK-3-UPDOWN: Interface Virtual-Access1, changed state to up

04:42:59: Vi1 PPP: Treating connection as a callin

04:42:59: Vi1 PPP: Phase is ESTABLISHING, Passive Open

04:42:59: Vi1 LCP: State is Listen

04:42:59: Vi1 MCB: Initialize

04:42:59: Vi1 PPP: Phase is UP

04:42:59: Vi1 IPCP: O CONFREQ [Closed] id 1 len 10

04:42:59: Vi1 IPCP: Address 192.168.2.2 (0x0306C0A80202)

04:42:59: Vi1 CDPCP: O CONFREQ [Closed] id 1 len 4

04:42:59: Vi1 PPP: Pending ncpQ size is 2

04:42:59: BR0:2 CCP: Redirect packet to Vi1

04:42:59: Vi1 CCP: I CONFREQ [Not negotiated] id 4 len 10

04:42:59: Vi1 CCP: MS-PPC supported bits 0x00000001 (0x120600000001)

04:42:59: Vi1 LCP: O PROTREJ [Open] id 1 len 16 protocol CCP (0x80FD0104000A1206

00000001)

04:42:59: BR0:2 IPCP: Redirect packet to Vi1

04:42:59: Vi1 IPCP: I CONFREQ [REQsent] id 5 len 40

04:42:59: Vi1 IPCP: CompressType VJ 15 slots CompressSlotID (0x0206002D0F01)

04:42:59: Vi1 IPCP: Address 192.168.2.1 (0x0306C0A80201)

04:42:59: Vi1 IPCP: PrimaryDNS 0.0.0.0 (0x810600000000)

04:42:59: Vi1 IPCP: PrimaryWINS 0.0.0.0 (0x820600000000)

04:42:59: Vi1 IPCP: SecondaryDNS 0.0.0.0 (0x830600000000)

04:42:59: Vi1 IPCP: SecondaryWINS 0.0.0.0 (0x840600000000)

04:42:59: Vi1 IPCP: O CONFREJ [REQsent] id 5 len 34

04:42:59: Vi1 IPCP: CompressType VJ 15 slots CompressSlotID (0x0206002D0F01)

04:42:59: Vi1 IPCP: PrimaryDNS 0.0.0.0 (0x810600000000)

04:42:59: Vi1 IPCP: PrimaryWINS 0.0.0.0 (0x820600000000)

04:42:59: Vi1 IPCP: SecondaryDNS 0.0.0.0 (0x830600000000)

04:42:59: Vi1 IPCP: SecondaryWINS 0.0.0.0 (0x840600000000)

04:42:59: Vi1 IPCP: I CONFACK [REQsent] id 1 len 10

04:42:59: Vi1 IPCP: Address 192.168.2.2 (0x0306C0A80202)

04:42:59: BR0:2 LCP: I PROTREJ [Open] id 6 len 10 protocol CDPCP (0x820701010004

)

04:42:59: Vi1 CDPCP: State is Closed

04:42:59: Vi1 IPCP: I CONFREQ [ACKrcvd] id 7 len 10

04:42:59: Vi1 IPCP: Address 192.168.2.1 (0x0306C0A80201)

04:42:59: Vi1 IPCP: O CONFACK [ACKrcvd] id 7 len 10

04:42:59: Vi1 IPCP: Address 192.168.2.1 (0x0306C0A80201)

04:42:59: Vi1 IPCP: State is Open

04:42:59: Vi1 DDR: dialer protocol up

04:42:59: Vi1 DDR: callback server and dialer protocol up ?- must be mlp

04:42:59: Di1 IPCP: Install route to 192.168.2.1

04:43:00: %LINEPROTO-5-UPDOWN: Line protocol on Interface BRI0:2, changed state

to up

04:43:00: %LINEPROTO-5-UPDOWN: Line protocol on Interface Virtual-Access1, chang

ed state to up

New Member

Re: MS Callback over ISDN

DEBUG part 2:

04:43:02: ISDN BR0: RX <- SETUP pd = 8 callref = 0x60

04:43:02: Sending Complete

04:43:02: Bearer Capability i = 0x8890

04:43:02: Channel ID i = 0x89

04:43:02: Calling Party Number i = 0x0181, '839'

04:43:02: Called Party Number i = 0x81, '886'

04:43:02: ISDN BR0: Incoming call id = 0x31

04:43:02: ISDN BR0: received HOST_INCOMING_CALL call_id 0x31

04:43:02: ISDN BR0: Event: Received a call from 839 on B1 at 64 Kb/s

04:43:02: ISDN BR0: Event: Accepting the call id 0x31

04:43:02: %LINK-3-UPDOWN: Interface BRI0:1, changed state to up

04:43:02: %ISDN-6-CONNECT: Interface BRI0:1 is now connected to 839

04:43:02: BR0:1 PPP: Treating connection as a callin

04:43:02: BR0:1 PPP: Phase is ESTABLISHING, Passive Open

04:43:02: BR0:1 LCP: State is Listen

04:43:02: ISDN BR0: TX -> CONNECT pd = 8 callref = 0xE0

04:43:03: ISDN BR0: RX <- CONNECT_ACK pd = 8 callref = 0x60

04:43:04: BR0:1 LCP: TIMEout: State Listen

04:43:04: BR0:1 LCP: O CONFREQ [Listen] id 51 len 32

04:43:04: BR0:1 LCP: AuthProto CHAP (0x0305C22305)

04:43:04: BR0:1 LCP: MagicNumber 0x010F6B16 (0x0506010F6B16)

04:43:04: BR0:1 LCP: MRRU 1524 (0x110405F4)

04:43:04: BR0:1 LCP: EndpointDisc 1 Local (0x130D016E6578746972616F6E65)

04:43:06: BR0:1 LCP: I CONFREQ [REQsent] id 0 len 30

04:43:06: BR0:1 LCP: MagicNumber 0x64AB047B (0x050664AB047B)

04:43:06: BR0:1 LCP: PFC (0x0702)

04:43:06: BR0:1 LCP: ACFC (0x0802)

04:43:06: BR0:1 LCP: Callback 6 (0x0D0306)

04:43:06: BR0:1 LCP: MRRU 1614 (0x1104064E)

04:43:06: BR0:1 LCP: EndpointDisc 3 00d0.592f.7e09 (0x13090300D0592F7E09)

04:43:06: BR0:1 LCP: O CONFREJ [REQsent] id 0 len 7

04:43:06: BR0:1 LCP: Callback 6 (0x0D0306)

04:43:06: BR0:1 LCP: I CONFACK [REQsent] id 51 len 32

04:43:06: BR0:1 LCP: AuthProto CHAP (0x0305C22305)

04:43:06: BR0:1 LCP: MagicNumber 0x010F6B16 (0x0506010F6B16)

04:43:06: BR0:1 LCP: MRRU 1524 (0x110405F4)

04:43:06: BR0:1 LCP: EndpointDisc 1 Local (0x130D016E6578746972616F6E65)

04:43:06: BR0:1 LCP: I CONFREQ [ACKrcvd] id 1 len 27

04:43:06: BR0:1 LCP: MagicNumber 0x64AB047B (0x050664AB047B)

04:43:06: BR0:1 LCP: PFC (0x0702)

04:43:06: BR0:1 LCP: ACFC (0x0802)

04:43:06: BR0:1 LCP: MRRU 1614 (0x1104064E)

04:43:06: BR0:1 LCP: EndpointDisc 3 00d0.592f.7e09 (0x13090300D0592F7E09)

04:43:06: BR0:1 LCP: O CONFACK [ACKrcvd] id 1 len 27

04:43:06: BR0:1 LCP: MagicNumber 0x64AB047B (0x050664AB047B)

04:43:06: BR0:1 LCP: PFC (0x0702)

04:43:06: BR0:1 LCP: ACFC (0x0802)

04:43:06: BR0:1 LCP: MRRU 1614 (0x1104064E)

04:43:06: BR0:1 LCP: EndpointDisc 3 00d0.592f.7e09 (0x13090300D0592F7E09)

04:43:06: BR0:1 LCP: State is Open

04:43:06: BR0:1 MCB: Initialize

04:43:06: BR0:1 PPP: Phase is AUTHENTICATING, by this end

04:43:06: BR0:1 CHAP: O CHALLENGE id 14 len 31 from "router"

04:43:06: BR0:1 LCP: I IDENTIFY [Open] id 2 len 18 magic 0x64AB047B MSRASV5.00

04:43:06: BR0:1 LCP: I IDENTIFY [Open] id 3 len 22 magic 0x64AB047B MSRAS-1-CONI

JP

04:43:06: BR0:1 CHAP: I RESPONSE id 14 len 25 from "test"

04:43:06: BR0:1 CHAP: O SUCCESS id 14 len 4

04:43:06: %DIALER-6-BIND: Interface BR0:1 bound to profile Di1

04:43:06: BR0:1 PPP: Phase is VIRTUALIZED

04:43:07: %LINEPROTO-5-UPDOWN: Line protocol on Interface BRI0:1, changed state

to up

04:43:08: %ISDN-6-CONNECT: Interface BRI0:1 is now connected to 839 test

04:43:19: Vi1 PPP: Outbound cdp packet dropped, CDPCP is Closed [starting negoti

ations]

04:43:19: Vi1 CDPCP: State is Closed

04:43:19: Vi1 CDPCP: TIMEout: State Closed

04:43:19: Vi1 CDPCP: State is Listen

163
Views
0
Helpful
5
Replies
CreatePlease login to create content