Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

MultiCast Across Multiple VLANs

Environment:

Core - C6509 w/ Sup720 Layer3 / Multicast on

Client - C3560 Layer2 / Multicast on

See diagram

I have setup up a VLAN for my lab bench (VLAN211). Multicast for Symantec Ghost v.8.x will not work on this VLAN. If I change the port on the client switch from VLAN211 to VLAN23 (one my other client networks) then everything works fine.

From the 6509:

ip multicast-routing

mls ip multicast flow-stat-timer 9

ip pim send-rp-announce Vlan11 scope 16 group-list 1

ip pim send-rp-discovery scope 16

access-list 1 permit 239.0.0.0 0.255.255.255

interface Vlan11

description Backbone_Servers

ip address 10.1.1.3 255.255.255.0

ip helper-address 10.1.1.11

ip helper-address 10.1.1.111

ip helper-address 10.1.1.66

no ip redirects

ip pim sparse-dense-mode

interface Vlan23

description School_House

ip address 10.2.3.2 255.255.255.0

ip helper-address 10.1.1.11

ip helper-address 10.1.1.111

ip helper-address 10.1.1.66

no ip redirects

ip pim sparse-dense-mode

interface Vlan211

description IT_Bench

ip address 10.2.11.2 255.255.255.0

ip helper-address 10.1.1.11

ip helper-address 10.1.1.111

ip helper-address 10.1.1.66

no ip redirects

ip pim sparse-dense-mode

From the 3560 Client switch this port works:

interface FastEthernet0/1

switchport access vlan 23

switchport trunk encapsulation dot1q

switchport trunk native vlan 23

switchport trunk allowed vlan 23,33

switchport mode trunk

service-policy input WMT-POLICY

priority-queue out

no mdix auto

spanning-tree portfast

From the 3560 Client switch this port does NOT work:

interface FastEthernet0/3

switchport access vlan 211

switchport trunk encapsulation dot1q

switchport trunk native vlan 211

switchport trunk allowed vlan 211,311

switchport mode trunk

service-policy input WMT-POLICY

priority-queue out

no mdix auto

spanning-tree portfast

Anyone got any suggestions?

2 REPLIES
Purple

Re: MultiCast Across Multiple VLANs

Did you create the layer 2 vlan on the 6500 , I see the layer 3 SVI created but don't see a layer 2 definition. If do a "show vlan " on the 6500 does vlan 211 show up and in the active state ???

New Member

Re: MultiCast Across Multiple VLANs

It has been created. A 'show vlan' on the 6509 reports:

VLAN Name Status Ports

---- -------------------------------- --------- -----

23 School_House active

211 IT_Bench active

VLAN Type SAID MTU Parent RingNo BridgeNo Stp BrdgMode Trans1 Trans2

---- ----- ---------- ----- ------ ------ -------- ---- -------- ------ ------

23 enet 100023 1500 - - - - - 0 0

211 enet 100211 1500 - - - - - 0 0

I listed only the two I referenced originally -- 23 works and 211 does not work.

254
Views
0
Helpful
2
Replies
CreatePlease to create content