Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Multicast - Is the cisco web page wrong? help required

on page

http://www.cisco.com/en/US/tech/tk828/tk363/technologies_white_paper09186a00800d6b63.shtml

this does not look correct. Please can someone at Cisco confirm this. (check the auto-rp announce/discovery loopbacks)

On my config, i was going to use the folloiwng

discovery, use an individual loopback/ip address and for the announce use my anycast address)

----------------------------------------------------

my config without the msdp config

ROUTER 1

interface Loopback0

description MSDP/Management Interface

ip address 10.249.1.8 255.255.255.255

ip pim sparse-dense-mode

!

no int lo 1

interface Loopback1

description Anycast RP Interface

ip address 10.249.2.8 255.255.255.255

ip pim sparse-dense-mode

!

interface Loopback3

description Sink RP Interface

ip address 1.1.1.1 255.255.255.255

ip pim sparse-dense-mode

!

ip pim rp-address 1.1.1.1 20

!

access-list 20 deny 224.0.1.39

access-list 20 deny 224.0.1.40

access-list 20 permit 224.0.0.0 15.255.255.255

!

ip pim send-rp-announce loopback1 scope 15 group-list 10

ip pim send-rp-discovery loopback0 scope 15

!

ROUTER 2

interface Loopback0

description MSDP/Management Interface

ip address 10.249.51.8 255.255.255.255

ip pim sparse-dense-mode

!

interface Loopback1

description Anycast RP Interface

ip address 10.249.2.8 255.255.255.255

ip pim sparse-dense-mode

!

!

interface Loopback3

description Sink RP Interface

ip address 1.1.1.1 255.255.255.255

ip pim sparse-dense-mode

!

ip pim rp-address 1.1.1.1 20

!

access-list 20 deny 224.0.1.39

access-list 20 deny 224.0.1.40

access-list 20 permit 224.0.0.0 15.255.255.255

!

ip pim send-rp-announce loopback1 scope 15 group-list 10

ip pim send-rp-discovery loopback0 scope 15

!

-------------------------------------------

the cisco config

Router 72a

ip multicast-routing

interface Loopback0

ip address 20.0.0.3 255.255.255.255

ip pim sparse-dense-mode

interface Loopback1

ip address 20.0.0.1 255.255.255.255

ip pim sparse-dense-mode

interface FastEthernet0/0

ip address 20.0.1.3 255.255.255.0

ip pim sparse-dense-mode

interface Ethernet3/1

ip address 20.0.3.3 255.255.255.0

ip pim sparse-dense-mode

interface Ethernet3/2

ip address 20.0.2.3 255.255.255.0

ip pim sparse-dense-mode

ip pim rp-address 1.1.1.1 20

ip pim send-rp-announce Loopback1 scope 32 group-list 10

ip pim send-rp-discovery Loopback1 scope 32

ip msdp peer 20.0.0.2 connect-source Loopback0

ip msdp mesh-group anycast 20.0.0.2

ip msdp originator-id Loopback0

access-list 10 permit 224.0.0.0 15.255.255.255

access-list 20 deny 224.0.1.39

access-list 20 deny 224.0.1.40

access-list 20 permit 224.0.0.0 15.255.255.255

Router 75a

ip multicast-routing distributed

interface Loopback0

ip address 20.0.0.2 255.255.255.255

ip pim sparse-dense-mode

interface Loopback1

ip address 20.0.0.1 255.255.255.255

ip pim sparse-dense-mode

interface FastEthernet0/0/0

ip address 20.0.1.2 255.255.255.0

ip pim sparse-dense-mode

ip route-cache distributed

interface FastEthernet0/1/0

ip address 20.0.6.2 255.255.255.0

ip pim sparse-dense-mode

ip route-cache distributed

ip pim rp-address 1.1.1.1 20

ip pim send-rp-announce Loopback0 scope 32 group-list 10

ip pim send-rp-discovery Loopback0 scope 32

ip msdp peer 20.0.0.3 connect-source Loopback0

ip msdp mesh-group anycast 20.0.0.3

ip msdp originator-id Loopback0

access-list 10 permit 224.0.0.0 15.255.255.255

access-list 20 deny 224.0.1.39

access-list 20 deny 224.0.1.40

access-list 20 permit 224.0.0.0 15.255.255.255

1 ACCEPTED SOLUTION

Accepted Solutions
Cisco Employee

Re: Multicast - Is the cisco web page wrong? help required

The non-RP routers will only keep track of one discovery message. You will never see two info sources for the same RP.

I don't think that using the unique IP address for the sending the Discovery message will buy you much since the end result will still be the utilization of a AnycastRP.

Hope this help,

Harold Ritter
Sr. Technical Leader
CCIE 4168 (R&S, SP)
harold@cisco.com
México móvil: +52 1 55 8312 4915
Cisco México 
Paseo de la Reforma 222 Piso 19
Cuauhtémoc, Juárez
Ciudad de México, 06600
México
7 REPLIES
Cisco Employee

Re: Multicast - Is the cisco web page wrong? help required

The example is correct and will work fine. You can use the same IP address for both the announce and discovery processes. The other loopback is unique and has to be used for your routing protocol, MSDP or anything else that requires the loopback address.

Hope this helps.

Harold Ritter
Sr. Technical Leader
CCIE 4168 (R&S, SP)
harold@cisco.com
México móvil: +52 1 55 8312 4915
Cisco México 
Paseo de la Reforma 222 Piso 19
Cuauhtémoc, Juárez
Ciudad de México, 06600
México
New Member

Re: Multicast - Is the cisco web page wrong? help required

It does, thx,

but when you do a show ip pim rp map i would assume that the info source ie, the mapping agent, it would be prudent to use the unique ip address of the MSDP peer interface rather than the ip address of the RP? just so that you can see that two routers with different addresses are the source of the group-to-rp mapping?

Like the BSR entry below?

Please can you clarify that this is possible and if it is good practise.

Really appreciate the help on this :)))))

Ken

R01>sh ip pim rp map

PIM Group-to-RP Mappings

This system is a candidate RP (v2)

Group(s) 228.1.0.1/32

RP 10.221.254.17 (?), v2

Info source: 10.221.254.17 (?), via bootstrap

Uptime: 7w0d, expires: 00:01:48

RP 10.221.254.17 (?), v2

Info source: 10.221.254.18 (?), via bootstrap

Uptime: 7w0d, expires: 00:01:48

Cisco Employee

Re: Multicast - Is the cisco web page wrong? help required

I believe it should work. Quite frankly, I personally haven't seen too many people using Anycast RP in conjunction with AutoRP. Most of the Anycast RP deployments I have seen so far were with Static RP.

Harold Ritter
Sr. Technical Leader
CCIE 4168 (R&S, SP)
harold@cisco.com
México móvil: +52 1 55 8312 4915
Cisco México 
Paseo de la Reforma 222 Piso 19
Cuauhtémoc, Juárez
Ciudad de México, 06600
México
New Member

Re: Multicast - Is the cisco web page wrong? help required

Can you just confirm one last point for me please.

i have

rtr1---------rtr2

both are RP&MAs

off rtr1, i have 2600-r01 and off rtr2 i have 2600-r02

now the 2600 routers receive an auto-rp update from rtr1 with the the rp of .25 and an info source of .8, then the other auto-rp update comes in with an rp of .25 and an info source of

rtr2

!

interface Loopback0

descriptionMSDP Interface

ip address 30.96.100.8 255.255.255.255

ip pim sparse-dense-mode

!

interface Loopback1

description RP Interface

ip address 30.96.100.25 255.255.255.255

ip pim sparse-dense-mode

!

ip pim send-rp-announce Loopback1 scope 15 group-list 11

ip pim send-rp-discovery Loopback0 scope 15

!

rtr2

!

interface Loopback0

description MSDP Interface

ip address 30.96.100.9 255.255.255.255

ip pim sparse-dense-mode

!

interface Loopback1

description RP Interface

ip address 30.96.100.25 255.255.255.255

ip pim sparse-dense-mode

!

ip pim send-rp-announce Loopback1 scope 15 group-list 11

ip pim send-rp-discovery Loopback0 scope 15

It looks as if the auto-rp update (every 60 secs) from one info source overwrites the other update, and does not add to the group-to-rp mapping table on the 2600 routers.

Can you confirm that this is correct, and if this is the way that this is ment to work, I may as well use the anycast-rp interface for the auto-rp discovery (info-source) command.

2600-r01#

4w6d: Auto-RP: Received RP-discovery, from 10.96.100.8, RP_cnt 1, ht 180

4w6d: Auto-RP: Update (239.254.1.10/32, RP:10.96.100.25), PIMv2 v1

4w6d: Auto-RP: Update (239.255.0.1/32, RP:10.96.100.25), PIMv2 v1

4w6d: Auto-RP: Update (239.255.0.2/32, RP:10.96.100.25), PIMv2 v1

4w6d: Auto-RP: Update (239.255.0.3/32, RP:10.96.100.25), PIMv2 v1

4w6d: Auto-RP: Update (239.255.0.4/32, RP:10.96.100.25), PIMv2 v1

4w6d: Auto-RP: Update (239.255.0.5/32, RP:10.96.100.25), PIMv2 v1

4w6d: Auto-RP: Update (239.255.0.6/32, RP:10.96.100.25), PIMv2 v1

4w6d: Auto-RP: Received RP-discovery, from 10.96.100.8, RP_cnt 1, ht 180

4w6d: Auto-RP: Update (239.254.1.10/32, RP:10.96.100.25), PIMv2 v1

4w6d: Auto-RP: Update (239.255.0.1/32, RP:10.96.100.25), PIMv2 v1

4w6d: Auto-RP: Update (239.255.0.2/32, RP:10.96.100.25), PIMv2 v1

4w6d: Auto-RP: Update (239.255.0.3/32, RP:10.96.100.25), PIMv2 v1

4w6d: Auto-RP: Update (239.255.0.4/32, RP:10.96.100.25), PIMv2 v1

4w6d: Auto-RP: Update (239.255.0.5/32, RP:10.96.100.25), PIMv2 v1

4w6d: Auto-RP: Update (239.255.0.6/32, RP:10.96.100.25), PIMv2 v1

PIM Group-to-RP Mappings

Group(s) 239.254.1.10/32

RP 10.96.100.25 (?), v2v1

Info source: 10.96.100.8 (?), elected via Auto-RP

Uptime: 00:23:57, expires: 00:02:51

Group(s) 239.255.0.1/32

RP 10.96.100.25 (?), v2v1

Info source: 10.96.100.8 (?), elected via Auto-RP

Uptime: 00:23:57, expires: 00:02:52

Group(s) 239.255.0.2/32

RP 10.96.100.25 (?), v2v1

Info source: 10.96.100.8 (?), elected via Auto-RP

Uptime: 00:23:57, expires: 00:02:56

Group(s) 239.255.0.3/32

RP 10.96.100.25 (?), v2v1

Info source: 10.96.100.8 (?), elected via Auto-RP

Uptime: 00:23:57, expires: 00:02:51

Group(s) 239.255.0.4/32

RP 10.96.100.25 (?), v2v1

Info source: 10.96.100.8 (?), elected via Auto-RP

Uptime: 00:23:57, expires: 00:02:52

Group(s) 239.255.0.5/32

RP 10.96.100.25 (?), v2v1

Info source: 10.96.100.8 (?), elected via Auto-RP

Uptime: 00:23:57, expires: 00:02:55

Group(s) 239.255.0.6/32

RP 10.96.100.25 (?), v2v1

Info source: 10.96.100.8 (?), elected via Auto-RP

Uptime: 00:23:57, expires: 00:02:53

2600-r01#

2600-r01#

4w6d: Auto-RP: Received RP-discovery, from 10.96.100.9, RP_cnt 1, ht 180

4w6d: Auto-RP: Update (239.254.1.10/32, RP:10.96.100.25), PIMv2 v1

4w6d: Auto-RP: Update (239.255.0.1/32, RP:10.96.100.25), PIMv2 v1

4w6d: Auto-RP: Update (239.255.0.2/32, RP:10.96.100.25), PIMv2 v1

4w6d: Auto-RP: Update (239.255.0.3/32, RP:10.96.100.25), PIMv2 v1

4w6d: Auto-RP: Update (239.255.0.4/32, RP:10.96.100.25), PIMv2 v1

4w6d: Auto-RP: Update (239.255.0.5/32, RP:10.96.100.25), PIMv2 v1

4w6d: Auto-RP: Update (239.255.0.6/32, RP:10.96.100.25), PIMv2 v1

4w6d: Auto-RP: Received RP-discovery, from 10.96.100.9, RP_cnt 1, ht 180

4w6d: Auto-RP: Update (239.254.1.10/32, RP:10.96.100.25), PIMv2 v1

4w6d: Auto-RP: Update (239.255.0.1/32, RP:10.96.100.25), PIMv2 v1

4w6d: Auto-RP: Update (239.255.0.2/32, RP:10.96.100.25), PIMv2 v1

4w6d: Auto-RP: Update (239.255.0.3/32, RP:10.96.100.25), PIMv2 v1

4w6d: Auto-RP: Update (239.255.0.4/32, RP:10.96.100.25), PIMv2 v1

4w6d: Auto-RP: Update (239.255.0.5/32, RP:10.96.100.25), PIMv2 v1

4w6d: Auto-RP: Update (239.255.0.6/32, RP:10.96.100.25), PIMv2 v1

2600-r01#

2600-r01#

2600-r01#sh ip pim rp map

PIM Group-to-RP Mappings

Group(s) 239.254.1.10/32

RP 10.96.100.25 (?), v2v1

Info source: 10.96.100.9 (?), elected via Auto-RP

Uptime: 00:06:33, expires: 00:02:13

Group(s) 239.255.0.1/32

RP 10.96.100.25 (?), v2v1

Info source: 10.96.100.9 (?), elected via Auto-RP

Uptime: 00:06:33, expires: 00:02:11

Group(s) 239.255.0.2/32

RP 10.96.100.25 (?), v2v1

Info source: 10.96.100.9 (?), elected via Auto-RP

Uptime: 00:06:33, expires: 00:02:13

Group(s) 239.255.0.3/32

RP 10.96.100.25 (?), v2v1

Info source: 10.96.100.9 (?), elected via Auto-RP

Uptime: 00:06:33, expires: 00:02:10

Group(s) 239.255.0.4/32

RP 10.96.100.25 (?), v2v1

Info source: 10.96.100.9 (?), elected via Auto-RP

Uptime: 00:06:33, expires: 00:02:09

Group(s) 239.255.0.5/32

RP 10.96.100.25 (?), v2v1

Info source: 10.96.100.9 (?), elected via Auto-RP

Uptime: 00:06:33, expires: 00:02:09

Group(s) 239.255.0.6/32

RP 10.96.100.25 (?), v2v1

Info source: 10.96.100.9 (?), elected via Auto-RP

Uptime: 00:06:33, expires: 00:02:10

2600-r01#

Cisco Employee

Re: Multicast - Is the cisco web page wrong? help required

The non-RP routers will only keep track of one discovery message. You will never see two info sources for the same RP.

I don't think that using the unique IP address for the sending the Discovery message will buy you much since the end result will still be the utilization of a AnycastRP.

Hope this help,

Harold Ritter
Sr. Technical Leader
CCIE 4168 (R&S, SP)
harold@cisco.com
México móvil: +52 1 55 8312 4915
Cisco México 
Paseo de la Reforma 222 Piso 19
Cuauhtémoc, Juárez
Ciudad de México, 06600
México
New Member

Re: Multicast - Is the cisco web page wrong? help required

Just testing with BSR and it seems to take the highest mapping agent. If you have two mapping agents using BSR, is this normal.

Auto-RP seems fine.

Many many thx for you help. It has solved my issue.

New Member

Re: Multicast - Is the cisco web page wrong? help required

sorry, just read in the multicast book and only one BSR is active at any time :))

pls disregard my question :))

158
Views
0
Helpful
7
Replies