Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

Multicasting - Ghost Multicast Server Problems

I know that this topic has appeared in these forums before because I have already looked through most of the answers for direction. I am still stuck so I am posting this question. Is there any limitation in the 6500 series Sup 1A mod that prevents more then 12-15 multicast clients from joining at any one time.

We have used two products for lab management in the past. Alteris RapidDeploy and Ghost. We are currently moving to ghost as the product of choice. This brings some problems. We just started using multicast. with the alteris we are able to multicast to 60+ machines at a time but with ghost we have problems.

We use a 6506 with a Sup 1A as the core of our network and have a mixture of Cisco 2950's and 3Com 1100's and 3300 in remote buildings. Buildings are connected with 100Meg Fiber. We are behind on our software updates for our 6506 (currently CatOS 5.5(1) and IOS12.1(2)E ED) I have enable multicast on the router, set the interfaces to pim-sparse-dense mode and created a set RP. (suggest in another article) IGMP is enabled on the switch and the switch is aware what ports are multicast enabled.

We are stuck because it seems that no matter what we do, there seems to be a limit that we hit. Given time we can get about 18 machines to join a group but we have never gotten more then that.

Is the problem with our sup module? software level? configuration? I you would like I can post the configs of our 6506 but I have read several CIsco articles and I think I have enable at least the basic multicast commands.

Any help/suggestions would be greatly appreciated

Matt Regner

Network Support Specialist

5 REPLIES
Community Member

Re: Multicasting - Ghost Multicast Server Problems

hi

so you say you can get only 18 machines to join the group. What happens when the 18th person leaves the group does another machine join?

Have you pretty much narrowed it down to the equipment and not the Pc's because some NIC drivers in PC does not support multicast very well. Also are you running rgmp on your interface? Can you send me your basic config if possible

thanks

Community Member

Re: Multicasting - Ghost Multicast Server Problems

If you reboot machines in the group, other machine that were not part of the group join in. I have rgmp enabled but I didn't do anything to configure any of the individual interfaces. Unlike the multicast router were multicast routing was turn on each interface I know it is not good form but if you change the mode while some machines are in the group and the others are waiting then they will all join. i.e change the mode on the interface from ip pim sparse-dense-mode to ip pim sparse-mode will make them join for that session but not for the next session. When the ghost task starts, any machines that were waiting will then join a group but not the group already in the task. This weekend we are taking both portions to their latest software levels.

Thanks for any insights

Posting Both Configs, Sorry for the long post.

router config (session 15)

Current configuration:

!

version 12.1

service timestamps debug datetime

service timestamps log datetime

no service password-encryption

!

hostname Kings-Rtr

!

boot system bootflash:c6msfc2-is-mz.121-2.E

boot bootldr bootflash:c6msfc2-boot-mz.121-2.E

no logging console

!

ip subnet-zero

ip cef

no ip domain-lookup

ip name-server 10.1.18.56

ip name-server 10.1.18.55

!

ip multicast-routing

!

!

!

interface Loopback0

ip address 10.1.2.2 255.255.255.0

ip pim sparse-dense-mode

!

interface Vlan1

ip address 10.1.1.2 255.255.255.0

no ip mroute-cache

!

interface Vlan2

no ip address

shutdown

!

interface Vlan12

no ip address

ip helper-address 10.1.18.170

shutdown

!

interface Vlan13

ip address 10.1.13.1 255.255.255.0

ip helper-address 10.1.18.56

ip helper-address 10.1.25.25

ip pim sparse-mode

!

interface Vlan14

ip address 10.1.14.1 255.255.255.0

ip helper-address 10.1.18.56

ip helper-address 10.1.25.25

ip pim sparse-dense-mode

!

interface Vlan15

ip address 10.1.15.1 255.255.255.0

ip helper-address 10.1.18.56

ip pim sparse-dense-mode

!

interface Vlan16

ip address 10.1.16.1 255.255.255.0

ip helper-address 10.1.18.56

ip pim sparse-dense-mode

!

interface Vlan17

ip address 10.1.17.1 255.255.255.0

ip helper-address 10.1.18.56

!

interface Vlan18

ip address 10.1.18.1 255.255.255.0

!

interface Vlan19

ip address 10.1.19.1 255.255.255.0

ip helper-address 10.1.18.56

!

interface Vlan20

ip address 10.1.20.1 255.255.255.0

ip helper-address 10.1.18.56

ip helper-address 10.1.18.111

ip pim sparse-dense-mode

!

interface Vlan21

ip address 10.1.21.1 255.255.255.0

ip helper-address 10.1.18.56

ip pim sparse-dense-mode

!

interface Vlan22

ip address 10.1.22.1 255.255.255.0

ip helper-address 10.1.18.56

!

interface Vlan23

ip address 10.1.23.1 255.255.255.0

ip helper-address 10.1.18.56

!

interface Vlan24

no ip address

ip helper-address 10.1.18.56

!

interface Vlan25

ip address 10.1.25.1 255.255.255.0

ip helper-address 10.1.18.56

ip pim sparse-dense-mode

!

interface Vlan101

ip address 10.1.101.1 255.255.255.0

ip helper-address 10.1.18.56

!

interface Vlan102

ip address 10.1.102.1 255.255.255.0

ip helper-address 10.1.18.56

!

interface Vlan103

ip address 10.1.103.1 255.255.255.0

ip helper-address 10.1.18.56

!

interface Vlan104

ip address 10.1.104.1 255.255.255.0

ip helper-address 10.1.18.56

!

interface Vlan105

ip address 10.1.105.1 255.255.255.0

ip helper-address 10.1.18.56

!

interface Vlan106

ip address 10.1.106.1 255.255.255.0

ip helper-address 10.1.18.56

ip pim sparse-dense-mode

!

interface Vlan107

ip address 10.1.107.1 255.255.255.0

ip helper-address 10.1.18.56

!

interface Vlan108

ip address 10.1.108.1 255.255.255.0

ip helper-address 10.1.18.56

!

interface Vlan109

ip address 10.1.109.1 255.255.255.0

ip helper-address 10.1.18.56

!

interface Vlan110

ip address 10.1.110.1 255.255.255.0

ip helper-address 10.1.18.56

!

interface Vlan111

ip address 10.1.111.1 255.255.255.0

ip helper-address 10.1.18.56

!

interface Vlan112

ip address 10.1.112.1 255.255.255.0

ip helper-address 10.1.18.56

ip helper-address 10.1.18.111

!

interface Vlan113

ip address 10.1.113.1 255.255.255.0

ip helper-address 10.1.18.56

!

interface Vlan114

ip address 10.1.114.1 255.255.255.0

ip helper-address 10.1.18.56

!

interface Vlan115

ip address 10.1.115.1 255.255.255.0

ip helper-address 10.1.18.56

!

interface Vlan116

ip address 10.1.116.1 255.255.255.0

ip helper-address 10.1.18.56

!

interface Vlan117

ip address 10.1.117.1 255.255.255.0

ip helper-address 10.1.18.56

!

interface Vlan118

ip address 10.1.118.1 255.255.255.0

ip helper-address 10.1.18.56

!

interface Vlan119

ip address 10.1.119.1 255.255.255.0

ip helper-address 10.1.18.56

ip pim sparse-dense-mode

!

interface Vlan120

ip address 10.1.120.1 255.255.255.0

ip helper-address 10.1.18.56

ip pim sparse-dense-mode

!

interface Vlan121

ip address 10.1.121.1 255.255.255.0

ip helper-address 10.1.18.56

!

interface Vlan122

ip address 10.1.122.1 255.255.255.0

ip helper-address 10.1.18.56

!

interface Vlan123

ip address 10.1.123.1 255.255.255.0

ip helper-address 10.1.18.56

!

interface Vlan124

ip address 10.1.124.1 255.255.255.0

ip helper-address 10.1.18.56

!

interface Vlan125

ip address 10.1.125.1 255.255.255.0

ip helper-address 10.1.18.56

!

interface Vlan126

ip address 10.1.126.1 255.255.255.0

ip helper-address 10.1.18.56

ip pim sparse-dense-mode

!

interface Vlan127

ip address 10.1.127.1 255.255.255.0

ip helper-address 10.1.18.56

shutdown

!

interface Vlan128

ip address 10.1.128.1 255.255.255.0

ip helper-address 10.1.18.56

ip helper-address 10.1.18.170

!

interface Vlan129

ip address 10.1.129.1 255.255.255.0

!

router eigrp 1

network 10.1.0.0 0.0.255.255

!

ip default-gateway 10.1.18.19

ip classless

no ip forward-protocol udp tftp

no ip forward-protocol udp time

no ip forward-protocol udp tacacs

ip route 0.0.0.0 0.0.0.0 10.1.18.19

ip http server

ip pim rp-address 10.1.2.2

ip pim send-rp-announce Loopback0 scope 16

ip pim send-rp-discovery scope 16

!

route-map Epix permit 10

set ip default next-hop 10.1.18.19

!

snmp-server engineID local 000000090200000021000000

snmp-server community rmeister RO

snmp-server community wmeister RW

snmp-server enable traps snmp

snmp-server enable traps rtr

snmp-server host 10.1.1.100 wmeister

!

!

end

Switch Configuration

This command shows non-default configurations only.

Use 'show config all' to show both default and non-default configurations.

.........

................

................

..................

...............

..

begin

!

# ***** NON-DEFAULT CONFIGURATION *****

!

!

#time: Fri Feb 28 2003, 17:31:45

!

#version 5.5(1)

!

set password

set enablepass

!

#!

#snmp

set snmp community read-only rmeister

set snmp community read-write wmeister

!

#vtp

set vtp domain kings

set vlan 1 name default type ethernet mtu 1500 said 100001 state active

set vlan 13 name VLAN0013 type ethernet mtu 1500 said 100013 state active

set vlan 14 name VLAN0014 type ethernet mtu 1500 said 100014 state active

set vlan 15 name VLAN0015 type ethernet mtu 1500 said 100015 state active

set vlan 16 name VLAN0016 type ethernet mtu 1500 said 100016 state active

set vlan 17 name VLAN0017 type ethernet mtu 1500 said 100017 state active

set vlan 18 name VLAN0018 type ethernet mtu 1500 said 100018 state active

set vlan 19 name VLAN0019 type ethernet mtu 1500 said 100019 state active

set vlan 20 name VLAN0020 type ethernet mtu 1500 said 100020 state active

set vlan 21 name VLAN0021 type ethernet mtu 1500 said 100021 state active

set vlan 22 name VLAN0022 type ethernet mtu 1500 said 100022 state active

set vlan 23 name VLAN0023 type ethernet mtu 1500 said 100023 state active

set vlan 24 name VLAN0024 type ethernet mtu 1500 said 100024 state active

set vlan 25 name VLAN0025 type ethernet mtu 1500 said 100025 state active

set vlan 101 name VLAN0101 type ethernet mtu 1500 said 100101 state active

set vlan 102 name VLAN0102 type ethernet mtu 1500 said 100102 state active

set vlan 103 name VLAN0103 type ethernet mtu 1500 said 100103 state active

set vlan 104 name VLAN0104 type ethernet mtu 1500 said 100104 state active

set vlan 105 name VLAN0105 type ethernet mtu 1500 said 100105 state active

set vlan 106 name VLAN0106 type ethernet mtu 1500 said 100106 state active

set vlan 107 name VLAN0107 type ethernet mtu 1500 said 100107 state active

set vlan 108 name VLAN0108 type ethernet mtu 1500 said 100108 state active

set vlan 109 name VLAN0109 type ethernet mtu 1500 said 100109 state active

set vlan 110 name VLAN0110 type ethernet mtu 1500 said 100110 state active

set vlan 111 name VLAN0111 type ethernet mtu 1500 said 100111 state active

set vlan 112 name VLAN0112 type ethernet mtu 1500 said 100112 state active

set vlan 113 name VLAN0113 type ethernet mtu 1500 said 100113 state active

set vlan 114 name VLAN0114 type ethernet mtu 1500 said 100114 state active

set vlan 115 name VLAN0115 type ethernet mtu 1500 said 100115 state active

set vlan 116 name VLAN0116 type ethernet mtu 1500 said 100116 state active

set vlan 117 name VLAN0117 type ethernet mtu 1500 said 100117 state active

set vlan 118 name VLAN0118 type ethernet mtu 1500 said 100118 state active

set vlan 119 name VLAN0119 type ethernet mtu 1500 said 100119 state active

set vlan 120 name VLAN0120 type ethernet mtu 1500 said 100120 state active

set vlan 121 name VLAN0121 type ethernet mtu 1500 said 100121 state active

set vlan 122 name VLAN0122 type ethernet mtu 1500 said 100122 state active

set vlan 123 name VLAN0123 type ethernet mtu 1500 said 100123 state active

set vlan 124 name VLAN0124 type ethernet mtu 1500 said 100124 state active

set vlan 125 name VLAN0125 type ethernet mtu 1500 said 100125 state active

set vlan 126 name VLAN0126 type ethernet mtu 1500 said 100126 state active

set vlan 127 name VLAN0127 type ethernet mtu 1500 said 100127 state active

set vlan 128 name VLAN0128 type ethernet mtu 1500 said 100128 state active

set vlan 129 name VLAN0129 type ethernet mtu 1500 said 100129 state active

set vlan 1002 name fddi-default type fddi mtu 1500 said 101002 state active

set vlan 1004 name fddinet-default type fddinet mtu 1500 said 101004 state active stp ieee

set vlan 1005 name trnet-default type trbrf mtu 1500 said 101005 state active stp ibm

set vlan 1003 name token-ring-default type trcrf mtu 1500 said 101003 state active mode srb aremaxhop 7 stemaxhop 7 backupcrf off

!

#ip

set interface sc0 1 10.1.1.1/255.255.255.0 10.1.1.255

set ip route 0.0.0.0/0.0.0.0 10.1.1.100

!

#set boot command

set boot config-register 0x2

set boot system flash bootflash:cat6000-sup.5-5-1.bin

!

#igmp

set igmp enable

!

#rgmp

set rgmp enable

!

#port channel

set port channel 3/1-4 2

set port channel 3/5-8 3

set port channel 3/9-12 4

set port channel 3/13-16 5

set port channel 3/17-20 6

set port channel 3/21-22 7

set port channel 4/1-4 8

set port channel 4/5-8 9

set port channel 4/9-12 10

set port channel 4/13-16 11

set port channel 4/17-20 12

set port channel 4/21-24 13

set port channel 6/1-4 14

set port channel 6/5-8 15

set port channel 6/9-12 16

set port channel 6/13-16 17

set port channel 6/17-20 18

set port channel 6/21-24 19

set port channel 6/25-28 20

set port channel 6/29-32,6/37-38 21

set port channel 6/33-36 22

set port channel 6/39-40 23

set port channel 6/41-44 24

set port channel 6/45-48 25

set port channel 3/23-24 100

!

# default port status is enable

!

!

#module 1 : 2-port 1000BaseX Supervisor

!

#module 2 empty

!

#module 3 : 24-port 100BaseFX MM Ethernet

set vlan 18 3/23-24

set vlan 101 3/1

set vlan 102 3/2

set vlan 103 3/3

set vlan 104 3/4

set vlan 105 3/5

set vlan 106 3/6

set vlan 107 3/7

set vlan 108 3/8

set vlan 109 3/9

set vlan 110 3/10

set vlan 111 3/11

set vlan 112 3/12

set vlan 113 3/13

set vlan 114 3/14

set vlan 115 3/15

set vlan 116 3/16

set vlan 117 3/17

set vlan 118 3/18

set vlan 119 3/19

set vlan 120 3/20

set vlan 121 3/21

set vlan 122 3/22

set port duplex 3/1-24 full

set multicast router 3/6,3/19-20

set trunk 3/18 off dot1q 1-1005

set trunk 3/19 auto dot1q 1-1005

set trunk 3/22 off dot1q 1-1005

set spantree portfast 3/19 enable

set port channel 3/23-24 mode on

set port channel 3/1-22 mode off

!

#module 4 : 24-port 100BaseFX MM Ethernet

set vlan 125 4/1

set vlan 126 4/2

set vlan 127 4/3

set vlan 128 4/4

set vlan 129 4/5,4/23-24

set port duplex 4/1-4,4/24 full

set port name 4/24 3640 router subnet

set multicast router 4/2

set trunk 4/1 off dot1q 1-1005

set trunk 4/2 off dot1q 1-1005

set port channel 4/1-5,4/23-24 mode off

!

#module 5 empty

!

#module 6 : 48-port 10/100BaseTX Ethernet

set vlan 13 6/25

set vlan 14 6/26

set vlan 15 6/4,6/27

set vlan 16 6/28

set vlan 17 6/29

set vlan 18 6/1-3,6/5-24,6/34,6/39-44,6/46-47

set vlan 19 6/30

set vlan 20 6/31,6/37-38

set vlan 21 6/32

set vlan 22 6/33,6/45

set vlan 25 6/35-36

set port speed 6/3,6/31 10

set port speed 6/1-2,6/7-12,6/16-19,6/25-27,6/29-30,6/33-47 100

set port duplex 6/1-2,6/7-12,6/16,6/18-19,6/29-30,6/33-47 full

set port name 6/3 Vlan 18 Uplink (old)

set port name 6/4 Xerox

set port name 6/11 MS01

set port name 6/19 Web Advisor

set port name 6/21 Library - RS03

set port name 6/25 Vlan 13 Uplink

set port name 6/26 Vlan 14 Uplink

set port name 6/27 Vlan 15 Uplink

set port name 6/28 Vlan 16 Uplink

set port name 6/29 Vlan 17 Uplink

set port name 6/30 Vlan19 Uplink

set port name 6/31 Vlan 20 Uplink

set port name 6/32 Blaster

set port name 6/33 Lion - RS02 (old)

set port name 6/35 Spector Team0 A

set port name 6/36 Spector Team0 B

set port name 6/37 Oracle-1of2

set port name 6/38 Oracle-2of2

set port name 6/39 MS02 OWA

set port name 6/40 MS02 SMTP

set port name 6/41 MS02 Team B1

set port name 6/42 MS01 Team B2

set port name 6/43 MS02 Team A1

set port name 6/44 MS02 Team A2

set port name 6/45 Lion - RS03

set port name 6/47 to internet (PIX)

set multicast router 6/25-28,6/31,6/35-36

set trunk 6/9 off negotiate 1-1005

set spantree portfast 6/9 enable

set port channel 6/9,6/16,6/19-20,6/25-44 mode off

!

#module 15 : 1-port Multilayer Switch Feature Card

set multicast router 15/1

!

#module 16 empty

end

Console> (enable)

Community Member

Re: Multicasting - Ghost Multicast Server Problems

I have used Cisco's iptv server along with a 6509. We had over 80 people join a group to watch the super bowl a year ago. There where no problems. Do you have any other routers in your network that have multicast users behind them? Also did you turn CGMP on for both the router and the switch?

Community Member

Re: Multicasting - Ghost Multicast Server Problems

Other then our internet router the 6506 is the only router on the network. All network segments collapse back to the 6506.

I didn't see a command to turn on CGMP, for either protion, I think that might be on the Sup II level. I have to work with a Sup IA. If there is a command to enable it on the Sup IA then please share because i didn't see anything to set it. If you think that the problem is that we have a Sup Ia please tell me that too because I would love to know.

Thanks for the post.

Community Member

Re: Multicasting - Ghost Multicast Server Problems

Hello Matt,

I have also a problem to get my ghost working on the Network. please cann you help me ? how dit you get yours works?

I have this issue

Ghost Server (10.61.10.111) --- vlan 121 (port Gig 5/8)on Cat 6509switch02 --- MSFC ----- vlan 113,114,115--- clients (receivers)

Note that Cat6509 switch 02 and cat 6509 swict 01 are using HSRP and on every etage there are 2 or cat 3548 xl connected to the cat 6509 switches

Thanks for any help

AF

412
Views
0
Helpful
5
Replies
CreatePlease to create content