Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

multicasting only working in dense mode

I'm having a problem on a Cat6513 with a MSFC where I cannot get multicasting working between two VLAN interfaces if they are configured with anything besides dense mode. Here's my config:

!

ip multicast-routing

!

!

!

interface Loopback0

ip address 10.251.1.1 255.255.255.0

ip pim sparse-dense-mode

!

interface Vlan10

ip address 10.10.200.2 255.255.255.0

ip helper-address 10.11.200.10

no ip redirects

ip pim sparse-dense-mode

ip rgmp

standby ip 10.10.200.1

standby priority 140

standby preempt

!

interface Vlan105

description Server Farm VLAN

ip address 10.11.200.2 255.255.255.0

ip helper-address 10.11.200.10

no ip redirects

ip pim sparse-dense-mode

ip rgmp

standby ip 10.11.200.1

standby priority 130

standby preempt

ip classless

ip route 0.0.0.0 0.0.0.0 10.254.1.1

no ip http server

ip pim send-rp-announce Loopback0 scope 32

ip pim send-rp-discovery Loopback0 scope 32

!

!

If it is configured this way, the multicast client on VLAN10 cannot receive the stream from the server on VLAN105. If I change VLAN10 to be "ip pim dense-mode", it will work. Both of these interfaces are the active HSRP interfaces I've looked and looked over how to configure this any I can't find anything wrong. I can see the IGMP join requests come in to VLAN10 from the client but it doesn't seem to actually join. Any ideas?

8 REPLIES
New Member

Re: multicasting only working in dense mode

There is a good document at ftp://ftpeng.cisco.com/ipmulticast/autorp.html regarding auto-rp configuration and diagnostics.

Section 4 is useful as it contains a diagnostics flowchart you can follow. Section 5 contains common errors, such as possible misconfiguration on other routers etc.

Let me know how you go as I believe one of our clients has a similar problem.

New Member

Re: multicasting only working in dense mode

My Working setup for sparse PIM is as below, check out if you can do something...

interface Vlan6

description ## Back Bone##

ip address 10.x.x.1 255.255.255.0

ip helper-address 10.y.x.x

no ip proxy-arp

ip pim query-interval 180

ip pim sparse-dense-mode

ip multicast ttl-threshold 15

no ip route-cache cef

ip igmp query-interval 180

ip cgmp( instead of rgmp)

no ip mroute-cache

Also on the L2 , do you have cgmp enabled.

set cgmp enable

set cgmp leave enable

New Member

Re: multicasting only working in dense mode

Unfortunately, CGMP does not even appear to be an option on this version of CatOS (7.6(1)):

Server_Farm (enable) set c?

cam Set CAM table entry

cdp Set cdp, use 'set cdp help' for more info

channelprotocol Set channeling protocol for a module

config Set system configuration parameters

cops Set COPS information

crypto To generate RSA key pairs for the host

Server_Farm (enable)

New Member

Re: multicasting only working in dense mode

According to the flow chart, the problem I am having is local to this MSFC but the flow chart does not go any deeper than that. Since these VLAN interfaces are on the same MSFC that is the RP, I would think the configuration would work. I'm still not sure what the problem is. According to all the documentation, in sparse-dense mode, if the RP is unreachable, it should revert back to dense mode and work, which does not seem to be happening.

New Member

Re: multicasting only working in dense mode

Well you've got RGMP enabled on the interfaces. Here are some things you can check:

1. I presume you're using 6500 in hybrid mode. Have you enabled RGMP on the switch? set rgmp enable

2. IGMP snooping is a prerequisite for RGMP. You need to enable IGMP snooping on the switch. set igmp enable

3. Make sure the loopback interface on the router has RGMP as per the other two VLAN interfaces.

New Member

Re: multicasting only working in dense mode

Yes, it is a 6500 in hybrid mode. RGMP and IGMP snooping have both been enabled on the switch. I tried to enable RGMP on the loopback but got the message:

"RGMP not supported on non-802 media"

New Member

Re: multicasting only working in dense mode

I was going to test your environment in our labs but our 6500 is in use at the moment.

I guess the 'last-resort' things I would try are (in order):

1. Disable RGMP all around.

2. Manually configure the rendezvous point.

3. Place multicast in sparse mode only.

and then work from there depending on the results.

New Member

Re: multicasting only working in dense mode

Hello,

I would be interested to see the output of

sh ip pim rp mapping

Regards

Ian

198
Views
0
Helpful
8
Replies
CreatePlease to create content