Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

multilink ppp config?

Hi,

Have been trying to configure multilink ppp between two sites over two x.21 serial lines but after running fine for a while something goes wrong? Would the experts in here be able to cast their eyes over the following configs to spot any obvious errors.....

Router A (3745):

!

version 12.2

service timestamps debug datetime msec

service timestamps log uptime

service password-encryption

!

hostname "Router A"

!

enable secret 5 ***

enable password 7 ***

!

username *** password 7 ***

username *** password 7 ***

ip subnet-zero

!

!

!

multilink virtual-template 1

ipx routing 000a.8ac4.bbb0

isdn switch-type basic-net3

!

!

!

!

interface Loopback0

no ip address

ipx network FF

!

interface FastEthernet0/0

ip address 199.100.2.254 255.255.255.0

no ip mroute-cache

duplex auto

speed auto

ipx encapsulation SAP

ipx network 1

no cdp enable

!

interface Serial0/0

description Not Connected

no ip address

no ip mroute-cache

shutdown

clockrate 2000000

no fair-queue

!

interface FastEthernet0/1

ip address 199.100.101.254 255.255.255.0

no ip mroute-cache

shutdown

duplex auto

speed auto

no cdp enable

!

interface Serial0/1

description Connected to Router B Secondary line

no ip address

encapsulation ppp

no ip mroute-cache

fair-queue

ppp multilink

!

interface FastEthernet1/0

ip address 10.5.5.254 255.255.255.0

duplex auto

speed auto

!

interface Serial1/0

description Connected to Router B Primary line

no ip address

encapsulation ppp

no ip mroute-cache

fair-queue

ppp multilink

!

interface FastEthernet1/1

no ip address

shutdown

duplex auto

speed auto

!

interface Serial1/1

description Connected Router C

ip unnumbered FastEthernet0/0

encapsulation ppp

no ip mroute-cache

!

interface BRI2/0

description Backup ISDN line 1 (phone number ***)

no ip address

encapsulation ppp

shutdown

dialer pool-member 1

isdn switch-type basic-net3

ppp authentication chap

ppp multilink

!

interface BRI2/1

description Backup ISDN line 2 (phone number ***)

no ip address

encapsulation ppp

shutdown

dialer pool-member 1

isdn switch-type basic-net3

ppp authentication chap

ppp multilink

!

interface BRI2/2

description NOT CONNECTED TO LINE

no ip address

encapsulation ppp

shutdown

dialer pool-member 1

isdn switch-type basic-net3

ppp authentication chap

ppp multilink

!

interface BRI2/3

description NOT CONNECTED TO LINE

no ip address

shutdown

isdn switch-type basic-net3

!

interface Virtual-Template1

ip unnumbered FastEthernet0/0

ipx ppp-client Loopback0

ppp multilink

!

interface Dialer0

description Connection to Router C ISDN lines

ip unnumbered Loopback0

encapsulation ppp

dialer pool 1

dialer idle-timeout 300

dialer string ***

dialer string ***

dialer string ***

dialer hold-queue 5

dialer load-threshold 1 either

dialer-group 1

ipx network AA

no ipx route-cache

ipx watchdog-spoof

ppp authentication chap

ppp multilink

!

ip classless

ip route 0.0.0.0 0.0.0.0 199.100.2.249

ip route 155.195.0.0 255.255.0.0 199.100.2.240

ip route 172.16.1.5 255.255.255.255 Dialer0

ip route 172.31.0.0 255.255.0.0 199.100.2.240

ip route 197.103.9.0 255.255.255.0 197.103.9.1

ip route 197.103.10.0 255.255.255.0 199.100.2.252

ip route 199.0.0.0 255.0.0.0 199.100.2.240

ip route 199.67.139.54 255.255.255.255 199.100.2.249

ip route 199.94.20.96 255.255.255.255 199.100.2.249

ip route 199.100.3.0 255.255.255.0 199.100.3.254

ip route 199.100.4.0 255.255.255.0 199.100.4.254

ip route 199.100.5.0 255.255.255.0 199.100.5.254

ip route 199.105.176.0 255.255.255.248 199.100.2.10

ip route 199.105.176.0 255.255.255.248 199.100.2.11 10

ip route 199.105.184.0 255.255.254.0 199.100.2.10

ip route 199.105.184.0 255.255.254.0 199.100.2.11 10

ip route 205.183.246.0 255.255.255.0 199.100.2.10

ip route 205.183.246.0 255.255.255.0 199.100.2.11 10

ip route 208.134.161.0 255.255.255.0 199.100.2.10

ip route 208.134.161.0 255.255.255.0 199.100.2.11 10

no ip http server

ip pim bidir-enable

!

!

dialer-list 1 protocol ip permit

dialer-list 1 protocol ipx permit

!

!

!

snmp-server community *** RO

snmp-server enable traps tty

!

line con 0

exec-timeout 5 0

speed 115200

line aux 0

line vty 0 4

exec-timeout 5 0

password 7 ***

login

!

end

Router B (3600):

!

version 12.2

service timestamps debug uptime

service timestamps log uptime

service password-encryption

!

hostname Router B

!

enable secret 5 ***.

enable password 7 ***

!

ip subnet-zero

!

!

!

multilink virtual-template 1

ipx routing 0008.215d.a2d1

!

!

!

interface Loopback0

no ip address

ipx network FF

!

interface Serial0/0

description Connected to router A

no ip address

encapsulation ppp

no ip mroute-cache

ppp multilink

!

interface Serial0/1

description Connected to router A (line 2)

no ip address

encapsulation ppp

no ip mroute-cache

ppp multilink

!

interface FastEthernet1/0

ip address 199.100.4.254 255.255.255.0

no ip mroute-cache

speed auto

full-duplex

ipx network 4

no cdp enable

!

interface Virtual-Template1

ip unnumbered FastEthernet1/0

ipx ppp-client Loopback0

!

ip classless

ip route 0.0.0.0 0.0.0.0 199.100.2.254

no ip http server

ip pim bidir-enable

!

!

!

!

!

line con 0

exec-timeout 5 0

speed 115200

line aux 0

line vty 0 4

exec-timeout 5 0

password 7 ***

login

!

end

4 REPLIES
Silver

Re: multilink ppp config?

Instead of using a virtual template you can use a multilink interface

interface Multilink1

ip address 10.10.10.1 255.255.255.0

no cdp enable

ppp multilink

multilink-group 1

interface Serial0/0

description Connected to router A

no ip address

encapsulation ppp

no ip mroute-cache

ppp multilink

multilink-group 1

!

interface Serial0/1

description Connected to router A (line 2)

no ip address

encapsulation ppp

no ip mroute-cache

ppp multilink

multilink-group 1

Do you have problems when the dialers become active ?

New Member

Re: multilink ppp config?

Interesting - I am new to multilink interfaces, is there somewhere that will describe the differences between these and a virtual templates? I guess what I am asking is why change? What's the advantage?

To answer your question, the diallers are not physically connected and are only used if lines die to another router. Therefore they shouldn't be active at all...... The routing from router A to router B shouldn't push anything through them. But I am wondering if they could be causing some sort of conflict.

Silver

Re: multilink ppp config?

that is exactly why I asked about the dialers , I was thinking the same thing.

New Member

Re: multilink ppp config?

When we found there was a problem (ftp slowed down and connections started dropping) our fix was to remove ppp multilink from one of the serial interfaces, effectively removing one of the lines from the bundle. This had the effect of restoring all the connections. This, to me, would suggest that the diallers were not causing the problems?

106
Views
0
Helpful
4
Replies
CreatePlease login to create content