cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
396
Views
0
Helpful
1
Replies

Multilink with Serial- and BRI-IF on 2503

krusekl
Level 1
Level 1

Hello all,

I have two routers with IOS 12.0(27) on it. There's a leased line which works with the ser0-interface only and there's a ISDN-line with two b-channels which works (mostly) with the bri0-if only.

Now I want to do/to have the following to get work:

the leased-line with the ser0-interfaces on both sides should be for the basic traffic. After reaching a threshold, the first b-channel should come up.

I tried to do this via a dialer rotary-group and put the ser0 and bri0-if in it.

I worked, until the dialer-idle time was reached and then the VirtualAcces-IF goes down and never comes up again. After resetting the external X.21-Modem for the ser0-IF on one side the VirtualAccess-IF comes up again and so on.

In this case the bri0 did not come up to handle the traffic instead of the ser0-IF.

Switching on the debugging I could see, that the ser0-IF got the dialer-string with the phone-number for the bri0-if, maybe that's the reason for crashing the external modem.

I got help in the web in that way, that I should configure the ser0 with dialer dtr, dialer pool-member 1, dialer priority 10 and the bri0 with dialer pool-member 1 and dialer priority 5. It worked for the ser0, but not for the bri0-IF.

Now, is it possible to combine the leased-line for basic traffic with a ISDN-line in that way using the dialer threshold and dialer rotary-group?

What is an other possibility for expanding the bandwith using my hardware?

I post the config of the both routers - maybe it helps, and maybe anyone knows a way to do this...

Router A:

!

version 12.0

service timestamps debug uptime

service timestamps log uptime

service password-encryption

service udp-small-servers

service tcp-small-servers

!

hostname router-b

!

no logging buffered

no logging console

no logging monitor

enable secret xxxxx

!

username router-a password xxxxx

ip subnet-zero

isdn switch-type basic-net3

!

!

!

interface Ethernet0

ip address 192.168.5.9 255.255.255.0

ip helper-address 192.168.94.5

ip helper-address 192.168.94.23

no ip directed-broadcast

!

interface Serial0

no ip address

no ip directed-broadcast

encapsulation ppp

no ip mroute-cache

shutdown

dialer in-band

no fair-queue

pulse-time 1

ppp authentication chap

ppp multilink

!

interface Serial1

no ip address

no ip directed-broadcast

shutdown

!

interface BRI0

no ip address

no ip directed-broadcast

encapsulation ppp

no ip route-cache

no ip mroute-cache

no keepalive

dialer rotary-group 1

isdn switch-type basic-net3

no fair-queue

!

interface Dialer1

ip address x.x.x.1 255.255.255.0

ip helper-address 192.168.94.5

ip helper-address 192.168.94.23

no ip directed-broadcast

encapsulation ppp

dialer in-band

dialer map ip x.x.x.2 name router-a broadcast 010519474439

dialer load-threshold 40 either

dialer-group 1

no fair-queue

ppp authentication chap

ppp multilink

!

ip classless

ip route 0.0.0.0 0.0.0.0 192.168.5.1

ip route 192.168.1.0 255.255.255.0 200.200.205.2

!

logging source-interface Ethernet0

logging x.x.94.31

access-list 101 permit ip any any

dialer-list 1 protocol ip list 101

snmp-server community zit4mrtg RO

!

line con 0

transport input none

line aux 0

transport input all

line vty 0 4

password xxxxx

login

!

end

Router B:

!

version 12.0

service timestamps debug uptime

service timestamps log uptime

service password-encryption

service udp-small-servers

service tcp-small-servers

!

hostname router-a

!

no logging buffered

no logging console

no logging monitor

enable secret xxxx

enable password xxxxx

!

username router-b password xxxxxx

ip subnet-zero

no ip domain-lookup

isdn switch-type basic-net3

!

!

!

interface Loopback0

ip address x.x.x.33 255.255.255.252

no ip directed-broadcast

!

interface Ethernet0

ip address 192.168.1.1 255.255.255.0

ip helper-address 192.168.94.5

ip helper-address 192.168.94.23

no ip directed-broadcast

!

interface Serial0

no ip address

no ip directed-broadcast

encapsulation ppp

no ip mroute-cache

shutdown

dialer in-band

no fair-queue

pulse-time 1

ppp authentication chap

ppp multilink

!

interface Serial1

no ip address

no ip directed-broadcast

shutdown

!

interface BRI0

no ip address

no ip directed-broadcast

encapsulation ppp

no ip mroute-cache

dialer rotary-group 1

isdn switch-type basic-net3

no fair-queue

!

interface Dialer1

ip address x.x.x.2 255.255.255.0

ip helper-address 192.168.94.5

ip helper-address 192.168.94.23

no ip directed-broadcast

encapsulation ppp

dialer in-band

dialer idle-timeout 300

dialer map ip x.x.x.1 name router-b broadcast 0105134583

dialer load-threshold 40 either

dialer-group 1

no fair-queue

ppp authentication chap

ppp multilink

!

ip classless

ip route 0.0.0.0 0.0.0.0 200.200.205.1

!

no logging trap

access-list 100 deny udp any any eq netbios-ns

access-list 100 permit ip any any

access-list 100 deny udp any any eq netbios-dgm

dialer-list 1 protocol ip list 101

!

line con 0

transport input none

line aux 0

transport input all

line vty 0 4

password xxxx

login

!

end

1 Reply 1

vkapoor5
Level 5
Level 5

See if you can use the 'backup interface' and 'backup load' commands on the serial interface. This link has more information :

http://www.cisco.com/univercd/cc/td/doc/product/software/ios121/121cgcr/dialts_c/dtsprt6/dcdbaks.htm