Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Multiple BVIs to Cisco 2600 router ??

I'd like to configure multiple BVIs (Bridged Virtual Interfaces) to Cisco router. How can it be done? I cannot create BVI 2 unless I have another bridge-group. To clarify the idea, I included my current config. It is running on ADSL with WIC-1ADSL. I want to have multiple BVIs and each need to acquire a real routable IP address from ISP? The one I have created is being used as NAT interface.

I also have fasteth0/0 bridged to group 1 since I'd like to assign some ISP-provided real IPs to some hosts.

I'm running IP/IDS/FW PLUS IPSEC 3DES software version 12.2.4-XL6.

----------- My current config is this: ------------------

Router#show running-config

Building configuration...

Current configuration : 1317 bytes

!

version 12.2

service timestamps debug uptime

service timestamps log uptime

no service password-encryption

!

hostname Router

!

!

!

!

ip subnet-zero

!

!

ip name-server 10.16.10.16

ip name-server 10.16.11.16

!

ip audit notify log

ip audit po max-events 100

ip ssh time-out 120

ip ssh authentication-retries 3

!

crypto mib ipsec flowmib history tunnel size 200

crypto mib ipsec flowmib history failure size 200

!

!

!

!

!

!

!

!

bridge irb

!

!

!

interface ATM0/0

no ip address

atm vc-per-vp 256

no atm ilmi-keepalive

atm voice aal2 aggregate-svc upspeed-number 0

dsl operating-mode auto

!

interface ATM0/0.1 point-to-point

pvc SoneraADSL 0/33

encapsulation aal5snap

!

bridge-group 1

!

interface FastEthernet0/0

no ip address

duplex auto

speed auto

bridge-group 1

!

interface FastEthernet0/1

ip address 192.168.1.30 255.255.255.224

ip nat inside

duplex auto

speed auto

!

interface BVI1

ip address dhcp

ip nat outside

no ip mroute-cache

!

ip nat inside source list 10 interface BVI1 overload

ip classless

ip http server

ip pim bidir-enable

!

ip director cache time 60

access-list 10 permit 192.168.1.0 0.0.0.31

!

bridge 1 protocol ieee

bridge 1 route ip

call rsvp-sync

!

!

mgcp profile default

!

dial-peer cor custom

!

!

!

!

!

line con 0

line aux 0

line vty 0 4

Router#

2 REPLIES
Silver

Re: Multiple BVIs to Cisco 2600 router ??

You can createaanother bridge-group say 2 and configure 'int bvi2' . But, how you use it depends on what you want to do with it. If you are planning to use this also for NAT, you could create bridge-group 2 and interface bvi2, create another sub-interface under the ATM interface and include it under bridge-group 2. and then, you can create an ACL to map inside addresses to the BVI address for NAT.

New Member

Re: Multiple BVIs to Cisco 2600 router ??

Here is a sample config using irb to provide dsl service. Disadvantage is the use of 4 address to provide 1gateway address and 1 host address. 252 subnet mask. 248 sn provides 5 hosts and the gateway. you can route to each bvi and do not have ip overlap if someone on the other end sets up the wrong ip address. no need to bridge to the ethernet port. bvi number matches the sub int port.

another way is to use a multipoint sub int. and add a larger subnet to the bvi. the issue address out of the subnet to different pvc's but you will have no control over someone changing their address and conflicting with any one else on the multipoint.

hope this helps

bridge irb

!

!

interface Serial0/0

no ip address

ip access-group 102 in

ip helper-address 215.47.17.127

encapsulation frame-relay IETF

ip route-cache flow

no ip route-cache cef

delay 100

no fair-queue

service-module t1 timeslots 1-24

frame-relay lmi-type ansi

!

interface Serial0/0.1 point-to-point

bandwidth 1536

ip unnumbered Ethernet0/0

delay 100

no cdp enable

frame-relay interface-dlci 500 IETF

!

interface Serial0/1

no ip address

encapsulation frame-relay IETF

ip route-cache flow

delay 100

keepalive 5

no fair-queue

service-module t1 timeslots 1-24

frame-relay lmi-type ansi

!

interface Serial0/1.30 point-to-point

delay 100

no cdp enable

frame-relay interface-dlci 30 IETF

bridge-group 30

!

interface Serial0/1.31 point-to-point

delay 100

no cdp enable

frame-relay interface-dlci 31 IETF

bridge-group 31

!

interface Serial0/1.32 point-to-point

delay 100

no cdp enable

frame-relay interface-dlci 32 IETF

bridge-group 32

!

!

interface BVI30

ip address x.x.x.x x.x.x.252

!

interface BVI31

ip address x.x.x.x x.x.x.248

!

interface BVI32

ip address x.x.x.x x.x.x.252

!

!

!

bridge 30 protocol ieee

bridge 30 route ip

bridge 31 protocol ieee

bridge 31 route ip

bridge 32 protocol ieee

bridge 32 route ip

288
Views
0
Helpful
2
Replies