Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Multiple DHCP Pools on 4006 Sup IV

I can configure multiple dhcp pools but only the first one will hand out addresses.

Code: c4000 i9s 12.2(25)EWA6

Checked open caveats for this revision. No open issues.

All the interfaces are VLAN's that the pools are assigned to.

ip dhcp pool 0

network 10.1.0.0 255.255.0.0

domain-name chi.aoa-net.org

dns-server 172.22.1.0 172.22.1.4

!

ip dhcp pool 65

network 10.1.65.0 255.255.255.0

default-router 10.1.65.254

!

ip dhcp pool 72

network 10.1.72.0 255.255.255.0

default-router 10.1.72.254

!

ip dhcp pool 76

network 10.1.76.0 255.255.255.0

default-router 10.1.76.254

!

ip dhcp pool 75

network 10.1.75.0 255.255.255.0

default-router 10.1.75.254

-------------------------------

interface Vlan65

ip address 10.1.65.254 255.255.255.0

ip access-group 165 in

!

interface Vlan66

ip address 10.1.66.254 255.255.255.0

shutdown

!

interface Vlan69

ip address 10.1.69.254 255.255.255.0

shutdown

!

interface Vlan71

ip address 10.1.71.254 255.255.255.0

shutdown

!

interface Vlan72

ip address 10.1.72.254 255.255.255.0

!

interface Vlan73

ip address 10.1.73.254 255.255.255.0

shutdown

!

interface Vlan75

ip address 10.1.75.254 255.255.255.0

!

interface Vlan76

ip address 10.1.76.254 255.255.255.0

---------------------------

The 65 VLAN is the only one that works.

10 REPLIES
Silver

Re: Multiple DHCP Pools on 4006 Sup IV

Did you try to use the ip helper address under the interface? For example, on the interface vlan 75 set the helper as 10.1.75.254. This way the broadcast will be directed to the DHCP pool you have.

Rate if this post helps,

Regards,

Cisco Employee

Re: Multiple DHCP Pools on 4006 Sup IV

Hi Friend,

You really don't need the ip helper address if the DHCP server is configured on the router/switch itself.

What i will like to know is why have you configured pool 0 and if your interface 72,75 and 76 and up and up. Can you verify this by "sh int vlan :

Regards,

Ankur

New Member

Re: Multiple DHCP Pools on 4006 Sup IV

Here is the sh int:

Vlan72 is up, line protocol is up

Hardware is Ethernet SVI, address is 000e.38ce.0c3f (bia 000e.38ce.0c3f)

Internet address is 10.1.72.254/24

MTU 1500 bytes, BW 1000000 Kbit, DLY 10 usec,

reliability 255/255, txload 1/255, rxload 1/255

Encapsulation ARPA, loopback not set

ARP type: ARPA, ARP Timeout 04:00:00

Last input 17:42:51, output never, output hang never

Last clearing of "show interface" counters never

Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0

Queueing strategy: fifo

Output queue: 0/40 (size/max)

5 minute input rate 0 bits/sec, 0 packets/sec

5 minute output rate 0 bits/sec, 0 packets/sec

L3 in Switched: ucast: 6 pkt, 394 bytes - mcast: 0 pkt, 0 bytes

L3 out Switched: ucast: 0 pkt, 0 bytes - mcast: 0 pkt, 0 bytes

156 packets input, 49594 bytes, 0 no buffer

Received 150 broadcasts (0 IP multicast)

0 runts, 0 giants, 0 throttles

0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored

3 packets output, 138 bytes, 0 underruns

0 output errors, 0 interface resets

0 output buffer failures, 0 output buffers swapped out

Vlan76 is up, line protocol is up

Hardware is Ethernet SVI, address is 000e.38ce.0c3f (bia 000e.38ce.0c3f)

Internet address is 10.1.76.254/24

MTU 1500 bytes, BW 1000000 Kbit, DLY 10 usec,

reliability 255/255, txload 1/255, rxload 1/255

Encapsulation ARPA, loopback not set

ARP type: ARPA, ARP Timeout 04:00:00

Last input 00:00:00, output never, output hang never

Last clearing of "show interface" counters never

Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0

Queueing strategy: fifo

Output queue: 0/40 (size/max)

5 minute input rate 0 bits/sec, 0 packets/sec

5 minute output rate 0 bits/sec, 0 packets/sec

L3 in Switched: ucast: 394063 pkt, 108168542 bytes - mcast: 0 pkt, 0 bytes

L3 out Switched: ucast: 342133 pkt, 187837618 bytes - mcast: 0 pkt, 0 bytes

395997 packets input, 108421349 bytes, 0 no buffer

Received 1934 broadcasts (0 IP multicast)

0 runts, 0 giants, 0 throttles

0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored

352845 packets output, 189694089 bytes, 0 underruns

0 output errors, 0 interface resets

0 output buffer failures, 0 output buffers swapped out

The pool configuration was done following this Cisco document:

http://www.cisco.com/en/US/products/sw/iosswrel/ps1831/products_configuration_guide_chapter09186a00800ca6b5.html#wp1001302

Thanks for the post

Dan

Cisco Employee

Re: Multiple DHCP Pools on 4006 Sup IV

Hi Dan,

Can you try removing pool 0?

If your clients in one vlan is getting an ip address other pools should also work.

Are your clients directly connected to this switch or connetced to some other switch and if connected to other swictches do you have a trunk between this switch and other switches allowing these vlans?

Regards,

Ankur

New Member

Re: Multiple DHCP Pools on 4006 Sup IV

Ankur,

The pool0 you will notice has the DNS entries that are propogated to the subnetted pools and the 65 pool works fine with the pool0 DNS entries and the pool65 default gateways and IP address assignments.

The vlans work when a manual IP address is assigned. There is a trunk between this switch and a Series 1200 Access Point that has trunking working, because of the manual IP addresses working when assigned.

Thanks for the help

Dan

Cisco Employee

Re: Multiple DHCP Pools on 4006 Sup IV

Hi Dan,

To narrow down the problem is it possible for you to connect any client directly to the layer 3 switch on which you have your DHCP pools to some vlan which is not proving a DHCP address.

You can manually bind a port to some vlan and connect one machine and see if it gets an ip address from specified VLAN.

I believe that should work and hoping to see some problem in AP.

Regards,

Ankur

New Member

Re: Multiple DHCP Pools on 4006 Sup IV

Ankur,

Tried that after my last post. I put put a port on one of the local floor switches to VLAN 76 and hard wired a port. It didn't give out an IP address. So it eliminated the Access Point.

I think this is a issue with the IOS code.

Dan

New Member

Re: Multiple DHCP Pools on 4006 Sup IV

Tried the ip helper-address, no help.

Dan Moore

Cisco Employee

Re: Multiple DHCP Pools on 4006 Sup IV

Dan,

IP helper address is not required on routers or switch if you have DHCP POOL on same router which is doing routing for those POOL relates subnets.

Regards,

Ankur

Silver

Re: Multiple DHCP Pools on 4006 Sup IV

I know it is not required but I am just wondering why the client is not picking up an IP address from the associated pool.

I just said to give it a try to isolate the problem by directing the broadcast.

Regards,

191
Views
0
Helpful
10
Replies
CreatePlease login to create content