Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Multiple OSPF instances problem

I want to run two instances of OSPF on a router and advertise my loopback address (/32) into both instances. I cant get it to work. Is it possible to make work?

I am using my loopback as the source of a un-numbered Async interface for my OSPF process 20, area 0. I also want my loopback to be a part of my main OSPF process 10, area 400.

The reason I am using two processes is to control via distribution lists what goes into my OSPF 10.

The only way i can get it to work is to declare it in OSPF 20 and re-distribute it into OSPF 10. Is this the only way?

If I have it in OSPF 10 only my adjacency with the other router on my async goes down.

If I have it in both instances only one of them advertises it. A show "ip ospf int loop 1" only shows it being a part of OSPF 20, area 0.

Help appreciated.

2 REPLIES
Gold

Re: Multiple OSPF instances problem

Okay, it's odd, but this is what I see.... I've configured a single loopback, as you have, and configured two ospf processes, each one with a network statement "covering" the loopback.

7206F#sho ip ospf 20 int

7206F#sho ip ospf 10 int

Loopback1 is up, line protocol is up

Internet Address 10.1.1.1/24, Area 100

Process ID 10, Router ID 144.1.1.1, Network Type POINT_TO_POINT, Cost: 1

Transmit Delay is 1 sec, State POINT_TO_POINT,

Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5

Index 1/1, flood queue length 0

Next 0x0(0)/0x0(0)

Last flood scan length is 0, maximum is 0

Last flood scan time is 0 msec, maximum is 0 msec

Neighbor Count is 0, Adjacent neighbor count is 0

Suppress hello for 0 neighbor(s)

So, as you say, the interface only shows up in one router. But, when I look at the database, I see:

7206F#sho ip ospf data router

OSPF Router with ID (10.1.1.1) (Process ID 20)

Router Link States (Area 200)

LS age: 186

Options: (No TOS-capability, DC)

LS Type: Router Links

Link State ID: 10.1.1.1

Advertising Router: 10.1.1.1

LS Seq Number: 80000001

Checksum: 0x8A9E

Length: 24

Number of Links: 0

OSPF Router with ID (144.1.1.1) (Process ID 10)

Router Link States (Area 100)

LS age: 198

Options: (No TOS-capability, DC)

LS Type: Router Links

Link State ID: 144.1.1.1

Advertising Router: 144.1.1.1

LS Seq Number: 80000001

Checksum: 0xAF4F

Length: 36

Number of Links: 1

Link connected to: a Stub Network

(Link ID) Network/subnet number: 10.1.1.0

(Link Data) Network Mask: 255.255.255.0

Number of TOS metrics: 0

TOS 0 Metrics: 1

Note that one shows a stub connection to 10.1.1.0/24, and the other one is using 10.1.1..1 as it's router id, with a length of 24. So, out of curiousity, I checked with a pair of connected routers, and found that only one of the two processes is advertising the loopback. Next I tried it with a normal interface, and found that it does the same thing here, so.... The only way to do this is to redistribute from one process into another.

Russ.W

Bronze

Re: Multiple OSPF instances problem

Have you tried 'redistribute connected' under the OSPF 10 process?

609
Views
0
Helpful
2
Replies