Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

My Interface VLANS keep going up, and then down!

I have an 1841 router and a 2950 switch and VLANing/trunking from scratch for the first time. Keep in mind that if you see any unnecessary config don't feel bad to point it out. I am just compiling bits and pieces of what I know and what I'm reading. I want 3 VLANS on the switch. VLAN1 is the default with all of the ports right now and working fine with forwarding? out of the box. I guess I will make this my management/native? VLAN when everything is moved over.

VLAN2 will be workstations 10.1.2.0 255.255.255.0

VLAN3 will be voice. 10.1.3.0 255.255.255.0

VLAN4 will be servers. 10.1.4.0 255.255.255.0

I have set port 0/48 on the switch as a trunk with the below config:

interface FastEthernet0/48

description SWT-RTR-TRUNK

switchport access vlan 2

switchport trunk allowed vlan 2-4

switchport mode trunk

switchport nonegotiate

spanning-tree portfast

!

Switch VLANS:

interface Vlan1

no ip address

no ip route-cache

shutdown

!

interface Vlan2

description Workstation VLAN

ip address 10.1.2.2 255.255.255.0

no ip route-cache

shutdown

!

interface Vlan3

description Voice VLAN

ip address 10.1.3.2 255.255.255.0

no ip route-cache

shutdown

!

interface Vlan4

description Server VLAN

ip address 10.1.4.2 255.255.255.0

no ip route-cache

shutdown

!

Router Config:

interface FastEthernet0/1

description Workstation IP

ip address 10.1.2.1 255.255.255.0

duplex auto

speed auto

!

interface FastEthernet0/1.1

description Voice IP

encapsulation dot1Q 3

ip address 10.1.3.1 255.255.255.0

no snmp trap link-status

!

interface FastEthernet0/1.2

description Server IP

encapsulation dot1Q 4

ip address 10.1.4.1 255.255.255.0

no snmp trap link-status

For like a few minutes, I was able to ping all interfaces on the router 4.1,3.1,2.1 from the switch. BUT, I was unable to ping the switch interfaces 4.2,3.2,2.2. So, I looked at the switch vlans... and they were all shutdown. I tried to no shutdown on lets say vlan4, and write mem and it's fine. I try to bring up another and 4 goes back to saying shutdown. The shutdown is hopping around and I cannot ping anything any more. Anyone know what I have wrong?

Thanks!

1 ACCEPTED SOLUTION

Accepted Solutions
Purple

Re: My Interface VLANS keep going up, and then down!

As previous poster said , the 2950 is a layer 2 switch only ,cannot do any routing . As such it can only have 1 ip address which is to manage the switch and nothing else , all routing between vlans is done by your router over your trunk link between the router and the 2950 so choose what you want the address to be to manage the switch and that is the only address you will need and why it keeps shutting all others down because only 1 active ip address is allowed . If you want the management ip to be an address in vlan 2 then you create the layer 3 SVI and put your interface on that interface . Delete all other layer 3 SVI's they are not needed. Also you will need to define your ip default-gateway pointing towards the router address of whatever vlan you decide to use for management.

3 REPLIES
Cisco Employee

Re: My Interface VLANS keep going up, and then down!

On a L2 switch such as 2950, you can have only one VLAN interface active. Since it cannot route, there is no value in having multiple VLAN interfaces. Just have one VLAN interface configured and use it for management(ping/telnet/snmp). The following page should help as well.

http://www.cisco.com/warp/public/473/8.html#topic4

Purple

Re: My Interface VLANS keep going up, and then down!

As previous poster said , the 2950 is a layer 2 switch only ,cannot do any routing . As such it can only have 1 ip address which is to manage the switch and nothing else , all routing between vlans is done by your router over your trunk link between the router and the 2950 so choose what you want the address to be to manage the switch and that is the only address you will need and why it keeps shutting all others down because only 1 active ip address is allowed . If you want the management ip to be an address in vlan 2 then you create the layer 3 SVI and put your interface on that interface . Delete all other layer 3 SVI's they are not needed. Also you will need to define your ip default-gateway pointing towards the router address of whatever vlan you decide to use for management.

New Member

Re: My Interface VLANS keep going up, and then down!

Thanks guys... makes sense. I killed all other vlans and set my management vlan to 10.1.2.2 and it worked fine!

Thanks again!

527
Views
4
Helpful
3
Replies
CreatePlease to create content