Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Mysterious Blockage - 2950 & 2900XL Switches

LAN has Switch A (2900XL) connected to Router. Switch B (2950) is connected to Switch A. Both switches only have VLAN1 and each has its own IP address. Network info: 192.168.2.0/255.255.255.0.

Switch A has server 192.168.2.8 and workstation 192.168.2.226 connected.

Switch B has workstations 192.168.2.13, 192.168.2.229, and printer 192.168.2.232 connected.

Cluster management is not enabled; trunk is not enabled between switches.

Symptoms:

192.168.2.13 can not ping or tracert 192.168.2.232 or 192.168.2.229. Can ping and tracert 192.168.2.8 and 192.168.2.226.

192.168.2.229 can not ping or tracert 192.168.2.232 or 192.168.2.13. Can ping and tracert 192.168.2.8 and 192.168.2.226.

192.168.2.8 can ping and tracert everyone.

Switch B can ping everyone but can not trace ip to 192.168.2.232.

Switch A can ping everyone but can not trace ip to 192.168.2.232.

MAC Address table on Switch B is empty.

MAC Address table on Switch A is populated.

This problem didn't used to exist but don't know what changes caused it. Any ideas?

1 ACCEPTED SOLUTION

Accepted Solutions

Re: Mysterious Blockage - 2950 & 2900XL Switches

This looks pretty default. You could try to reload the switch and I would add the following for each access-port:

switchport mode access

spanning-tree portfast

Please let me know if this helps, I will have another look at it tomorrow.

Regards,

Leo

6 REPLIES

Re: Mysterious Blockage - 2950 & 2900XL Switches

It looks as if the problem is with switch B.

All misbehaving nodes are on it and it's mac-table definitely should contain some adresses. It may have turned on the private vlan feature or something like that. Could you post the config of switch B?

Regards,

Leo

New Member

Re: Mysterious Blockage - 2950 & 2900XL Switches

Current configuration : 2208 bytes

!

! Last configuration change at 16:38:55 CST Thu Feb 2 2006

! NVRAM config last updated at 15:59:41 CST Thu Feb 2 2006

!

version 12.1

no service pad

service timestamps debug datetime localtime show-timezone

service timestamps log datetime localtime show-timezone

no service password-encryption

!

hostname ScheibMR

!

enable secret 5

!

clock timezone CST -6

clock summer-time CDT recurring

ip subnet-zero

!

spanning-tree extend system-id

!

!

interface FastEthernet0/1

description Community

no ip address

!

interface FastEthernet0/2

description Bea-II (not used)

no ip address

!

interface FastEthernet0/3

description Carmilita

no ip address

!

interface FastEthernet0/4

description Jodie

no ip address

!

interface FastEthernet0/5

description Nurse

no ip address

!

interface FastEthernet0/6

description Conference

no ip address

!

interface FastEthernet0/7

description Laura

no ip address

!

interface FastEthernet0/8

description Darleen

no ip address

!

interface FastEthernet0/9

description Printer (4100)

no ip address

!

interface FastEthernet0/10

description Behavior

no ip address

!

interface FastEthernet0/11

description Bea-I

no ip address

!

interface FastEthernet0/12

description Brenda

no ip address

!

interface FastEthernet0/13

description Printer (4000)

no ip address

!

interface FastEthernet0/14

description Donna

no ip address

!

interface FastEthernet0/15

description Michele

no ip address

!

interface FastEthernet0/16

description Susan

no ip address

!

interface FastEthernet0/17

no ip address

!

interface FastEthernet0/18

no ip address

!

interface FastEthernet0/19

no ip address

!

interface FastEthernet0/20

no ip address

!

interface FastEthernet0/21

no ip address

!

interface FastEthernet0/22

no ip address

!

interface FastEthernet0/23

no ip address

!

interface FastEthernet0/24

description Scheib MH Switch

no ip address

!

interface Vlan1

ip address 192.168.2.3 255.255.255.0

no ip route-cache

!

ip default-gateway 192.168.2.2

ip http server

!

snmp-server engineID local 800000090300000AF4FABF01

!

line con 0

line vty 0 4

password

login

line vty 5 15

password

login

!

ntp clock-period 17179909

ntp server 128.249.1.1

end

Re: Mysterious Blockage - 2950 & 2900XL Switches

This looks pretty default. You could try to reload the switch and I would add the following for each access-port:

switchport mode access

spanning-tree portfast

Please let me know if this helps, I will have another look at it tomorrow.

Regards,

Leo

New Member

Re: Mysterious Blockage - 2950 & 2900XL Switches

I rebooted the switch and the mac-address-table was instantly populated and the other problems went away. Thanks.

New Member

Re: Mysterious Blockage - 2950 & 2900XL Switches

I rebooted the switch and the mac-address-table was instantly populated and the other problems went away. Thanks.

New Member

Re: Mysterious Blockage - 2950 & 2900XL Switches

I rebooted the switch and the mac-address-table was instantly populated and the other problems went away. Thanks.

147
Views
0
Helpful
6
Replies
CreatePlease login to create content