Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

NAT and 2 ISP configuration with the same router

Hi,

I have a Router Cisco 801 with a simple ISP connection.

Now i want to add a new connection to a Global Extranet (like a second ISP).

I have configure two Interface Dialer and two Access lists like this :

interface Ethernet0

ip address 192.168.100.100 255.255.255.0

ip nat inside

....

interface BRI0

no ip address

ip nat outside

encapsulation ppp

dialer pool-member 1

dialer pool-member 2

ppp authentication chap pap callin

...

Interface Dialer 1

description ISP 1

ip address negotiated

ip nat outside

dialer pool 1

dialer-group 1

dialer string ....

.....

Interface Dialer 2

description ISP 2

ip address negotiated

ip nat outside

dialer pool 2

dialer-group 2

dialer string ....

.....

ip nat inside source list 145 interface Dialer1 overload

ip nat inside source list 155 interface Dialer2 overload

ip route 0.0.0.0 0.0.0.0 Dialer1

ip route 160.92.0.0 255.255.0.0 Dialer2

!

access-list 145 permit ip any any

access-list 155 permit ip any any

dialer-list 1 protocol ip list 145

dialer-list 2 protocol ip list 155

!

(.... : Command not important for the understanding of the problem )

-----------------

Here is the explanation of my problem :

Ping doing on the router :

TEST 1:

1) ping www.cisco (bind with dialer 1) --> OK

Waiting for Isdn line down,then

2) ping 160.92.1.1 (bind with dialer 2) --> OK

TEST 2:

1) ping www.cisco (bind with dialer 1) --> OK

2) ping 160.92.1.1 (bind with dialer 2) --> No response

Conclusion

I can't access to my global Extranet if i'm connected to Internet.

With this configuration, I think of having a problem with NAT.

How can i correct my problem if a solution exist. Or Troubleshoot the connection.

Thanks for help

1 REPLY
New Member

Re: NAT and 2 ISP configuration with the same router

Do you know what IP addresses you'll be hitting on your Extranet? If you do, you could use route-maps instead of access-lists in your NAT statement. This will let you NAT by destination.

You shouldn't use extended access-lists to try to NAT by destination.

Mick.

128
Views
0
Helpful
1
Replies
CreatePlease login to create content