Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

NAT and MLPPP not working correctly

I have a VERY weird problem. I have this kind of setup on 6 locations, and on two, I have the weirdest problems.

routers: C2610

IOS: 12.0.7T

When contacfting our mail server (SMTP), from a NAT:ed IP, the "conversation" always dies after rcpt to is sent to the mail server. I have setup ACLs and the 'debug ip packet ACL detailed' to see what happens, and I see the packets arriving from the mail server, and also the retransmissions. But somehow, they just dont seem to get thru. Not even if I do a telnet from the C2610, using the NAT:ed IP as the source-interface (telnet mail 25 /source-interface eth0/0). But, as I said, I do se the packets from the debug, so they do arrive anyway. If I do a telnet mail 25 (hence using the outside interface), everything works like a charm.

If I shutdown one of the 2 MLPPP links, everything works like it should with NAT:ed addresses.

As I said, I am running MLPPP w/ 2 links at 6 different location, but on 2 of them, I get this weird problem.

Any suggestions?

1 REPLY
New Member

Re: NAT and MLPPP not working correctly

I might ad that I tried upgrading to 12.1.16 , but then no NAT:ed traffic worked at all. At least with 12.0.7T one can surf the web etc, but with 12.1.16, all connections just got resetted all the time (RST sent, I would assume from the router, killing the connection).

87
Views
0
Helpful
1
Replies