Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

NAT and XWINDOWS problem

Hello,

I have got two UNIX workstations connected by two CISCO 803 ISDN routers. I would like to display from one workstation to another by using XWINDOWS. If I try it without NAT it works fine, but if I use NAT, the XWINDOWS server can't find the client on the other side. There is any way to allow redirect the display from one workstation to another using NAT at the same time?

Worstation A --- CISCO803 A -----ISDN ------ CISCO803 B ----- Workstation B

CISCO803 A: all traffic get out with the same IP address (using NAT)

In Workstation B:

setenv DISPLAY workstationA:0

xclock (application to display time)

Error, can't open display.

In Workstation A: anything happens

Thanks a lot

6 REPLIES
Bronze

Re: NAT and XWINDOWS problem

I vaguely recall Xwindows uses TCP and UDP port 6000. See if a static NAT entry for the port number makes it to work. Configs from both the 800 routers could also

help us help you.

~Zulfi

New Member

Re: NAT and XWINDOWS problem

Hello, thanks a lot for your help.

This is the configuration router:

Current configuration

!

version 12.1

no service pad

service timestamps debug datetime msec

service timestamps log datetime msec

service password-encryption

!

hostname prueba

!

boot buffersize 8056

boot system flash c800-y6-mw.121-2.T.bin

logging buffered 4096 debugging

no logging console

!

username ......

!

!

!

!

ip subnet-zero

!

no ip domain-lookup

isdn switch-type basic-net3

!

!

!

interface Loopback0

ip address 172.24.99.1 255.255.255.0

!

interface Ethernet0

ip address 10.202.136.39 255.255.224.0

no ip redirects

ip nat inside

no cdp enable

!

interface BRI0

no ip address

encapsulation ppp

dialer pool-member 1

isdn switch-type basic-net3

no cdp enable

ppp authentication chap

!

!

interface Dialer80

description REMOTE ACCESS

ip unnumbered Loopback0

ip nat outside

encapsulation ppp

dialer pool 1

dialer idle-timeout 300

dialer string XXXXXX

dialer caller XXXXXX

dialer max-call 4096

dialer-group 1

no cdp enable

ppp authentication chap

!

!

ip nat translation timeout 120

ip nat inside source list 101 interface Loopback0 overload

no ip http server

ip classless

ip route 10.202.136.0 255.255.255.0 Ethernet0

ip route 192.100.1.0 255.255.255.0 Dialer80

access-list 101 permit ip any any

dialer-list 1 protocol ip list 101

no cdp run

!

line con 0

exec-timeout 0 0

transport input none

stopbits 1

line vty 0 3

exec-timeout 0 0

password 7

login

line vty 4

no exec-banner

exec-timeout 0 0

password 7

login

!

rcapi server port 2578

!

!

end

The configuration on the other side is symmetric.

Do you mean something as:

ip nat outside source static tcp 172.24.99.1 6000 10.202.136.102 6000

don't you?

Bronze

Re: NAT and XWINDOWS problem

Yes, thats what I meant. Any luck yet with this?

~Zulfi

New Member

Re: NAT and XWINDOWS problem

Hello Mr. Zulfi,

I tried that, but it doesn't work:

Current configuration

!

version 12.1

no service pad

service timestamps debug datetime msec

service timestamps log datetime msec

service password-encryption

!

hostname routerA

!

boot buffersize 8056

boot system flash c800-y6-mw.121-2.T.bin

logging buffered 4096 debugging

no logging console

!

username routerB......

!

!

!

!

ip subnet-zero

!

no ip domain-lookup

isdn switch-type basic-net3

!

!

!

interface Loopback0

ip address 172.24.99.1 255.255.255.0

!

interface Ethernet0

ip address 10.202.136.39 255.255.224.0

no ip redirects

ip nat inside

no cdp enable

!

interface BRI0

no ip address

encapsulation ppp

dialer pool-member 1

isdn switch-type basic-net3

no cdp enable

ppp authentication chap

!

!

interface Dialer80

description REMOTE ACCESS

ip unnumbered Loopback0

ip nat outside

encapsulation ppp

dialer pool 1

dialer idle-timeout 300

dialer string XXXXXX

dialer caller XXXXXX

dialer max-call 4096

dialer-group 1

no cdp enable

ppp authentication chap

!

!

ip nat translation timeout 120

ip nat inside source list 101 interface Loopback0 overload

ip nat outside source static tcp 172.24.99.1 6000 192.100.1.25 6000

no ip http server

ip classless

ip route 10.202.136.0 255.255.255.0 Ethernet0

ip route 192.100.1.0 255.255.255.0 Dialer80

access-list 101 permit ip any any

dialer-list 1 protocol ip list 101

no cdp run

!

line con 0

exec-timeout 0 0

transport input none

stopbits 1

line vty 0 3

exec-timeout 0 0

password 7

login

line vty 4

no exec-banner

exec-timeout 0 0

password 7

login

!

rcapi server port 2578

!

!

end

I telnet from a PC 10.202.136.36 behind of router A to the IP 192.100.1.25 behind of router B.

Router B doesn't use NAT.

Then, from PC 192.100.1.25, I redirect its display to PC10.202.136.36 but when I execute any application using XWIN, PC10.202.136.36 doesn't receive anything. I used two sniffers in both sides and I checked that XWIN traffic goes from PC 192.100.1.25 to 172.24.99.1 but not to PC10.202.136.36 ????

Thanks a lot

Bronze

Re: NAT and XWINDOWS problem

Juan, I think its about time you open up a case on this issue. Xwindows has this problem as a well known issue in conjunction with NAT/PAT. Generally a static NAT entry makes it to work but I think we are missing something here. This is all due to the complex nature of Xwindows since it embeds IP addresses in payload, which is problematic when it comes to NAT.

~Zulfi

New Member

Re: NAT and XWINDOWS problem

OK, I will try to open up a case.

Thanks a lot anyway.

125
Views
0
Helpful
6
Replies
CreatePlease login to create content