Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

NAT? Connecting two sites with same private ip range over a serial line

Hi,

We need a connection between our site and the client site. Problem is that both sides use the 172.16.0.0 network/subnet.

Can this be solved by NAT and how?

Did'nt find some info on NAT regarding translation from private to private.

Maybe this could be solved if we had two public ip address for the serial interface I think, but we haven't.

Thanks for your advice

  • Other Network Infrastructure Subjects
6 REPLIES
Green

Re: NAT? Connecting two sites with same private ip range over a

Yes, it can be done. CIsco presents this situation in their classes as (one of many) reasons for using NAT.

I believe you need to NAT at each end with a static one-to-one mapping (inside 172.16.x.x address --> WAN address --> outside maps to inside hosts, repeat this in the other direction).

Ultimately, I think DHCP is gonna be your best friend .....

Good Luck

Scott

New Member

Re: NAT? Connecting two sites with same private ip range over a

Hi, Try something like this. It has worked for me

Router A

interface Tunnel0

ip address 192.168.100.1 255.255.255.0

no ip directed-broadcast

tunnel source serial0/0

tunnel destination 10.x.x.x

Router B

interface Tunnel0

ip address 192.168.100.2 255.255.255.0

no ip directed-broadcast

tunnel source serial0/0

tunnel destination 10.x.x.x

Hope this helps

Stephen

http://www.sraymond.net

Re: NAT? Connecting two sites with same private ip range over a

New Member

Re: NAT? Connecting two sites with same private ip range over a

If you have 2 networks with the same IP network, broadcast will travel over the WAN/MAN link. If you have a busy network you will saturate the link with broadcasts. I don't see how NAT would help you here.

Please explain.

Re: NAT? Connecting two sites with same private ip range over a

Broadcasts never traverse a WAN link, unless the router acts as a bridge Because routers terminate broadcasts.

In this case, NAT works in conjunction with DNS. When both ends use, ip address from same subnet, the end host cannot use the ip address to communicate, because, if they do , then the packets will never reach the router, because the host thinks the destination is in its local subnet.

Check the document....which would clearly describes, how communication between overlapping networks is achieved using NAT. The inside host is translated into a diff pool, while the outside host is translated from a diff pool.NAT checks even the payload of the DNS reply, from the DNS server

New Member
212
Views
0
Helpful
6
Replies
This widget could not be displayed.