Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

nat on 1700

i have this scenario

incoming trafic------1700-------server

i have a 1700 with 2 ethernet interface with ip address IP_A and IP_B consecutively. A server is on subnet of the B interface.

What i want is any incoming traffic on interface A should be translated to the server IP address.

thanks for your help in advance.

4 REPLIES
VIP Purple

Re: nat on 1700

Hello,

the config should look something like this (the IP addresses are probably different from the ones you actually have in use):

interface Ethernet0/0

description connection to Lan_A

ip address 192.168.1.1 255.255.255.0

ip nat inside

!

interface Ethernet0/1

description connection to Lan_B

ip address 192.168.2.1 255.255.255.0

ip nat outside

!

ip nat pool SERVER 192.168.2.10 192.168.2.10 prefix 24

!

ip nat inside source list 1 pool SERVER overload

!

access-list 1 permit 192.168.1.0

Can you try and see if this works for you ? As I said, the IP address of the server in this example is 192.169.2.10/24, this might be different in your network, as are probably also the addresses of both Ethernet interfaces...

HTH,

GP

New Member

Re: nat on 1700

hello,

whats the "prefix 24" mean on your ff. line;

ip nat pool SERVER 192.168.2.10 192.168.2.10 prefix 24

thanks

VIP Purple

Re: nat on 1700

Hello,

prefix 24 is the same as 'netmask 255.255.255.0'. It is just the subnet mask of the IP address.

HTH,

GP

New Member

Re: nat on 1700

it was a very good info..thanks a lot.

117
Views
4
Helpful
4
Replies