Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

nat on a stick help

I'm attempting to configure nat on a stick w/ no luck. I need my internal nat clients on e0 192.168.0.0/24 to be able to access a web site on the external ip, 1.2.3.4/30...

I've looked over some advice of others and have come up with the below. This *should* allow people connecting on e0 to view the web page on the internal host 192.168.0.3/24. Instead I get zip.....

ip nat pool ISP 192.168.100.2 192.168.100.254 prefix-length 24

ip nat pool INTERNAL 192.168.200.1 192.168.200.254 prefix-length 24

ip nat inside source list 101 pool ISP

ip nat outside source list 102 pool INTERNAL

ip nat inside source static 192.168.0.3 192.168.100.1

!

Interface E0

ip address 192.168.0.100 255.255.255.0

ip nat inside

!

Interface e1

ip address 1.2.3.4 255.255.255.252

ip nat outside

!

Loopback0

ip address 10.0.0.1 255.255.255.0

ip nat outside

!

access-list 101 deny ip 192.168.0.0 0.0.0.255 host 192.168.100.1

access-list 101 permit ip 192.168.0.0 0.0.0.255 any

access-list 102 permit ip 192.168.0.0 0.0.0.255 host 192.168.100.1

!

ip route 192.168.100.1 255.255.255.255 loopback0

ip route 192.168.200.0 255.255.255.0 loopback0

1 REPLY
Silver

Re: nat on a stick help

I hope this is not the correct configuration for NAT on a Stick.You need to apply policy routing. Refer to this doc for more information....

http://www.cisco.com/en/US/tech/tk648/tk361/technologies_tech_note09186a0080094430.shtml

98
Views
0
Helpful
1
Replies