Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

NAT on Cisco 1721

Here is my situation:

Cisco 1721 connected to linksys cable modem on WIC0 ethernet connection gaining IP via DHCP. Fastethernet0 connected to local LAN.

Problem:

From my laptop connected to the LAN if I ping a website such as google.com, it resolves it to an IP address but times out with the packets.

I am trying to set up NAT on the cisco but can't figure what I am missing.Below is a copy of the running config.

Any help would be greatly appreciated, I have been working on this for 2 days straight now.

Current configuration : 861 bytes

!

version 12.2

service timestamps debug uptime

service timestamps log uptime

!

hostname EHS

!

enable secret 5 #########################

!

ip subnet-zero

ip name-server 24.116.0.63

ip name-server 24.116.0.82

ip name-server 24.116.0.201

!

!

!

!

interface Ethernet0

description #WAN Connection#

ip address dhcp

ip nat outside

half-duplex

!

interface FastEthernet0

description #LAN Connection#

ip address xxx.xxx.xxx.1 255.255.255.0

ip nat inside

speed auto

!

router rip

version 2

network 10.0.0.0

network 192.168.101.0

!

ip nat inside source list 101 interface Ethernet0 overload

ip classless

ip route 0.0.0.0 0.0.0.0 10.120.144.1

no ip http server

!

!

access-list 101 permit ip any any

!

line con 0

password ##############################

login

line aux 0

line vty 0 4

password #############################

login

!

no scheduler allocate

end

3 REPLIES
New Member

Re: NAT on Cisco 1721

ip route 0.0.0.0 0.0.0.0 10.120.144.1

I would double check that statement. I had the same issue, and that was the cause. I am assuming you have someone like comacst for cable. Well you cable modem is getting the 10.x.x.x address and your router is getting the real address 68.x.x.x. Best way to determine this is to either remove the route statement or at bootup have debug dhcp detailed on to find the real gateway.

New Member

Re: NAT on Cisco 1721

The problem was the IP address I was recieving from Cableone. They make you register you MAC address before handing out a routeable IP address. I had to change the MAC address of my outside interface to match that of a registered NIC. Everything is working now.

Thanks

New Member

Re: NAT on Cisco 1721

I had a similar problem... and go to the linksys config and on the dynamic routing tab enable RIP2. That seemed to make a diff for me...

ricardo

99
Views
0
Helpful
3
Replies
CreatePlease to create content