Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Community Member

NAT overload with Cisco Router

Hi, I have a couple of questions, first I have a Cisco Soho 77 ADSL that I want to setup as a Web server in my PC. I have a cable connection and my ISP seems to block port 80, I tried a lot of stuff to setup my web server, like using Dynamic DNS service www.dynu.com or www.no-ip.com and others, I tried to open my port in my router but I think I have done something wrong since I lost Internet connection to my ISP. Also I can't access my web server from other PCs.

This is my router Configuration.

Current configuration : 1118 bytes

!

version 12.2

no service pad

service timestamps debug uptime

service timestamps log uptime

service password-encryption

!

hostname Client_Name

!

enable secret 5 $$$$$$$$$$$$$$$$$.

!

mmi polling-interval 60

no mmi auto-configure

no mmi pvc

mmi snmp-timeout 180

ip subnet-zero

!

ip dhcp pool dsl1

network 192.168.25.0 255.255.255.0

default-router 192.168.25.1

domain-name intelnet.net.gt

dns-server 216.230.128.3 216.230.128.32

!

!

!

!

interface Ethernet0

no shut

ip address 192.168.25.1 255.255.255.0

ip nat inside

!

interface ATM0

no shut

description Cliente_No.de Serie_DSLAM_Puerto DSLAM_ TEL

ip address 10.28.1.30 255.255.255.252

ip nat outside

no atm ilmi-keepalive

pvc 0/32

protocol ip 10.28.1.29

encapsulation aal5snap

!

dsl operating-mode auto

hold-queue 224 in

!

ip nat inside source list 101 interface ATM0 overload

ip classless

ip route 0.0.0.0 0.0.0.0 10.28.1.29

no ip http server

!

access-list 101 permit ip 192.168.25.0 0.0.0.255 any

!

line con 0

stopbits 1

line vty 0 4

password thepassword

login

!

scheduler max-task-time 5000

end

What might be the problem? What do I need to change to open a different Port?

Thanks.

4 REPLIES
Community Member

Re: NAT overload with Cisco Router

I don't understand what you are trying to do. Are trying to set up an http session to the router itself? If that is the case remove the no ip http server line from your config. If not I need a clarification since all your IP addresses are private and you will not have that server on internet

Community Member

Re: NAT overload with Cisco Router

Hi, Thanks for your reply.

I have a private IP, I know there is a Dynamic DNS service like http://www.tzo.com, http://www.dynu.com or http://www.no-ip.com, where I may not need a static IP address. With the Dynamic DNS service I can host a web site, email server, FTP server and more at my location even if I have a dynamic IP address.

The Dynamic DNS service consists of two parts, client software which runs on my server and the Dynamic DNS servers, part of the Internet domain name system. When my IP address changes the client software reports that change to the dynamic DNS servers and the dynamic DNS servers resolve requests for my domain to my current IP address.

I'm have tried this service but it has not worked form me, I think my router configuration is not correct for this service. I will appreciate your help very much.

Thanks

Community Member

Re: NAT overload with Cisco Router

Hi,

I would like to know if the above configuration was working before you did the changes.I hope you have the global ip addresses your ISP has provided you ?

Community Member

Re: NAT overload with Cisco Router

Thanks for your reply. I have not changed the above configuration yet. I would like to know if I need to make some change to it, someone told me that I need to do is a reverse mapping NAT, what do you think? and if is, how can I change the current config?, and I think that my global IP is 216.230.149.X, I have found in www.showmyip.com it is correct?

Thanks a lot.

646
Views
0
Helpful
4
Replies
CreatePlease to create content