Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

NAT problem

I am studying NAT configuration and have setup two routers for in/out NAT and redundancy. I want to setup the LAB likes this, if the R1(2509) wan link goes down, the floating route come up and the traffic are route through R2 (3700).

But I have a problem on R1 when the wan link is DOWN. The traffic does’t routes to R2 even the correct route shown in the routing table.

When I ping the remote host (192.168.80.3), R1 just simply reply the icmp directly (it acts as the remote host), but the traffic does’t transmitted to the target host…

If I replaced the R1 with a Cisco 3700 then the fail over working well….

If I removed the “ip nat outside source” statement and access the remote host directly (192.168.60.1), the fail over working too. .

Anyone tell me why the configuration does't work on the 2509 ?

R1 – 2509 12.1(27a)

R2 – 3700 12.3(15)

Here is the configuration of the R1.

interface Loopback1

ip address 192.168.80.2 255.255.255.255

!

interface Ethernet0

ip address 192.168.50.245 255.255.255.0

ip nat inside

!

interface Serial0

ip address 192.168.20.166 255.255.255.0

ip nat outside

encapsulation ppp

no ip mroute-cache

!

ip nat inside source static 192.168.50.147 192.168.80.7

ip nat inside source static 192.168.50.146 192.168.80.6

ip nat outside source static 192.168.60.1 192.168.80.3

ip classless

ip route 192.168.60.1 255.255.255.255 Serial0

ip route 192.168.60.1 255.255.255.255 192.168.50.254 20

ip route 192.168.80.3 255.255.255.255 192.168.60.1

1 REPLY
New Member

Re: NAT problem

very strange.... after rebooted the router, it works!

103
Views
0
Helpful
1
Replies