Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

NAT query

Hi,

If I have the following scenario, will the configuration below work?

TIA

PF

The IP on vlan 2 access a server on vlan 3, the source IP from Vlan 2 must be translated to a pool (pool1) of IP addresses. Similary if the IP on vlan 2 access a server on vlan 4, the source IP from vlan 2 must be translated to vlan4 interface IP address. Is the below configuration correct?

access-list 160 permit ip 192.168.10.0 0.0.0.255 host 172.16.10.10

access-list 165 permit ip 192.168.10.0 0.0.0.255 host 10.20.20.20

route-map loc3 permit 10

match ip address 160

route-map loc4 permit 10

match ip address 165

ip nat pool pool1 10.10.200.20 10.10.200.254 netmask 255.255.255.0

ip nat inside source static 192.168.10.10 10.10.200.10

ip nat inside source route-map loc3 pool pool1

ip nat inside source route-map loc4 interface Vlan4 overload

int vlan 2

ip address 192.168.10.1 255.255.255.0

ip nat inside

int vlan 3

ip address 172.16.10.1 255.255.255.0

ip nat outside

int vlan 4

ip address 10.10.10.10 255.255.255.0

ip nat outside

2 REPLIES
VIP Purple

Re: NAT query

Hello,

the config looks perfectly ok...do you have a specific problem, or are you just doing a pre-implementation check ?

Regards,

GP

New Member

Re: NAT query

GP,

Thanks for the reply. I was just doing a pre-implementation check. I had it implemented and it is working fine. Thanks very much.

PF

81
Views
0
Helpful
2
Replies