Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Nat Question

I'm trying to Nat a few machines in a remote location, attached by a point to point T1. I cannot ping the through the NAT though attached is my config, even though all of the other connectivity is intact. The other end of the serial link is 172.20.246.2 .

show config

Using 900 out of 29688 bytes

!

version 12.1

service timestamps debug uptime

service timestamps log uptime

no service password-encryption

!

hostname xxxxx

!

enable secret 5 $1$xxxxxxxxxxxxx

enable password xxxxxx

!

!

!

!

!

memory-size iomem 25

ip subnet-zero

!

!

!

!

interface Serial0

ip address 172.20.246.1 255.255.255.0

ip nat outside

no fair-queue

!

interface FastEthernet0

ip address 192.215.230.1 255.255.255.0

ip nat inside

speed auto

!

router eigrp 100

network 192.168.3.0

auto-summary

no eigrp log-neighbor-changes

!

ip nat pool hp 172.20.246.3 172.20.246.250 netmask 255.255.255.0

ip nat inside source list 9 pool hp

ip nat inside source static 192.215.230.20 172.20.246.20

ip classless

ip route profile

ip route 0.0.0.0 0.0.0.0 172.20.246.2

no ip http server

!

access-list 9 permit 192.215.230.0 0.0.0.255

!

line con 0

line aux 0

line vty 0 4

password xxxxx

login

!

no scheduler allocate

end

  • Other Network Infrastructure Subjects
4 REPLIES
Silver

Re: Nat Question

Your internal addresses are 192.215.230.0 and you want them to appear as 172.20.246.X from outside?

Your serial link and NAT spaces overlap. Is it possible to /30 the serial link ips and put a route for rest of 172.20.246?

Rais.

New Member

Re: Nat Question

I had done it that way originally, using 192.168.3.24/30, and added static routes for the 172.20.246, it still does not seem to translate.

Silver

Re: Nat Question

internal Network( 192.215.230.X) ----ROUTER------External Network

Again your config will NAT 192.215.230.X(public) to 172.20.246 (private).

1. Do you have a route for 172.20.246.X in your external network?

2. Is 192.215.230.20 getting NATed?

3. What do you get when you debug Ip NAT.

4. Try pinging the router from both sides and debug icmp. See which side packets are acting abnormal.

Thanks.

New Member

Re: Nat Question

The clinet machines were not configured with a default gateway. No wonder they never replied to pings.

108
Views
0
Helpful
4
Replies
This widget could not be displayed.