Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

NAT Trouble

I have a serial ip of 160.x.x.x and a pool of 25 IP's e0 207.x.x.x/25 on a 2620. I need to setup up nat and make all of my internal IP's Class c Private. I also need to 207.x.x.10 to point to an internal mail server at 192.168.0.10. Any help would be greatly appreciated.

2 REPLIES
New Member

Re: NAT Trouble

How many internal PCs do you have? Less than 20?

Here's an example of a setup for one static NAT (mail server) and PAT (port address translation).

interface serial0

ip address 160.x.x.x 255.255.255.252

ip nat outside

!

interface ethernet0

ip address 10.1.1.1 255.255.255.0

ip nat inside

!

ip nat inside source static 10.1.1.2 207.x.x.1

ip nat inside source list 1 pool nat-pool overload

ip nat pool nat-pool 207.1.1.3 207.1.1.3 netmask 255.255.255.128

access-list 1 deny 10.1.1.2 0.0.0.0

access-list 1 permit 10.0.0.0 0.255.255.255

Like I said... this is just an example, but it should give you a start.

If you have less than 20 PCs, you can make the pool equal to the number of PCs you have like:

ip nat pool nat-pool 207.x.x.3 207.x.x.18 netmask 255.255.255.128

and omit the "overload" from the "ip nat inside source list" config directive.

Mick.

PS... should have used 192.168 instead of 10.x for your case, but I spaced... :)

Blue

Re: NAT Trouble

This should do it

interface ethernet 0

ip address x.x.x.x 255.255.255.0

ip nat inside

!

interface serial 0

ip address 160.x.x.x 255.255.255.0

ip nat outside

!

ip nat pool ovrld 207.x.x.x-207.x.x.x prefix 25

ip nat inside source list 1 pool ovrld overload

ip nat inside source static tcp 192.168.0.10 207.x.x.10 25

!

access-list 7 permit 192.168.0.0 0.0.0.255

80
Views
0
Helpful
2
Replies