Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Community Member

NAT with Secondary IP on 2620

I have a 2620 that has a T1 on serial 0 and then a Public network IP 63.X.X.X on Fa0/0 with a /27 subnet. My question is I want to set up a secondary IP on fa0/0 ie: 10.10.20.X. I want to use NAT for my private network with the translations from the 10.10.20.X network to the public network on fa0/0. Is this set up possible? Sorry but I have a hard time explaining things maybe I can clarify better in an email offline. thanks

1 REPLY
Community Member

Re: NAT with Secondary IP on 2620

I am not quire sure what you mean by this, but I hope this may answer your question. When you do NAT on an interface, I have had problems with secondary IP blocks not passing to the interface with NAT. Even if you put the ip address secondary on the interface, you cannot route to it. I have gotten around this problem with using:

interface Serial0

ip address 10.10.22.2 255.255.255.0

ip access-group 111 in

no ip directed-broadcast

ip nat outside

!

interface FastEthernet0

ip address 192.168.10.1 255.255.255.0 secondary

ip address 192.168.1.10 255.255.255.0

ip access-group 1 in

no ip directed-broadcast

ip nat inside

full-duplex

!

ip nat pool FSE-natpool-1 xxx.xxx.xxx.xxx xxx.xxx.xxx.xxx netmask 255.255.255.0

ip nat inside source list 1 pool FSE-natpool-1 overload

ip nat inside source static 192.168.1.6 xxx.xxx.xxx.xxx no-alias

ip route 0.0.0.0 0.0.0.0 10.10.22.1

ip route 192.168.10.1 255.255.255.0 FastEthernet0

Notice the (ip route 192.168.10.1 255.255.255.0 FastE0). This was done because the block was not routing through the NAT and was getting kicked out.

Let me know if this is not what you are looking for.

-Ryan

147
Views
0
Helpful
1
Replies
CreatePlease to create content