Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

NAT with two Internet interfaces

I have a Cisco 4700 with IOS 12.2(2)T1 with 3 ethernet ports. The F0 port is the local privately address network and the other two Ethernet ports are used to connect to two different DSL circuits, which one is a backup to the other. I would like to do NAT on the router for the local LAN but I did notice that when I have the two "nat inside source" statements the router won't translate the traffic from the local network. If I remove one of them all works fine. I thought this would be a problem, but is there a way of having my configuration work or what I intend to do?

Thanks for any help.

Jeff

interface Ethernet0

description **Internet DSL 1**

ip address xxx.yyy.21.6 255.255.255.224

ip nat outside

media-type 10BaseT

no cdp enable

!

interface Ethernet1

description **Internet DSL 2**

ip address aaa.bbb.25.93 255.255.255.0

ip nat outside

media-type 10BaseT

no cdp enable

!

interface FastEthernet0

description ***Ethernet LAN***

ip address 192.168.1.1 255.255.255.0

ip nat inside

half-duplex

no cdp enable

!

ip nat inside source list 1 interface Ethernet0 overload

ip nat inside source list 2 interface Ethernet1 overload

ip classless

ip route 0.0.0.0 0.0.0.0 xxx.yyy.21.1

ip route 0.0.0.0 0.0.0.0 aaa.bbb.25.1 100

!

access-list 1 permit 192.168.1.0 0.0.0.255

access-list 2 permit 192.168.1.0 0.0.0.255

3 REPLIES
Silver

Re: NAT with two Internet interfaces

You can use route-map , match ip address and you can to Nat for two extewrnal interfcaes

route-map leaseline permit 5

match ip address 1

match interface Serial0/0

route-map isdnbackup permit 10

match ip address 2

match interface Dialer1

access-list 1 permit 192.168.0.0 0.0.255.255

access-list 2 permit 192.168.0.0 0.0.255.255

New Member

Re: NAT with two Internet interfaces

Thanks for info. Would this be an addition to my existing configuration, especially with the two "ip nat inside source" commands? I know having the two "ip nat inside source" commands are causing me a problem.

Thanks for any help.

Jeff

Gold

Re: NAT with two Internet interfaces

You would use the route maps on your ip nat inside source statements:

ip nat inside source route-map pool ...

http://www.cisco.com/en/US/tech/tk648/tk361/technologies_tech_note09186a0080093fca.shtml

Details information on this capability. It should work for what you want.

:-)

Russ.W

89
Views
0
Helpful
3
Replies
CreatePlease login to create content