Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

Nat with X.25

Hi,

I have configured NAT for tcp load balancing, but something went wrong.

I have two servers running w2k and several users running w2k too that connect using ip over x.25. My router configuration looks like this :

interface Loopback0

ip address 172.16.0.1 255.255.255.0

!

interface FastEthernet0/0

ip address 192.168.0.75 255.255.255.0

ip nat inside

speed auto

full-duplex

no cdp enable

!

interface Serial0/0

bandwidth 64

ip address 10.1.1.1 255.255.255.0

ip nat outside

encapsulation x25

x25 address 1113061

x25 htc 50

x25 idle 1

!remote cliente

x25 map ip 10.1.1.3 1113075

no cdp enable

!

interface FastEthernet0/1

no ip address

shutdown

duplex auto

speed auto

no cdp enable

!

interface Serial0/1

no ip address

shutdown

no cdp enable

!

router ospf 100

log-adjacency-changes

network 192.168.0.75 0.0.0.0 area 0

network 172.16.0.1 0.0.0.0 area 0

!

ip nat pool real-hosts 192.168.0.8 192.168.0.9 netmask 255.255.255.0 type rotary

ip nat inside destination list 2 pool real-hosts

ip classless

ip route 10.1.1.0 255.255.255.0 10.1.1.2

ip http server

ip pim bidir-enable

!

!

access-list 2 permit 10.1.1.222

dialer-list 1 protocol ip permit

dialer-list 1 protocol ipx permit

no cdp run

!

line con 0

exec-timeout 0 0

line aux 0

line vty 0 4

password cisco

login

!

!

end

The problem is that I can't ping the address 10.1.1.222 from the remote client. However i ping successfuly the addresses in the pool real-hosts.

When I ping from the servers to the remote client debug ip nat detailed don´t show anything.

Can you please help?

Thank's in advance

David

4 REPLIES

Re: Nat with X.25

The following NAT command will only translate TCP flows.

ip nat inside destination list 2 pool real-hosts

Ping packets are ICMP so they will not get translated.

Mike.

New Member

Re: Nat with X.25

Thank you Mike, a lot.

I will try telnet and other tcp aplications to test the configuration.

Silver

Re: Nat with X.25

Could you please confirm if this is the situation, as I wanted to disagree. Thank you

New Member

Re: Nat with X.25

Yes,

I have successfully access my webserver ( 2 actually) using a browser. So it works with tcp aplications. I would like to know if you have any other sugestions.

David

119
Views
4
Helpful
4
Replies
CreatePlease to create content