Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

NAT

Hi,

Static Nat is working, however dynamic NAT is not working in following config. Why is dynamic NAT not working in this config?

I can ping from workstation with static private address 193.168.1.5/24 to the e0/0 int 193.168.1.1. The above does not ping successfully to s1/0 int 200.200.100.1 on router.

Thanks.

Said

NAT#sh run

Building configuration...

Current configuration : 1031 bytes

!

version 12.3

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname NAT

!

boot-start-marker

boot-end-marker

!

!

no aaa new-model

ip subnet-zero

ip cef

!

!

!

ip audit po max-events 100

no ftp-server write-enable

!

!

!

!

interface Ethernet0/0

ip address 193.168.1.1 255.255.255.0

ip nat inside

half-duplex

!

interface TokenRing0/0

no ip address

shutdown

ring-speed 16

!

interface Serial1/0

ip address 200.200.100.1 255.255.255.252

ip nat outside

no fair-queue

!

interface Serial1/1

no ip address

shutdown

!

interface Serial1/2

no ip address

shutdown

!

interface Serial1/3

no ip address

shutdown

!

ip nat pool public 200.200.100.129 200.200.100.250 netmask 255.255.255.128

ip nat inside source list 1 pool public

ip nat inside source static 193.168.1.2 200.200.100.252

ip http server

ip classless

ip route 0.0.0.0 0.0.0.0 200.200.100.2

!

!

access-list 1 permit 193.168.1.0 0.0.0.255

!

line con 0

exec-timeout 0 0

line aux 0

line vty 0 4

login

!

!

1 ACCEPTED SOLUTION

Accepted Solutions
Purple

Re: NAT

Hi,

Could you post the output of 'sh ip nat translations' after you ping from the workstation ?

Also, is the workstation able to ping locations on the Internet at all ? Or is it having problems getting out to any address ?

Paresh

3 REPLIES
Purple

Re: NAT

Hi,

Could you post the output of 'sh ip nat translations' after you ping from the workstation ?

Also, is the workstation able to ping locations on the Internet at all ? Or is it having problems getting out to any address ?

Paresh

New Member

Re: NAT

Paresh,

I shut off the the routers and the dynamic NAT config is working.

Purple

Re: NAT

Cool.. I could not see any reason myself why it was not working. The reboot probably cleared the NAT translation table which I thought was where the issue was.

Good to see that you got it going.

Paresh

108
Views
0
Helpful
3
Replies
CreatePlease login to create content