Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Community Member

Native VLAN dot1q

When configuring "router on a stick" or Inter Vlan Routing between a router and a Ethernet switch is the Native VLAN required for dot1q trunking? Is the Native Vlan required for all trunk links between a router and switch. What's the purpose of creating a VLAN that's not tagging on trunk link?

12 REPLIES
Cisco Employee

Re: Native VLAN dot1q

Native VLAN is not required. IOS on router does not require a Native and Hybrid software on certain platforms allows you to configure all VLANs to be tagged. If you platform does not have the configuration option to tag all VLANs, you assign the Native VLAN to a bogus VLAN like 999, all other VLANs with traffic will be tagged.

Re: Native VLAN dot1q

Native VLAN is required. If you configure "router on a stick" using subinterfaces simply use "encapsulation dot1Q x native" on the subinterface belonging to the VLAN which is native on the switch end of the line.

The purpose of creating a VLAN that's not tagging on trunk link is enabling trunk negotiation and basic connectivity if the opposite trunk sites are not configured correctly.

Regards,

Milan

Community Member

Re: Native VLAN dot1q

IOS Versions prior to 12.1(3) don't allow the "native" parameter under the "encapsulation dot11 x" statement. So, under the Main interface ex. Fasteth0/1 you just configure an ip address. However, I'm having a problem because the router won't be able to see the switch on the other side that is configured as follows (on switch):

vlan database

vtp domain test

vtp trans

vlan 25

apply

exit

!

conf t

int vlan 1

ip addr 10.12.1.2 255.255.255.128

int f0/1

switchport mode trunk

switchport trunk native vlan 1

switchport trunk allowed vlan all

int f 0/2

switchport access vlan 25

spanning-tree portfast

ip default-gateway 10.12.1.1

end

UNLESS you add the following statement:

on the router:

int f0/1.1

encapsulation dot1q 1

exit

But, then, intervlan routing doesn't work....This is a catch 22 situation that needs to be resolved. Please help.

Re: Native VLAN dot1q

You need another statement in the switch config:

int f0/1

switchport trunk encapsulation dot1q

(default is ISL, I suppose you're using Cat3500 connected to the router via f0/1).

In you router config should be:

int f0/1.1

encapsulation dot1q 1 native

int f0/1.25

encapsulation dot1q 25

(again I suppose router connected to the switch via f0/1).

Your default gateway is strange: If IP address is 10.12.0.2 255.255.255.128 the default gateway should be 10.12.0.x where x is between 1 and 126. But you should still be able to route between PCs connected to switch ports in different VLANs 1 and 25.

HTH,

Milan

Community Member

Re: Native VLAN dot1q

You are right, mistake on my part, switch config has

ip default-gateway 10.12.1.1 with vlan1 on switch ip as 10.12.1.2 255.255.255.128. Gracias,

I tried your recommendations, router has following:

int f0/1

ip address 10.12.1.1 255.255.255.128

no shut

int f 0/1.1

encap dot1q 1

no shut

int f0/1.25

encap dot1q 25

ip address 10.12.2.1 255.255.255.128

ip helper-address 10.12.3.13

no shut

exit

end

but then when w/s connects to 2950 switchport f0/2 , the w/s can only ping gateway, nothing else, not even dhcp server....

Should a bridge group be created for IEEE 802.1q?

Many thanks for your comments...

Re: Native VLAN dot1q

Greg,

first move your

ip address 10.12.1.1 255.255.255.128

to int f 0/1.1

I "router on the stick" each subinterface has to have its own IP address within its VLAN!!

If it still doesn't work, the only remaining thing is the "native" for int f 0/1.1 .

Myabe you should try to move the "encap dot1q 1 native" command to int f0/1 or remove it at all.

Regards,

MIlan

Community Member

Re: Native VLAN dot1q

BTW, using a 2950-48 switch running 12.1(6) where isl is not supported. So, switchport trunk encap dot1q x is defaulted to vlan1 and assumed on a trunk port.....appreciate your responses greatly.

Maybe you have a sample working config? Thanks!

Re: Native VLAN dot1q

I'm using Cat4000 as switch and Cat2948G-L3 as router on the stick.

If you want I can send you my config but I'm afraid it wouldn't help you much.

But I told you already what I think is necessary.

Regards,

Milan

Community Member

Re: Native VLAN dot1q

Thanks...really appreciate your effort....afraid your design is not similar based on software versions (running strictly Cisco Classic IOS on my devices)....Thanks for you help. Tried your recommendations, still no go.....muchas gracias amigo....

Community Member

Re: Native VLAN dot1q

Regarding Router on a Stick/Inter VLAN Routing, is the following possible? The router is connected to a 6500 running CAT OS.

Router#1

Int FE0/1

description Native VLAN

no ip address

Int FE0/1.10

description Mgmt VLAN

ip address 10.1.2.1/24

dot1q

Int FE0/1.20

description User Segment

dot1q

ip address 10.1.3.1/24

Since the physical interface is automatically the Native Vlan it will pass layer 2 instructions such as CDP..... According to some CCO docs it appears standard not to assign an IP address to physical interface. The management Vlan does not necessarily need to be on the Native VLAN.

According to previous posting VLAN999 is created to pass only Layer 2 info and does not have a subnet configured. Is this true?

Cisco Employee

Re: Native VLAN dot1q

http://www.cisco.com/warp/customer/473/50.shtml#801.1Q

See the above URL for config examples.

Cisco Employee

Re: Native VLAN dot1q

1114
Views
0
Helpful
12
Replies
CreatePlease to create content