Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

native vlan help

Hi

I inherited teh current configuration on the switches, and am trying to understand them. Currently I have teh following vlan configuration:

interface GigabitEthernet0/1

switchport trunk encapsulation dot1q

switchport trunk native vlan 102

switchport mode trunk

!

interface GigabitEthernet0/2

switchport trunk encapsulation dot1q

switchport trunk native vlan 102

switchport mode trunk

!

interface VLAN1

no ip address

no ip directed-broadcast

no ip route-cache

shutdown

!

interface VLAN102

ip address 10.12.9.34 255.255.248.0

no ip directed-broadcast

no ip route-cache

Could someone please tell me why the native vlan would be changed to 102, instead of left as 1.

Also lets say the gigabit port is connected to the next switch (switch 3) and it had a native vlan of 104, what would happen in terms of communication between the two switches? What are the possible side affects of this kind of change?

Thanks in advance

Dan

1 ACCEPTED SOLUTION

Accepted Solutions

Re: native vlan help

dan when ever you are going to have trunk using the dot1Q then both the switch's trunk port must be in the same native VLAN otherwise trunking will not form.

hope this helps you

rate this post if it helps

regards

Devang

9 REPLIES

Re: native vlan help

dan when ever you are going to have trunk using the dot1Q then both the switch's trunk port must be in the same native VLAN otherwise trunking will not form.

hope this helps you

rate this post if it helps

regards

Devang

Gold

Re: native vlan help

This is not true.

You can get 802.1q trunks up with different vlans. Native means it does not contain a tag. There is no way to determine by just looking at the packets what vlan it really came from since there is no tag.

Now you will get nasty messages from CDP if your are running it but it will still come up.

This causes all kinds of issues with spanning tree since it is bascally the same as plugging 2 access port from 2 different vlans together.

New Member

Re: native vlan help

Hi

Thanks for the add on info. Basically it can be done but its not recommended, is the jist of what I've gathered.

Firstly would anything horrible happen if I took out the native vlan on the trunk port?

Thanks

Dan

Gold

Re: native vlan help

You can choose not to use the native vlan. Ie define it to be a strange number and then assign no ports to it. This does not really eliminate the native vlan since VTP will still use it but you could turn VTP off. If you remove the native vlan statement cisco defaults it to vlan 1.

All native vlan means is that packets contain no vlan tags. Many other switch venders use the term UNTAGGED to set what cisco calls the native vlan.

New Member

Re: native vlan help

Hi

Thanks for the reply.

Since I have servers configured within vlan 102, I guess I should leave well alone.

Would it be wise to be put teh truninking native vlan to another number that isn't related to the vlan in which the servers reside?

If I'm totally off track please let me know, as I'm quite new at this.

Thanks

Dan

Gold

Re: native vlan help

For example say you delete the statement on both switches. As long as you have not disallowed vlan 102 to pass over the trunk all that happens is the switch will start to place a tag of 102 on the packets. Now this only occurs between the switches. The tags are removed when when the packets are sent to the servers.

In general you do not want to use the native vlan for user traffic. This in effect creates a big flat vlan on all your switches. In a well designed network you will only allow vlans on trunks where they will be used so it tends to issolate switches from each other. It really doesn't matter in smaller networks and even in larger ones since switches are so fast nowdays just one of those best practice things

Re: native vlan help

sorry for that,,,

i have some misunderstanding ...

but normally it is recommanded to have the trunk port on the both switch should be in same vlan...right otherwise error will occure due to the native vlan...that i know in native vlan fram will tranfer with out tagg...

sorry again...

regards

Devang

Gold

Re: native vlan help

yes you should always make sure the vlan numbers match.

It will cause all kinds of issues if you do this wrong.

The switches get very confused if you would send a packet to a switch with a tag that matched its native vlan. If you are very careful you could make it work but there is no reason to.

The key is that you have to be very careful to configure this correctly. There is nothing in the 802.1q protocol that prevents you from doing this wrong. The trunks come up just fine. If you have cisco on both ends with CDP enables you will get a warning but the trunks do not go down because of CDP.

Re: native vlan help

thanks a lot for your reply...

you make my idea regarding to dot1q clear...

thanks again

regards

Devang

190
Views
5
Helpful
9
Replies
CreatePlease login to create content