Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Webcast-Catalyst9k
New Member

Native VLan on acess switch

I've 7 accesss switches from which one switch is connected to 2nd switch with RJ 45 Trunk and other switches cascaded with eachother.

My question is ,Is native vlan necessary on all access switches, if yes than ?

Overview:SW1-Trunkport Fa0/1 to SW2-Fa0/13.

SW2-SW3-SW4-SW5-SW6-SW7(Cascading).

SW4-Connected to core switch Trunk port.

Encapsulation type is dotlq and the cascaded switches are in half duplex but the switch that has the RJ45 trunk connectivity with 2nd switch is in Auto duplex and the connectivity for core switch is also in Auto duplex from one of access switch.

Is that affecting speed?

1 ACCEPTED SOLUTION

Accepted Solutions
Hall of Fame Super Bronze

Re: Native VLan on acess switch

Ah, you have a CX_GIGASTACK

From

http://www.cisco.com/en/US/products/hw/switches/ps607/products_tech_note09186a00800a2cac.shtml

"GigaStack GBIC supports one full-duplex link (in a point-to-point link), or up to eight half-duplex links (in a stack configuration) to other Gigabit Ethernet devices."

16 REPLIES
Hall of Fame Super Bronze

Re: Native VLan on acess switch

Any reason for running half-duplex between switches ?

If you don't configure the native VLAN on the switch ports, it will default to VLAN 1. This setting should not affect your speed problem, Half-Duplexing does.

New Member

Re: Native VLan on acess switch

This Network is at my client site and why cascaded gbic ports are in half duplex, don't know.

Native Vlan configured on all gibic and trunk port is VLAN100 and vlan 1 is shutdown.

I am thinkin to remove Native VLans from ports and makin to full duplex the cascaded ports.

Will that work without affecting anything and half to full duplex will give me Speed?

Hall of Fame Super Bronze

Re: Native VLan on acess switch

Your client is running a suboptimal configuration by half-duplexing your uplink ports.

Your uplink ports should be the fastest and most reliable ports on each switch.

VLAN1 is never shutdown. You may be seeing the SVI VLAN1 but that's not relevant. If you issue 'show vlan' VLAN1 is active and that's all it counts. With the 'show vlan' command, you also see all ports associated to it.

New Member

Re: Native VLan on acess switch

So if i make all the ports to full duplex, is it ok?

My config is.:

interface GigabitEthernet0/2

description *** Cascaded to SW11-5 &

SW11-3 ***

duplex half

switchport trunk encapsulation dot1q

switchport trunk native vlan 100

switchport mode trunk

!

interface VLAN1

no ip address

no ip directed-broadcast

no ip route-cache

shutdown

!

interface VLAN100

ip address 172.25.x.x 255.255.255.0

no ip directed-broadcast

no ip route-cache

Hall of Fame Super Bronze

Re: Native VLan on acess switch

I recommend leaving duplex in auto mode.

New Member

Re: Native VLan on acess switch

Thank you for that.

Last thing I want to know that , can i remove Native Vlans from the uplink and gb ports ,

Is that Necessary to keep in Native Vlan?

If no than why?

interface GigabitEthernet0/1

switchport trunk encapsulation dot1q

switchport trunk native vlan 100******

switchport mode trunk

!

interface GigabitEthernet0/2

description *** Cascaded to...***

duplex half

switchport trunk encapsulation dot1q

switchport trunk native vlan 100****(Can I remove, if no use?)

switchport mode trunk

Hall of Fame Super Bronze

Re: Native VLan on acess switch

The native VLAN should match at both ends.

The VLAN used must exist on each VTP database.

The absense of any command will force the port to use VLAN1.

VLAN1 is created and active in all switches, by default.

New Member

Re: Native VLan on acess switch

Thanks, I understand this but I am thinking ,"why Native VLAN 100 is confiured on these ports"?

I want to know the Specific reason only, coz I don't think ir is useful here, Anyways traffic will move to defalut VLAN1, if not configured that.

Hall of Fame Super Bronze

Re: Native VLan on acess switch

It was configured with native VLAN 100, because that's the design they wanted to go with. There is nothing wrong with leaving the native VLAN to 100 as long as both ends match and that VLAN is created and active on both switches.

Like I stated before, most configs do not have a native VLAN command hence by default VLAN1 is used.

On your setup, I recommend leaving the native VLAN to 100. That's not the reason for your speed problems. Your problem is the half-duplexing on both ports.

---

Please rate helpful posts.

Thanks

Re: Native VLan on acess switch

Hi,

802.1q trunks do not tag native VLAN frames. On the switch that's configured with 'switchport trunk native vlan 100' if a frame arrived untagged then the switch knows the frame belongs to vlan100 and act accordingly. If you are wondering how does it matter, let's say the switch received untagged ARP frame it would flood it out every vlan 100 port + any trunks.

Hope this helps!

Sundar

New Member

Re: Native VLan on acess switch

Hi!Sundar,

If I remove Vlan 100 from the cascaded ports, it wouldn't flood out any trunks as i am using 802.1q and what than what about the untagged frames?

Re: Native VLan on acess switch

The default native vlan on a trunk is vlan 1. Hence, switch would consider those frames to belong to vlan 1.

HTH

Sundar

New Member

Re: Native VLan on acess switch

Thanks , my interface VLan1 is shut down and i am removing my Native VLAN100 from ports , It won't affect anything and untagged frames will belong to vlan1 only, right?

New Member

Re: Native VLan on acess switch

I changed all gb ports to Auto and it's in Auto Duplex(Half)

Auto-duplex (Half), 1000Mb/s, media type is CX_GIGASTACK

Why it can't be in Full Duplex?

However, the Trunk to core switch for sw4 ga 0/1 is in Auto Duplex(Full) and ga0/2 Is in Auto Duplex (Haplf).

Hall of Fame Super Bronze

Re: Native VLan on acess switch

Ah, you have a CX_GIGASTACK

From

http://www.cisco.com/en/US/products/hw/switches/ps607/products_tech_note09186a00800a2cac.shtml

"GigaStack GBIC supports one full-duplex link (in a point-to-point link), or up to eight half-duplex links (in a stack configuration) to other Gigabit Ethernet devices."

New Member

Re: Native VLan on acess switch

Oh!Thanks Edison.I got it.

202
Views
3
Helpful
16
Replies
CreatePlease to create content