Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

natting

Can anyone please tell me if I had 1 internet address, and just one pc sitting on the network, to get access to the internet do I just need to nat the pc address to ip address the serial interface of the router ?

thanks

Carl

  • Other Network Infrastructure Subjects
5 REPLIES

Re: natting

Hi

You need to have a ethernet interface configured in the router which will be on the same network in which your pc is configured.

Need to mention ip nat inside under that interface and ip nat outside in the serial interface.

create a static nat translation (one to one translation)using ip nat inside source static 192.168.121.33 p.p.p.p where in p.p.p.p is public ip..

or the other simple way around to reach the internet is to do simple overloading over ur serial (public) interface..

ip nat inside source list 1 interface serial 0 overload

do remember to create an ACL (ACL 1 here) permiting the subnet being configured in ur ethernet..

regds

New Member

Re: natting

I recomend doing the overloading as spremkumar recomended. If you do the static nat you are making a direct connection between the real IP address and the private that you are using. With this scenario unless proper access-lists are in place anything that hits the real IP address will automatically beforwarded on to the pc on the inside network. Also if you do the static nat you can not add additional computers later. Doing the overload will make it so that no matter how many pc's you place on the internal side of the router they will always be natted to the one external IP Address.

New Member

Re: natting

Thanks for the reply's,

If I did want to nat then is what I said correct, you simply nat the ip on the serial interface to whatever your machine ip is,

Also for the PAT scenario, rather than using a list and specifying addresses in the list, how would I just PAT any address that comes through the router ?

thanks

Carl

Re: natting

Hi

I would suggest to go thru this link which explains the command with the keywords..

http://www.cisco.com/univercd/cc/td/doc/product/software/ios123/123cgcr/ipras_r/ip1_i2g.htm#wp1079180

I think its not possible to configure overload without mentioning any ACL.

You can try out creating an ACL permiting any and attaching to the nat statement.

But i have heard some probs in recent past while doing so (without mentioning specific network in the ACL)..

regds

New Member

Re: natting

here is an example config:

interface FastEthernet0/0

description connection to the internet

ip address xxx.xxx.xxx.169 xxx.xxx.xxx.xxx

ip nat outside

interface FastEthernet0/1

description Connection to LAN.

ip address 10.0.0.1 255.255.255.0

ip nat inside

!

!

THis is overloading the interface so that anything in access-list 1 is permitted.

#########################################

ip nat inside source list 1 interface FastEthernet0/0 overload

#########################################

This will nat internal IP addresses to external Ip address

#########################################

ip nat inside source static 10.0.0.201 xxx.xxx.xxx.170 extendable

#########################################

This will deny inside if you want to prevent internet access.

#########################################

access-list 1 deny 10.0.0.88

#########################################

This will permit everything if thats what you want

#########################################

access-list 1 permit 10.0.0.0 0.255.255.255

106
Views
0
Helpful
5
Replies