Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

NBAR and QOS

I am new to QOS and testing out the NBAR features. I have 12.2(16) loaded and I am trying to block kazaa2 I have the PDLM loaded but the traffic is still coming through. Can someone please advise me on what I am missing in my config below. I have elimited any irrelevant info in the config. I am under the impression I just need to identify the traffic via a class map and then shape the traffic with a policy and then apply that policy to the interface. What am I missing? thanks

version 12.2

service password-encryption

ip nbar pdlm flash:kazaa2.pdlm

ip cef

class-map match-any kazaa2

match protocol kazaa2

match protocol fasttrack

policy-map mykazaapolicy

description used to Block all kazaa traffic

class kazaa2

police 8000 8000 8000 conform-action drop exceed-action drop violate-action drop

interface Ethernet0/0

ip address 10.10.11.2 255.255.255.0

ip broadcast-address 10.10.11.255

ip nbar protocol-discovery

service-policy input mykazaapolicy

interface Ethernet0/1

ip address 10.10.12.1 255.255.255.0

ip broadcast-address 10.10.12.255

ip nbar protocol-discovery

service-policy input mykazaapolicy

service-policy output mykazaapolicy

4 REPLIES
New Member

Re: NBAR and QOS

I had the exact same issue. You need a "T" train of IOS. Look for 12.2(15)T1 for your router. Using the Software Finder on Cisco's site, look for the feature called NBAR Real-time Transport Protocol Payload Classification. Without this it won't classify KaZaA2 traffic. With it it does. Since this morning I have this IOS version loaded on my 7206VXR, and it is now classifying KaZaA.

New Member

Re: NBAR and QOS

Thanks that is exactly what I was looking for. I spent about 5 hours beating my head against the wall. Thanks again

New Member

Re: NBAR and QOS

Before upgrading your IOS try with:

match protocol kazaa2 file-transfer "*"

match protocol fasttrack file-transfer "*"

on the class-map definition. This will put a wildcard and thus match all file transfers.

Hope this help

New Member

Re: NBAR and QOS

Thanks for your response...I tried this but with no luck so I used a IOS (T) version and it works now. Thanks

98
Views
0
Helpful
4
Replies