Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

NBMA frame and OSPF confusion

--begin ciscomoderator note-- The following post has been edited to remove potentially confidential information. Please refrain from posting confidential information on the site to reduce security risks to your network. -- end ciscomoderator note --

Hi,

I have configured a frame-relay switch and 2 routers connected r1---framesw----r2

What i dont understand is Broadcast or nonbroadcast whats the catch.

Whats the difference apart from hello intvervals.

Is there any benifets from running in either mode ?

It seems DR is still elected from output.

It is realy confusing me : |

I can comprehend the other models p-p p-mp demand

The configs are below without ip ospf network broadcast on serial int I still get an adj ..

r2#sh run

hostname r2

!

interface Loopback0

ip address 192.168.1.1 255.255.255.0

!

interface Serial1

ip address 192.1.1.3 255.255.255.0

encapsulation frame-relay

ip ospf network broadcast

frame-relay lmi-type ansi

!

!

router ospf 64

log-adjacency-changes

network 192.1.1.0 0.0.0.255 area 0

network 192.168.1.0 0.0.0.255 area 1

end

r2#

#########################################################################################################################

hostname r3 frame-switch

!

ipv6 unicast-routing

frame-relay switching

!

!

!

!

!

!

!

!

!

no voice hpi capture buffer

no voice hpi capture destination

interface Serial0/0

no ip address

encapsulation frame-relay IETF

clockrate 64000

no fair-queue

frame-relay lmi-type ansi

frame-relay intf-type dce

frame-relay route 100 interface Serial0/1 200

!

interface FastEthernet0/1

no ip address

shutdown

duplex auto

speed auto

!

interface Serial0/1

description connection to R1 Serial 0

no ip address

encapsulation frame-relay IETF

clockrate 64000

frame-relay lmi-type ansi

frame-relay intf-type dce

frame-relay route 200 interface Serial0/0 100

!

^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^

hostname r1

!

enable secret 5 xxxxxxxxxxxxxxxxxxxxxxxxxxx

enable password cisco1

!

no ip domain-lookup

isdn switch-type ntt

!

interface Loopback10

ip address xx.xx.xx.0 255.0.0.0

!

interface Serial0

no ip address

!

interface Serial1

ip address 192.1.1.1 255.255.255.0

encapsulation frame-relay

ip ospf network broadcast

ip ospf priority 0

frame-relay lmi-type ansi

!

interface TokenRing0

no ip address

shutdown

!

interface BRI0

no ip address

shutdown

!

router ospf 64

network xx.xx.xx.0 0.0.0.255 area 0

network 192.1.1.0 0.0.0.255 area 0

!

end

r1#

##########################################################################################################

This is when the ip ospf network broadcast isnt present

1#sh ip ospf interface s1

Serial1 is up, line protocol is up

Internet Address 192.1.1.1/24, Area 0

Process ID 64, Router ID xx.xx.xx.0, Network Type NON_BROADCAST, Cost: 64

Transmit Delay is 1 sec, State DROTHER, Priority 0

Designated Router (ID) 192.168.1.1, Interface address 192.1.1.3

No backup designated router on this network

Timer intervals configured, Hello 30, Dead 120, Wait 120, Retransmit 5

Hello due in 00:00:14

Neighbor Count is 1, Adjacent neighbor count is 1

Adjacent with neighbor 192.168.1.1 (Designated Router)

Suppress hello for 0 neighbor(s)

r1#

##########################################################################################################

Now when I apply Ip ospf network broadcast to the serial int on the 2 routers it changes it to broadcast which is understandable.

erial1 is up, line protocol is up

Internet Address 192.1.1.3/24, Area 0

Process ID 64, Router ID 192.168.1.1, Network Type BROADCAST, Cost: 64

Transmit Delay is 1 sec, State DR, Priority 1

Designated Router (ID) 192.168.1.1, Interface address 192.1.1.3

No backup designated router on this network

Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5

Hello due in 00:00:02

Index 1/2, flood queue length 0

Next 0x0(0)/0x0(0)

Last flood scan length is 1, maximum is 1

Last flood scan time is 0 msec, maximum is 4 msec

Neighbor Count is 1, Adjacent neighbor count is 1

Adjacent with neighbor xx.xx.xx.0

Suppress hello for 0 neighbor(s)

What are the advanatges of 1 over the ot

8 REPLIES
New Member

Re: NBMA frame and OSPF confusion

Additional information.

In non broadcast mode i specified the neighbour command under the OSPF process 64.

mode 1 neighbour 192.x.x.x (non broadcast)

mode 2 Ip ospf network broadcast.Broadcast

Gold

Re: NBMA frame and OSPF confusion

There are four options for configuring a point-to-multipoint interface in OSPF:

-- Configure it as broadcast interface, and configure the OSPF interface priority on all the remotes so the hub router is always eleceted as the DR. A DR is always going to be elected on a broadcast network, but you have to make certain it's the hub router.

-- Configure it as a non-broadcast network, and manually configure the neighbors using neighbor statements.

-- Configure it as a point-to-multipoint, which gets rid of the DR election, and injects /32's to each remote router's interface to make certain the next hops are correctly reachable.

-- Configure point-to-point subinterfaces, per remote.

Each of these has pro's and con's--it just depends on what which poison you prefer. Would you rather configure each remote with an OSPF priority of 0, have the /32's in your routing table, manually ocnfigure the neighbors, or configure point-to-point subinterfaces. If it were my network, I'd do the point-to-point subinterfaces, unless I really had a _lot_ of remotes, and the configuration was just too much of a mess to do this.

Russ.W

New Member

Re: NBMA frame and OSPF confusion

Hi Russ,

Im confused here.

I have to get the my system out of brain lock : )

My book Cisco Prees --troubleshooting routing protocols says.

Broadcast Model.

In the broadcast model the broadcast network is simulated.DR's ANd BDR's are elected.

The broadcast model can be simulated in two ways.

1)configure the network-type broadcast

2) configure the neighbour statement

Now when i configure the neighbour statement on the 2 routers the model is Non broadcast.

This appears to me to be non broadcast simulated network as you suggest in point 2 are they just trying to confuse the situation ?

Both require manual intervention on the routers.

Which poison is better design ?

How is non broadcast defined all packets routing and data are traversing the link.

Does all it mean is that i is going to unicast route updates ro the neighbour address and not broadcast to 224.0.0.5 or is there more to it ?

r1#sh ip ospf int s1

Serial1 is up, line protocol is up

Internet Address 192.1.1.1/24, Area 0

Process ID 64, Router ID 77.77.77.0, Network Type NON_BROADCAST, Cost: 64

Transmit Delay is 1 sec, State DROTHER, Priority 0

Designated Router (ID) 192.168.1.1, Interface address 192.1.1.3

No backup designated router on this network

Timer intervals configured, Hello 30, Dead 120, Wait 120, Retransmit 5

Hello due in 00:00:22

Neighbor Count is 1, Adjacent neighbor count is 1

Adjacent with neighbor 192.168.1.1 (Designated Router)

Suppress hello for 0 neighbor(s)

r1#

HMM

Russ is there any reason why we wouldnt configure 2 router in area 0 at the central office to be DR and BDR,

then we wouldnt need to configure priority of 0 (option 1)at all remote locations .

Make The router (hub)that connecst the remotes be a ABR and not the DR The dr and BDR are in area 0 at central site.

With the /32 as you suggest they would get summarised at the ABR (hub that connects remotes)and bbecome a lSA type 3 to the backbone? so this wouldnt add much to the routing table...

Thankyou for your time....

Gold

Re: NBMA frame and OSPF confusion

I don't know why they would say to configure neighbor statements using netowrk type broadcast--the point f network type broadcast is to qutodiscover your neighbors. The only time you'd want to manulaly configure neighbors is when you aren't using multicast hellos to discover them.

As for configuring the hub routers to be DR's--you could bumpthe priority to force the hub router to be a DR, but you're still going to have a BDR, which is going to cause confusion if the hub router goes down, and you have a dual homed remoted (which is what it sounds like). It's more stable, with dual homed remotes, if you're using the network type broadcast, to make certain none of the remotes can ever become a BDR or DR, byt configuring their priority to 0.

Yes, you can summarize out the /32's at the border, using point-to-multipoint, using an area range statement.

Hope that helps...

Russ.W

New Member

Re: NBMA frame and OSPF confusion

Hi Russ,

I just want to confirm NON Broadcast.

If i use the neighbour command on routers and do a sh ip osp int.

It is Non Bradcast.

Now does this mean that updates are unicast to the neighbour ip address.

I cant fine any example that tells me the differnce between using NB or B.That is the confusing part if there is no difference why have it ?

The book seems to be misleading.

Page 320 of troubleshooting IP routing protocols.

It also says here.

Another way to simulate the "broadcast model" is through the neighbour statement,as shown in Example 8-21.the neighbour statement must be configured manually in the hub router.Which is router a in this case,

Router A must be configured with a higher priority so its always the DR.

RouterA#

Int s 0

encap frame-relay

ip address 1.1.1.2 /24

ip ospf priority

router ospf 1

neighbour 1.1.1.3

neighbour 1.1.1.4

Is this incorrect because the command.

Sh ip ospf int

Will show it as NON Broadcast....

Thankyou very much for you effort in replying.

Its greatly appreciated.

Gold

Re: NBMA frame and OSPF confusion

Well, the books is saying that you can emulate the broadcast model with nonbroadcast links by configuring the neighbors. This isn't exactly true, but.... You won't have s DR or BDR with the nonbroadcast model.

With the broadcast model, you can configure the hub with a higher priority, but it's just "safer" to configure the remotes.

Russ.W

New Member

Re: NBMA frame and OSPF confusion

Russ,

Here is the config and the sh ip ospf int s1 say it is DR on no broadcast network.

The reason 'm so persistent is I want to do the CCIE

exam but i want oknow what is correct.

interface Serial1

ip address 192.1.1.3 255.255.255.0

encapsulation frame-relay

frame-relay lmi-type ansi

!

interface BRI0

no ip address

encapsulation hdlc

shutdown

!

router ospf 64

log-adjacency-changes

network 192.1.1.0 0.0.0.255 area 0

network 192.168.1.0 0.0.0.255 area 1

neighbor 192.1.1.1

!

ip classless

ip http server

!

!

gatekeeper

shutdown

!

!

line con 0

line aux 0

line vty 0 4

login

!

end

r2#sh ip ospf int s1

Serial1 is up, line protocol is up

Internet Address 192.1.1.3/24, Area 0

Process ID 64, Router ID 192.168.1.1, Network Type NON_BROADCAST, Cost: 64

Transmit Delay is 1 sec, State DR, Priority 1

Designated Router (ID) 192.168.1.1, Interface address 192.1.1.3

No backup designated router on this network

Timer intervals configured, Hello 30, Dead 120, Wait 120, Retransmit 5

Hello due in 00:00:16

Index 1/1, flood queue length 0

Next 0x0(0)/0x0(0)

Last flood scan length is 2, maximum is 2

Last flood scan time is 0 msec, maximum is 0 msec

Neighbor Count is 1, Adjacent neighbor count is 1

Adjacent with neighbor 77.77.77.0

Suppress hello for 0 neighbor(s)

r2#

2#sh ip ospf neighbor

Neighbor ID Pri State Dead Time Address Interface

77.77.77.0 0 FULL/DROTHER 00:01:40 192.1.1.1 Serial1

r2#

And if I REMOVE ip ospf priority 0 on the neighbour and combac to this router

and do sh ip ospf neighbour

r2#sh ip ospf neighbor it has become BDR so BDR and DR are elected on Non broadcast MA when using only the neighbour statement please explain.

Neighbor ID Pri State Dead Time Address Interface

77.77.77.0 1 FULL/BDR 00:01:59 192.1.1.1 Serial1

r2#

r2#sh ip ospf int s1

Serial1 is up, line protocol is up

Internet Address 192.1.1.3/24, Area 0

Process ID 64, Router ID 192.168.1.1, Network Type NON_BROADCAST, Cost: 64

Transmit Delay is 1 sec, State DR, Priority 1

Designated Router (ID) 192.168.1.1, Interface address 192.1.1.3

Backup Designated router (ID) 77.77.77.0, Interface address 192.1.1.1

Timer intervals configured, Hello 30, Dead 120, Wait 120, Retransmit 5

Hello due in 00:00:08

Index 1/1, flood queue length 0

Next 0x0(0)/0x0(0)

Last flood scan length is 2, maximum is 2

Last flood scan time is 0 msec, maximum is 0 msec

Neighbor Count is 1, Adjacent neighbor count is 1

Adjacent with neighbor 77.77.77.0 (Backup Designated Router)

Suppress hello for 0 neighbor(s)

r2#

And this link suggests that DR and BDR are elected on NBMA networks using the neighbour statement which you implied in your last post doesnt happen.

http://www.cisco.com/en/US/tech/tk365/tk480/technologies_tech_note09186a008009470d.shtml#config2

Ok thats enough from me thanks verymuch again for your effort in helping me out.

regards...

Thankyou...

Gold

Re: NBMA frame and OSPF confusion

We _do_ elect a DR/BDR on nonbroadcast links with neighbor statements, and you should use the OSPF priority commands to force the DR to be the DR, with no possible BDR. Most books and online configs state you should just set the hub router's priority higher, but it's always better to set the remotes to 0.

Russ.W

181
Views
0
Helpful
8
Replies
CreatePlease to create content