Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Need help configuring static nat on 2600 IOS 11.3(2)XA1

I'm attempting to setup static NAT to help ease the process of consolidating addresses. I have followed the guidelines to the word as presented in the Cisco documentation series for my IOS, but it seems the commands simply do not exist.

I am referring to this document:

http://www.cisco.com/univercd/cc/td/doc/product/software/ios113ed/113ed_cr/dial_r/drprt11/drnat.htm#40606

I am executing the commands in Global config mode:

pericles(config)#ip nat inside source ?

list Specify access list describing local addresses

pericles(config)#ip nat inside source static ?

% Unrecognized command

Is there something I am missing? I have tried adding the inside and outside designations to the interfaces first, then trying to specify the static translations, but the command still does not appear. Seems like all I can do is configure dynamic translations, which is not what I am trying to do.

Here's what I get when I query the ip nat command:

pericles(config)#ip nat ?

inside Inside address translation

translation NAT translation entry configuration

seems odd that there aren't more commands, like pool or outside.

What am I missing here? Any help would be very appreciated.

1 REPLY
New Member

Re: Need help configuring static nat on 2600 IOS 11.3(2)XA1

ip nat pool dom 200.3.89.154 200.3.89.159 netmask 255.255.255.248 type rotary

ip nat inside source list 1 pool dom overload

interface Ethernet0/0

ip address 172.21.4.1 255.255.255.128

ip nat inside

interface Loopback50

ip address 200.3.89.153 255.255.255.248

ip nat outside

interface Serial0/0.1 point-to-point

description (INTERNET) ---> M.Office

ip address 200.3.74.78 255.255.255.252

ip nat outside

frame-relay interface-dlci 151

ip route 0.0.0.0 0.0.0.0 200.3.74.77

!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

ROUTER#sh ver

Cisco Internetwork Operating System Software

IOS (tm) C2600 Software (C2600-IS-M), Version 11.3(7)T, RELEASE SOFTWARE (fc1)

Copyright (c) 1986-1998 by cisco Systems, Inc.

Compiled Tue 01-Dec-98 12:31 by ccai

Image text-base: 0x80008084, data-base: 0x8082C820

ROM: System Bootstrap, Version 11.3(2)XA3, PLATFORM SPECIFIC RELEASE SOFTWARE (fc1)

ROUTER uptime is 8 weeks, 4 days, 1 hour, 59 minutes

System restarted by power-on at 07:05:07 UTC Mon Jan 28 2002

System image file is "flash:c2600-is-mz_113-7_T.bin", booted via flash

cisco 2610 (MPC860) processor (revision 0x202) with 16384K/4096K bytes of memory.

Processor board ID JAB023804M6 (1758503988)

M860 processor: part number 0, mask 32

Bridging software.

X.25 software, Version 3.0.0.

1 Ethernet/IEEE 802.3 interface(s)

1 Serial network interface(s)

2 Low-speed serial(sync/async) network interface(s)

2 Voice FXO interface(s)

32K bytes of non-volatile configuration memory.

8192K bytes of processor board System flash (Read/Write)

Configuration register is 0x2102

ROUTER#

!

!

!

ROUTER#sh ip nat statistics

Total active translations: 0 (0 static, 0 dynamic; 0 extended)

Outside interfaces:

Serial0/0.1, Loopback50

Inside interfaces:

Ethernet0/0

Hits: 817 Misses: 113

Expired translations: 120

Dynamic mappings:

-- Inside Source

access-list 1 pool dom refcount 0

pool dom: netmask 255.255.255.248

start 200.3.89.154 end 200.3.89.159

type rotary, total addresses 6, allocated 0 (0%), misses 0

!

!

!

ROUTER#sh ip nat translations

Hope this help

218
Views
0
Helpful
1
Replies