Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Need help with access-list

I've configured RIPv2 between R5, R4 and R3.

R5-E0<---------------->R4-E0<--------------->R3-E0

R4 is getting 8 routes (network 189.160.1.0 to 189.160.8.0 ) from R5 and advertising these 8 routes to R3 as a RIP routes. What I am try to do is that instead of R4 sending 8 routes to R3, I am trying to configure R4 so that R4 will send 189.160.0.0/16 only routes to R3. I do not want to use summary command to do this. Below is my config...but it does not work...R3 still sees 8 routes learned from R4. Please tell me what is wrong in my config.

R4#

int E0/0

Ip address 180.120.1.1 255.255.255.0

!

router rip

version 2

network 180.120.0.0

network 189.160.0.0

distribute-list prefix R3 out Ethernet0/0

no auto-summary

!

ip prefix-list R3 seq 5 permit 189.160.0.0/16

!

R3#

int E0/0

Ip address 180.120.1.2 255.255.255.0

!

router rip

version 2

passive-interface default

no passive-interface Ethernet0/0

network 180.120.0.0

no auto-summary

R3# sh ip route

R 189.160.1.0 [120/1] via 180.120.1.1, 00:00:01, Ethernet0/0

R 189.160.2.0 [120/2] via 180.120.1.1, 00:00:01, Ethernet0/0

R 189.160.3.0 [120/1] via 180.120.1.1, 00:00:01, Ethernet0/0

R 189.160.4.0 [120/2] via 180.120.1.1, 00:00:01, Ethernet0/0

R 189.160.5.0 [120/2] via 180.120.1.1, 00:00:01, Ethernet0/0

R 189.160.6.0 [120/2] via 180.120.1.1, 00:00:01, Ethernet0/0

R 189.160.7.0 [120/2] via 180.120.1.1, 00:00:01, Ethernet0/0

R 189.160.8.0 [120/2] via 180.120.1.1, 00:00:01, Ethernet0/0

2 REPLIES
Silver

Re: Need help with access-list

AFAIK distribute-list will not summarise it will only restrict routes so only way to get summary routes would be to do an auto-summary.

VIP Purple

Re: Need help with access-list

Hello,

in addition to Gautam's post, you could also redistribute a static route for the 189.160.0.0/16 into RIP. Either way, you first need the 189.160.0.0/16 route in the RIP database of R4 before you can do anything with it. Your prefix list needs to deny all prefixes for that network with a mask greater than 16.

So basically your configuration options on R4 are:

router rip

version 2

network 180.120.0.0

network 189.160.0.0

distribute-list prefix R3 out Ethernet0/0

-->auto-summary

!

ip prefix-list R3 seq 5 deny 189.160.0.0/17 le 32

or

router rip

version 2

--> redistribute static

network 180.120.0.0

network 189.160.0.0

distribute-list prefix R3 out Ethernet0/0

auto-summary

!

ip prefix-list R3 seq 5 deny 189.160.0.0/17 le 32

!

-->ip route 189.160.0.0 255.255.0.0 Ethernet0/0

HTH,

GP

95
Views
0
Helpful
2
Replies
CreatePlease to create content