Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Need to NAT to certain destination and not others

I need to NAT addresses inside on the ethernet LAN and outbound on the serial destined for a specific network and not NAT all the rest. I have a pool set up and an extended ACL with the source and destination networks of the network I want to NAT to defined. When I ping a loopback in the network sourced from the routers ethernet it works like I expect. It doesn't NAT because it's not in the ACL. But once I ping an address using the NAT extended ACL which also works like I expect, then all traffic appears to be NAT'd from that point on. Even the ping to the loopback that worked previously. I can see this in the NAT stat's. Anyone have any idea? It's a 1721 router running 12.2.8T.

3 REPLIES
VIP Purple

Re: Need to NAT to certain destination and not others

Hello,

can you post your configuration, as well as the output of the command:

show ip nat translations

Regards,

Georg

New Member

Re: Need to NAT to certain destination and not others

Here's the NAT piece of the config.

ip nat pool localsite 10.114.7.2 10.114.7.254 netmask 255.255.255.0

ip nat inside source list ToDenBosch pool localsite

!

ip access-list extended ToDenBosch

permit ip 192.168.7.0 0.0.0.255 10.65.16.0 0.0.0.255

interface FastEthernet0

ip address 192.168.7.68 255.255.255.0

ip address 10.114.7.1 255.255.255.0 sec

ip nat inside

!

interface Serial0.1

ip nat outside

Anonymous
N/A

Re: Need to NAT to certain destination and not others

Hi Bleddy,

I am having exactly similar problem with the NAT issue you had. Have your problem resolved yet? If yes, is it possible to share your solution with me.

Many thanks.

best regards,

Chee

91
Views
0
Helpful
3
Replies