Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Webcast-Catalyst9k
New Member

Need to provide access to PC Anywhere client on my LAN

Some of My clients are running software that requires the provider to have remote support capabilities via PC Anywhere. I'm using a 1720 router with NAT for my Internet gateway, and would like to give them safe passage through to my clients running PC Anywhere. I've toyed with the "ip nat outside source" command and some associated access lists, but have had no luck. My current running config is as follows:

version 12.1

service timestamps debug uptime

service timestamps log uptime

no service password-encryption

!

hostname *****

!

boot system flash 1:aaa1376.bin

no logging console

enable password *****

!

!

!

!

!

memory-size iomem 25

clock timezone PST -8

clock summer-time PDT recurring

ip subnet-zero

!

ip audit notify log

ip audit po max-events 100

!

!

!

interface Tunnel0

description admin tunnel to office 2

ip address 192.168.1.1 255.255.255.0

ip broadcast-address 0.0.0.0

tunnel source Serial0

tunnel destination w.x.y.z

!

interface Serial0

description ISP Genuity

ip address z.y.w.x 255.255.255.252

ip broadcast-address 0.0.0.0

ip nat outside

no fair-queue

service-module t1 timeslots 1-24

!

interface FastEthernet0

description inside network

ip address 192.168.0.1 255.255.255.0

ip broadcast-address 192.168.0.1

ip nat inside

speed auto

!

ip nat inside source list 1 interface Serial0 overload

ip classless

ip route 0.0.0.0 0.0.0.0 Serial0

ip route 10.1.1.0 255.255.255.0 Tunnel0

no ip http server

!

access-list 1 permit 192.168.0.0 0.0.0.255

!

line con 0

exec-timeout 0 0

transport input none

line aux 0

line vty 0 4

password powerband

login

!

no scheduler allocate

end

Any guidance would be greatly appreciated.

-Tim-

3 REPLIES

Re: Need to provide access to PC Anywhere client on my LAN

From your config it appears that you are using PAT. From the subnet mask it becomes clear that you have only one Internet IP adress available.

This means that you can enable PC Anywhere access on one PC using the standard port number for PC anywhere.

To set this up you need a static translation from the PC on the PC-Anywhere-port (I do not know which one) and map this statically to your outside adress. The global command to do this is:

ip nat inside source static tcp tcp-port tcp-port.

To enable multiple PC's you need either more IP's or different port numbers.

Goodluck,

Leo

New Member

Re: Need to provide access to PC Anywhere client on my LAN

Leo,

Thank you for your response. Your proposed solution raises a few questions.

With regard to NAT vs. PAT, I understand their differences by acronym, however I'm having trouble differentiating their application, and whether you can have one without the other.

Secondly, I use PC Anywhere to control remote clients in office #2 through my VPN Tunnel (interface tunnel0). With my workstation in office #1 set as the remote, I simply enter the broadcast address of my office #2 network, and it scans that network returning a list of PC Anywhere hosts. At that point, I merely select the host I wish to administer. Is there a way that I can provide this functionality to my software vendor? If not, I can always set up one host up as a gateway to the other PC Anywhere hosts on my network.

Lastly, I do have a block of IP addresses, but I outsource both my web hosting and email and as such have no need to utilize them. Perhaps I now have a use for them. PC Anywhere is configured by default to use a data port and status port of 5631 and 5632 respectively, however these ports can be reconfigured.

Forgive me if I seem to be babbling, but this has been troubling me for quite some time, and I would dearly like to get my arms around a solution understand it as well.

Best regards,

-Tim-

thadley@cbempire.com

Silver

Re: Need to provide access to PC Anywhere client on my LAN

NAT and PAT are basically the same - NAT means many to many for ip mappings, whereas PAT means many to just one ip. In common conversation, almost everyone refers to both nat and pat as nat. In fact, I'd say that 99.99% of people with home networks behind a cable modem/dsl router would call what they are doing nat, while cisco prefers to refer to that special case with one 1 as pat.

You could forward the ports as mentioned. You could restrict access to them via an access list, or perhaps instead, you could look at setting up a vpn for access for PC Anywhere.

Make sure you are running the latest PC Anywhere version, and check for patches, as it, like everything ,has had security issues

88
Views
0
Helpful
3
Replies
CreatePlease to create content