Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Negating Telnet transparent on cisco 2600 doesnt work?

Problem: The routers async lines do not exhibit the default behaviour of <CR><LF> as

described in the Cisco documentation. However, executing a TELNET TRANSPARENT

command will force a <CR><NULL>.(which is fine)

How do you confgure the async lines to generate the Cisco default behaviour?

Is it possible to disable the insertion of any character after the <CR>?

TEST

When this program READ_PORT is run, it connects to port 2033 on the Cisco router

10.10.10.101 and prints the hex code of any bytes received.

You will notice that when you first run it, it reports a stream of characters

ff, fb, 01,

ff, fb, 03,

ff, fd, 18,

ff, fd, 1f

What are these characters and why are they generated? Is it possible to disable

the generation of these characters?

If you then [telnet 10.10.10.101 /port=2034] and start typing characters, you will

see that each character you type displays its hex code in the other window. When you

press enter, you get hex code 0d (carriage return). When you press another character

you get hex code 00 followed by the code of the next character that you type.

Cisco IOS Terminal Services Command Reference, Release 12.2 describes the following

under the heading TELNET TRANSPARENT

"To configure the Cisco IOS software to send a CARRIAGE RETURN (CR) as a CR followed

by a NULL instead of a CR followed by LINE FEED (LF), use the TELNET TRANSPARENT

command in line configuration mode. To return to the default setting, use the no form

of this command"

"Defaults - CARRIAGE RETURN followed be a LINE FEED."

SYSTEM CONFIGURATION

1) A Cisco 2600 series router containing 2 10Base_T interfaces, 1 WIC-1T (single port

serial WAN interface card), 1 NM-4A/S (4 port Async /sync serial network module)

Note: The async /sync module is configured for use as async use.

2) The Cisco router is connected to a switch via Ethernet0/0. The switch also has a

number of UNIX (Tru64 and LINUX) and OpenVMS systems connected.

3) The router is using the ROUTER.TXT as a startup file.

4) Two Cisco RS232 cables are connected together with an adapter. One of the cables is

connected to interfaces Serial1/0 (line 33) and the other to Serial1/1 (line 34)

5) The program READ_PORT.C is compiled and has been executed on OpenVMS and LINUX systems.

-------------------------------------------

Below is the config of the router

interface Ethernet0/0

ip address 10.10.10.101 255.255.255.0

no ip mroute-cache

half-duplex

lat enabled

no cdp enable

no mop enabled

!

interface Serial0/0

no ip address

no ip mroute-cache

shutdown

!

interface Ethernet0/1

no ip address

no ip mroute-cache

shutdown

half-duplex

no cdp enable

!

interface Serial1/0

physical-layer async

ip unnumbered Ethernet0/0

!

interface Serial1/1

physical-layer async

ip unnumbered Ethernet0/0

!

interface Serial1/2

physical-layer async

ip unnumbered Ethernet0/0

!

interface Serial1/3

physical-layer async

ip unnumbered Ethernet0/0

!

ip classless

ip route 0.0.0.0 0.0.0.0 10.10.10.1

ip http server

ip pim bidir-enable

!

lat service ROUTER enabled

!

line con 0

exec-timeout 0 0

!

line 33 34

session-limit 1

no exec

transport preferred none

transport input lat telnet

transport output none

escape-character NONE

parity even

stopbits 1

speed 19200

!

line 35 36

session-limit 1

no exec

transport preferred none

transport input lat

transport output none

escape-character NONE

stopbits 1

speed 19200

!

line aux 0

!

line vty 0 4

password xxxx

login

!

end

2 REPLIES
New Member

Re: Negating Telnet transparent on cisco 2600 doesnt work?

I guess this is normal. Those characters get generated, any way

Gold

Re: Negating Telnet transparent on cisco 2600 doesnt work?

Just a guess, but connecting in RAW mode might get you the "clear" text passthrough you're looking for. Try connecting to port 4034 instead of 2034, which causes the router to not include all the telnet protocol garbage and translation. You could also try port 6034. Here's a URL that shows some of the other connection methods you can use by port; it's not a great description but I had trouble finding a better one. Look at Table 3.

http://www.cisco.com/en/US/tech/tk801/tk133/technologies_tech_note09186a008009469f.shtml#afewnotes

273
Views
0
Helpful
2
Replies
CreatePlease to create content