Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

Nested traffic policies on ATM sub-int

I have tried to apply the following to an ATM subinterface under the PVC, but it is not accepted, and does not give any error message when entering the configuration:

!

access-list 2050 deny tcp any any eq 1494

access-list 2050 deny tcp any any eq 1604

access-list 2050 deny tcp any any eq 80

access-list 2050 deny tcp any any eq 443

access-list 2050 permit ip any any

!

class-map match-any reb

match access-group 2004

match access-group 2005

match access-group 2006

match access-group 2007

!

class-map match-all reb_limit

match access-group 2050

!

policy-map reb_limit

class reb_limit

bandwidth 500

!

policy-map policy1

class reb

police cir 2000000 bc 625000 be 625000

conform-action transmit

exceed-action set-qos-transmit 1

violate-action drop

service_policy reb_limit

!

int atm1/0.100

pvc 10/100

service-policy input policy1

service-policy output policy1

(ACLs 2004,2005,2006 and 2007 are used to select the customer)

Basically the idea is that a customer called reb, is given a cir of 2000000bps. Of this, we want Citrix, http and secure-http to be able to use upto the cir rate, but anything else will be restricted to 500000bps.

Without having the service-policy reb_limit under the class reb in service-policy policy1, all is ok, but if we try and add the reb_limit service policy to the class, the entry is accepted, but when the config is displayed, the second service-policy is not seen.

Hardware is a 7206VXR with NPE400, running 12.2(8)T1.

Are hierarchical traffic policies not allowed on ATM interfaces?

3 REPLIES
Bronze

Re: Nested traffic policies on ATM sub-int

This looks like a bug to me. May be you should check the RNE of CSCdx29416 using the bug toolkit on CCO.

Cisco Employee

Re: Nested traffic policies on ATM sub-int

This is not a bug. If bandwidth needs to be reserved for some classes like reb-limit, the PVC needs to be configured with ATM traffic shaping such as VBR, ABR or CBR. Furthermore, only 75% of the PVC bandwidth can be reserved by default. If you need to reserve more, you will have to use the PVC command: max-reserved-bandwidth.

Have a look to the following URLs for more information:

http://www.cisco.com/warp/customer/121/max_reserved.html

http://www.cisco.com/warp/customer/121/7200_per-vc-CBWFQ.html

http://www.cisco.com/warp/customer/121/7500_per-vc-CBWFQ.html

Community Member

Re: Nested traffic policies on ATM sub-int

Thanks for the replies. It is not a bug. It appears that hierarchical policies are not valid on the 72xx unless the NSE is used. It is only available on the 75xx! (TAC response)

80
Views
2
Helpful
3
Replies
CreatePlease to create content