Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Netware servers won't communicate after IPX network change

what is wrong with this configuration?:

Diagram:

serverA-RouterA-<---->serverB-RouterB<---srvC-RC(notshown)-->

this is an all ethernet network MetroAreaNetwork connected via 1 Wireless 45Mbps dish (antenna)

the wan is all on 1 /24 mask network

*another dish was purchased. So there will be 2 antenna's atop bldg B, 1 to connect to each bldg (A and C). There is now a need to segment the network WAN links. each wan link will have it's own subnet and IPX network address

____________________________________________________________

configs: commands such as 'ip classless' and 'ip subnet-zero' are config'd but not shown.

____________________________________________________________

RouterA

interface ethernet 0

ip address 10.1.1.1 255.255.255.0

!

interface ethernet 0.1

ipx encapsulation sap

ipx network A1

!

interface ethernet 0.2

ipx network A2

!

interface ethernet 1

description link to router B

ip address 20.1.1.2 255.255.255.0

ipx network AB

!

router eigrp 100

network 10.0.0.0

network 20.0.0.0

!

ipx router eigrp 100

network A1

network A2

network AB

__________________________________________________________

RouterB

interface e0/0

ip address 10.1.2.1 255.255.255.0

!

interface e0/0.1

ipx encapsulation sap

ipx network B1

!

interface e0/0.2

ipx network B2

!

interface ethernet 0/1

description link to router A

ip address 20.1.1.1 255.255.255.0

ipx network AB

!

interface ethernet 0/1

description link to router C

ip address 20.2.1.1 255.255.255.0

ipx network CB

!

router eigrp 100

network 10.0.0.0

network 20.0.0.0

log-neighbor-changes

!

ipx router eigrp 100

network B1

network B2

network AB

network CB (link to C not shown)

log-neighbor-changes

_____________ROUTER C___NOT SHOWN_________________________

*LAN PC's can connect to their local server (4.11) but cannot connect to any remote servers. 'show ipx servers' displays all configured Netware File/Print servers, 'show ipx routes' shows all routes to all ipx networks. When using rconsole from the netware server, you can see the attached remote servers but cannot connect to them. Doing a TRACK ON (netware) shows RIP and SAP packets actually arriving from all remote servers, although there are still console error msgs that the servers are not communicationg. Servers can IPXping each other but will not connect (NCP ??). Cisco log entries show no errors, only a newly formed successful IPX-EIGRP adjacency. 'Show interfaces' do not show drops. There are no SAP filters or ACL's in place. Using 'ipx type-20-propagtion' doesn't help. nor 'ipx sap follow-route-path'. Routers have been rebooted, Servers have been downed, LAN to LAN Netware server communication.

IMMEDIATELY AFTER CHANGING THE IPX "WAN LINK" NETWORK ADDRESS THE SERVERS LOSE CONNECTIVITY TO EACH OTHER ALTHOUGH THE ROUTERS KNOW ABOUT ALL SERVERS and the services they have. Putting each netware server on a different ipx "wan" link kills communication. I get "Unable to communicate with 'Server A" console errors. The only way to get them to talk again is to restore the old previous configuration that puts the servers on the same WAN IPX network link. Do Netware servers have a RIP TAble (hop count to next server). Did i screw it up by segmenting each bldg?

2 REPLIES
New Member

Re: Netware servers won't communicate after IPX network change

Do a 'display servers' and 'display networks' on the NetWare servers, to see if all services and networks are seen. If not, somethings wrong with the Cisco config or NW addresses. Any duplicates on the network, including NW internals? If NW 4 or 5, do a DSREPAIR and verify network addresses. Full, unattended repair can't hurt either, which will verify net addresses.

Chuck

New Member

Re: Netware servers won't communicate after IPX network change

There is no " ipx routing a.b.c.d " specified in your configuration on both the routers .

105
Views
0
Helpful
2
Replies