Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Network Address Translation

I have 1 router cisco 1600, with 1 serial, I need to do a NAT, of 6 True Ips for 4 routers with false IPS.

Could anybody help myself?

Respectfully

Geyson

4 REPLIES
New Member

Re: Network Address Translation

Greetings:

This might be a little complicated over this forum, but let's give it a shot. You did not say whether this was to go to an ISP, so I will assume such during that is usually the case.

As a rule, you can apply a single valid address for everyone to go to the Internet. You then set up a valid access-list to indicate who can be translated and then any server that needs it's own individual address for acess from the outside needs to be configured. Take a look at the example below.

!

hostname xyz

!

ip subnet-zero

!

===============

ip nat pool CSI 225.143.68.10 225.143.68.254 netmask 255.255.255.0

ip nat inside source list 99 pool CSI overload

or

ip nat inside source list 99 interface serial0 overload

The first allows you to use a pool of addresses for users to use when going out to the Internet.

The second allows you to use the address on the serial interfaces as the one you translate to

for all users instead of using a pool. If you only have a few addresses to use, this allows you

to save as many as possible.

===============

Addresses for servers that need own address for whatever reason, such as an WWW server outside

users will need access to

ip nat inside source static 10.0.1.3 225.143.68.3

ip nat inside source static 10.0.1.4 225.143.68.4

ip nat inside source static 10.0.1.5 225.143.68.5

ip nat inside source static 10.0.1.6 225.143.68.6

ip nat inside source static 10.0.1.2 225.143.68.2

ip nat inside source static 10.0.7.2 225.143.68.226

!

interface Ethernet0

ip address 10.0.1.1 255.255.255.0

no ip mroute-cache

no ip route-cache

ip nat inside

!

interface Serial0

description T1 to Internet

ip address 216.181.57.38 255.255.255.252

ip nat outside

!

ip classless

ip route 0.0.0.0 0.0.0.0 serial0

!

access-list 99 permit 10.0.0.0 0.0.255.255

The URL that follows will also give you some information on NAT.

http://www.cisco.com/warp/public/556/index.shtml

Hope this all helps.

Thanks...Steve

New Member

Re: Network Address Translation

Steve,

this and my situation,

I have a router 1600, with 1 serial, in my head office, and 4 dispersed routers in the branches.

the technology that we are using and Frame-relay

I have those IPs leaving for the Internet.

200.173.9.106 255.255.255.248

200.173.9.107 255.255.255.248

200.173.9.108 255.255.255.248

200.173.9.109 255.255.255.248

200.173.9.110 255.255.255.248

and IPs of my servers

172.16.1.4 255.255.0.0

172.18.1.8 255.255.0.0

172.19.1.222 255.255.0.0

172.17.10.14 255.255.0.0

the Idea and the following, to do NAT 1 for 1 where when a request of the internet, the router arrives it changes IP for an internal IP and vice-versa.

and a little complicated.

Geyson

New Member

Re: Network Address Translation

Greetings:

If you want to apply a specific server address to a valid Internet address, you would do the following:

ip nat inside source static 172.16.1.4 200.173.9.106

This will allow that server to be access from the Internet at that address. For you general users who just need to get out, you can do the following:

ip nat pool CSI netmask 200.173.9.110 200.173.9.110 netmask 255.255.255.248

ip nat inside source list 99 pool CSI overload

or

ip nat inside source list 99 interface xyz overload

*** use if you have a valid Internet address on interface going out to the Internet ***

You access-list for out bound users will look as follows:

access-list 99 permit ip 172.16.0.0 0.0.255.255

access-list 99 permit ip 172.18.0.0 0.0.255.255

etc...

Hope this helps...Steve

New Member

Re: Network Address Translation

Steve,

Thank you very much for the help

1051
Views
0
Helpful
4
Replies
CreatePlease login to create content