Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Network Design/Configuration Help

Hello all,,,,

I have just started to walk the Network Path and still a long way to go beore I can reach my destination. Just so I don't take a wrong turn on the way, I need your help. Thank you ahead for your time.

I have obtain a Cisco 3620 router with the following interface...

1 Ethernet/IEEE 802.3 interface(s)

1 FastEthernet/IEEE 802.3 interface(s)

1 Token Ring/IEEE 802.5 interface(s)

1 Serial network interface(s) (T1 DSU/CSU)

I like to incorporate that in my home network for practice purpose (at least for a while) but already facing few bumps. I have a DSL connection to my ISP which provide dynamic IP addresses. Between my PC and ISP POP router, I have my DSL Modem. Previously I used a Linksys DSL Router which worked well for providing acces to my laptop, PC and so on. However, I do not have the Linksys anymore but the 3620 router. I would really love to configure that in my setup, so I can practice/learn from my day-to-day use. I have been searching Cisco's site for the last 3 days (on and off).... I am yet to hit something specific to my setup. I would really like if somebody can help me out in the start, so I can pick it up from there.

Thanks

chowchow

7 REPLIES
New Member

Re: Network Design/Configuration Help

Dear Chowchow,

To be honest, it is little hard to find information on the Cisco site on "How to configure a 3620 to replace my old DSL router" :) Obviously what you need here a DHCP Client Ethernet interface as you are using dynamic adressing + a NAT (Netw. address translation) enabling you to use multiple devices in your local network with the help of overloading. (Assuming your existing DSL modem provides an Ethernet for you).

So go through the above topics, as well as IP address assigments etc.

Please note that DHCP Client + NAT configuration available on specific IOS releases, so you may face some other advanture of IOS upgrading.

I hope this helps.

Regards,

Cagri

New Member

Re: Network Design/Configuration Help

Hi Cagri

Thanks for your kind response. After reading your message, I searched cisco.com for that specific documentation but not having much luck. Do you have any link ? ;))

I utilize a psuedo Ethernet Interface in my laptop ( PPP over Ethernet (PPPoE)) to obtain IP from ISP DHCP server.....

Laptop -->DSL Modem ---->ISP

*No static IP.

Up until I had access to this router, I had a Linksys DSL Router that I utilized to obtain an IP from my ISP and keep a constant connection. Then I configured DHCP to that router which provided DHCP services to various pc, laptop at home. We would simply connect client and have instance connection to ISP.

I am trying to do the same thing with this router. I want to configure the Ethernet0/0 Interface and configure it as DHCP client. Connect my laptop (or may be a hub later) to the FastEthernet1/0 and configure similar setup.

But I am not sure how exactly I need to go about doing that initially...My IOS version is 12.0(23).

Thanks for your response...

New Member

Re: Network Design/Configuration Help

Try this:

on the e0/0 and since its using pppoe try to assign the ip address in the interface configuration mode using the command #ip address negotiated. if that is not going to work then you can try #ip address dhcp

once you have your new ip from the isp on the e0/0 then you need to setup 2 things on your 3620 1)nat 2)dhcp

nat can be set by issuing the command #ip nat outside. on the e0/0 configuration mode then the command #ip nat outside. on the fe0/0 configuration mode ofcourse after you assign a static IP address to the fe0/0 (for example 198.168.10.1) then in the global configuration mode go ahead and creat the access list #access-list 103 permit 198.168.10.0 0.0.0.255

then and in the global config mode issue the nat command #ip nat inside source list 103 interface ethernet0/0 overload

now you connect a static ip machines to your fe0/0 and surf the web

however if you want to configure the dhcp you go like this

#no ip dhcp conflict logging

#ip dhcp exclude-address 198.196.10.1 198.196.10.1

#network 198.168.10.0 255.255.255.0

and that is all.

please let me know what will happen

#ip dhcp

New Member

Re: Network Design/Configuration Help

Hi,

Many thanks for taking the time to respond.. and I am sorry for the delay....

Ok, first of all, not sure if I have the right IOS you are expecting (?)

I have: 3600 Software (C3620-JS-M), Version 12.1(11b)

For example, I try ip address dhcp or ip address negotiated, but I receive error...Notice below

36router(config-if)#ip address ?

A.B.C.D IP address

I only have #ip dhcp option from the global configuration.

Then I try "ip nat outside" and it did work.

Also, I had to add access-list like this

access-list 103 permit ip 192.168.0.0 0.0.0.255 any

(ps I am using 192.168.0.1 as the router IP address)

Anyway, I feel I couldn't do the key stuf, so I am in the wrong IOS version Any recommendation?

Thanks

ChowChow

New Member

Re: Network Design/Configuration Help

Yup, I was in the wrong IOS.... anyway, installed 12.2x (IP Plus) and now I was able to go through all the configuration you've suggested.... (I will copy and paste my "sh run" output below).

Here's one quick question though.... My DSL require me to make a manual connection each time I need to connect to my DSL using the PPoE psuedo card (in my laptop).... However, in this case the topology is something like this....

RJ11 => RJ45 (DSL MODEM) =>RJ45 (Ethernet0/0)

Then RJ45 (FastEthernet)=>RJ45(Laptop)

In router, I have:

interface Ethernet0/0

ip address dhcp

ip nat outside

no ip route-cache

no ip mroute-cache

full-duplex

no cdp enable

I have my FastEthernet as this

interface FastEthernet1/0

ip address 192.168.0.1 255.255.255.0

no ip route-cache

no ip mroute-cache

speed auto

full-duplex

no cdp enable

*note: In the past, I was able to get my DSL Router to take this 3600 router's spot and that router had the option to dial in and get the IP from ISP's DHCP server..

Anyway, here's the entire config.....

36router#sh run

Building configuration...

Current configuration : 1086 bytes

!

version 12.2

service config

service timestamps debug uptime

service timestamps log uptime

no service password-encryption

!

hostname 36router

!

enable secret 5

enable password

!

ip subnet-zero

no ip routing

!

!

!

call rsvp-sync

!

!

!

!

!

!

!

!

interface Ethernet0/0

ip address dhcp

ip nat outside

no ip route-cache

no ip mroute-cache

full-duplex

no cdp enable

!

interface Serial0/0

no ip address

no ip route-cache

no ip mroute-cache

shutdown

no fair-queue

!

interface TokenRing0/0

no ip address

no ip route-cache

no ip mroute-cache

shutdown

ring-speed 16

no cdp enable

!

interface FastEthernet1/0

ip address 192.168.0.1 255.255.255.0

no ip route-cache

no ip mroute-cache

speed auto

full-duplex

no cdp enable

!

ip nat inside source list 103 interface Ethernet0/0 overload

ip classless

ip http server

ip pim bidir-enable

!

access-list 103 permit ip 192.168.0.0 0.0.0.255 any

snmp-server community public RO

!

dial-peer cor custom

!

!

!

!

line con 0

exec-timeout 0 0

line aux 0

line vty 0 4

password

login

!

New Member

Re: Network Design/Configuration Help

Hi, you came a long way.

first you need to put #ip nat inside. in the e1/0 config mode

second I was wrong on the ip dhcp thing. I believe you should use the ip address negotiated and the nogatiated only. however to be able to use the #ip address negotiated you need to configure the ppp on the e0/0 first. in the e0/0 config mode you go like this

#encapsulation ppp

#ip address negotiated

#ppp authentication chap pap

#ppp chap hostname {username sometimes the complete ip address}

#ppp chap password {passwd}

this is to the best of my knowledge. for the record I have never done it before I am just guessing. if any one knows better please step in

New Member

Re: Network Design/Configuration Help

Okay. I was wrong I tried it on my 3640 it doesn't work. see the ethernet port doesn't accept the ppp encaps command

what I would do if i was in your shoes I will hook up my old linksys router to the ISP then connect the 3620 to the linksys and use the ip dhcp command

that would a decent way to incorporate the 3620 into your home network

Thanks

302
Views
0
Helpful
7
Replies
CreatePlease to create content