Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Networking Question

Site A

- end users

- 3COM Switch (Gig)

- Cisco 3560 Switch

- SPF/GBics w/Fiber connection (to Site B)

- this switch has an IP address on port 1 (a VLAN address I assigned to it for management purposes)

- Fiber switch is connected via ethernet cable to 3COM switch

Site B

- end users

- 3COM Switch (Gig)

- Cisco 3560 Switch

- SPF/GBics w/Fiber connection (to Site A)

- this switch has an IP address on port 1 (a VLAN address I assigned to it for management purposes)

- originally connected to the 3COM switch via ehternet cable until I recently unplugged it

Site A address is 172.16.140.x

Site A address is 172.16.150.x

An end user came up on the .140.x side and requested and recieved an .150.x address, before I unplugged Site B's ethernet cable. Site A does not have a local DHCP server. It has a DHCP relay agent which is sent through a router which forwards request to DHCP server in Site B and then recieves IP address respective of the network its on.

However it recieved an address from 150.x scope (via the fiber connection I believe).

Can anyone explain to me why this happen and how do I rectify? I believe that if I build a DHCP server local it should resolve the issue. I also believe that I may have to enter in some routing parameters on the 3560 Fiber switch.

I appreciate your help with this. Thanks!

5 REPLIES

Re: Networking Question

There are some thing you need to clear up or give more information:

1. are the 3560 doing any kinf of L3 services?

2. how are the two 3560 connected? via trunk? access port?

3. Site you said should be on 172.16.140.x and you also said that that same site shoudl be on 172.16.150.x. Which is which?

4. What vlans are the users in site A in?

5. Waht vlans are the users in site B in?

Can you post the following for both 3560:

show vlan

show int trunk

show cdr neigh detail

show ip route

show run

New Member

Re: Networking Question

1. 3560 are not performing any L3 functions

2. 3560 are connected via fiber (bldg to bldg)

- they are plugged in to GBIC ports on switch

- I assigned port 1 on switch an IP address and by default it becomes VLAN1

3. Site A = 172.16.140.x

Site B = 172.16.150.x

(sorry about that)

4. Users are not in a VLAN per se I just assigned an IP address to port 1 (def VLAN port) for remote management purposes. I am thinking that I shouled have assigned a different port though right?

5. Same answer as number 4.

3560 show commands are attached in text document.

Re: Networking Question

The users are supposed to be in different subnets but they are in the same vlan. therefore, when a host in site A boot up and send a DHCP request, that request is forwarded to subnet in 172.16.150.x which is why they are getting address on that range. I would assume and guess that the router that is supposed to be forwarding the bootp from this hosts are attached to switch B and in vlan 1 as well. You will need to trunk the switches and segment them in different vlans. The router will need to be trunked as well and subinterfaces for these two subnets/vlans.

Please rate helpful posts.

New Member

Re: Networking Question

That makes alot of sense. All of the aforementioned. Thank you very much. You would happen to have or know of a template config file that I may be able to get some ideas from as to how I need to configure my switches and router do you?

Thank you again for your help.

Re: Networking Question

I don't have a link with template that is specific to your requirement but you can try the following:

Switch A:

interface fa 0/1

host A in 172.16.140.x

switchport access vlan 1

interface gig x/1

port connecting to switch B

switchport mode trunk

interface vlan 1

mgmt interface for the sole purpose of managing the switch A

ip address 172.16.140.x 255.255.255.0

Switch B:

interface fa 0/1

host in subnet 172.16.150.x

switchport access vlan 2

interface fa 0/1

interface connecting to the router doing inter-vlan routing for subnet 172.16.140.x and 172.16.150.x

switchport mode trunk

interface gig x/1

port connecting to switch A

swithcport mode trunk

interface vlan 1

mgmt interface for the sole purpose of managing the switch B

ip address 172.16.140.x+n 255.255.255.0

So, the above shows configuration for the hosts ports, ports connecting the two switches and the port connecting to the external router, assuming it is connected on switch B.

On the router, it would look like:

interface fa x/x.x

encapsulation dot1q 1 native

ip address 172.16.140.x 255.255.255.0

ip helper-address 172.16.150.x

interface fax/x.x+1

encapsulation dot1q 2

ip address 172.16.150.x 255.255.255.0

For more info on external router doing inter-vlan routing, the switches might be of different platform but the concept remains the same and shoudl apply to your situation:

http://www.cisco.com/en/US/tech/tk389/tk390/technologies_configuration_example09186a00800949fd.shtml

Please rate helpful posts.

164
Views
5
Helpful
5
Replies
CreatePlease login to create content