Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Newbie Needs help with frame-relay

I am new to this. I have 3 1601r with t1 wics. I have one hooke to a T1 for internet. The other 2 are to link a remote site back to to the main site across another T1 point to point. I got the internet working but cannot seem to get the other two talking. When I do sho frame-relay map I get Serial1.1 (down): point-to-point dlci, dlci 20(0x14,0x440), broadcast, IETF

status deleted

The following are the configs from those 2 routers:

! ******************************************************************

! silverSouth.cfg - Cisco router configuration file

! Automatically created by Cisco ConfigMaker v2.6 Build 6

! Tuesday, February 24, 2004, 04:36:05 AM

!

! Hostname: silverSouth

! Model: 1601

! ******************************************************************

!

service timestamps debug uptime

service timestamps log uptime

service password-encryption

no service tcp-small-servers

no service udp-small-servers

!

hostname silverSouth

!

enable password xxxx

!

no ip name-server

!

ip subnet-zero

no ip domain-lookup

ip routing

!

interface Ethernet 0

no shutdown

description connected to EthernetLAN

ip address 10.166.53.251 255.255.255.0

keepalive 10

!

interface Serial 1

no shutdown

no description

service-module t1 clock source line

service-module t1 data-coding normal

service-module t1 remote-loopback full

service-module t1 framing esf

service-module t1 linecode b8zs

service-module t1 lbo none

service-module t1 remote-alarm-enable

no ip address

encapsulation frame-relay

frame-relay lmi-type cisco

!

interface Serial 1.1 point-to-point

no shutdown

description connected to Hickey

ip address 192.168.250.10 255.255.255.252

frame-relay interface-dlci 20 ietf

!

interface Serial 0

no description

no ip address

shutdown

!

router rip

version 2

network 10.0.0.0

network 192.168.250.0

no auto-summary

!

!

ip classless

no ip http server

snmp-server community public RO

no snmp-server location

no snmp-server contact

!

line console 0

exec-timeout 0 0

password silver

login

!

line vty 0 4

password silver

login

!

! The following commands are not recognized by Cisco ConfigMaker

! and are therefore appended here.

!

no service single-slot-reload-enable

!

end

NEXT ONE:

! ******************************************************************

! Hickey.cfg - Cisco router configuration file

! Automatically created by Cisco ConfigMaker v2.6 Build 6

! Tuesday, February 24, 2004, 04:37:15 AM

!

! Hostname: Hickey

! Model: 1601

! ******************************************************************

!

service timestamps debug uptime

service timestamps log uptime

service password-encryption

no service tcp-small-servers

no service udp-small-servers

!

hostname Hickey

!

!

no ip name-server

!

ip subnet-zero

no ip domain-lookup

ip routing

!

interface Ethernet 0

no shutdown

description connected to EthernetLAN_2

ip address 10.26.7.251 255.255.255.0

keepalive 10

!

interface Serial 1

no shutdown

no description

service-module t1 clock source line

service-module t1 data-coding normal

service-module t1 remote-loopback full

service-module t1 framing esf

service-module t1 linecode b8zs

service-module t1 lbo none

service-module t1 remote-alarm-enable

no ip address

encapsulation frame-relay

frame-relay lmi-type cisco

!

interface Serial 1.1 point-to-point

no shutdown

description connected to silverSouth

ip address 192.168.250.9 255.255.255.252

frame-relay interface-dlci 20 ietf

!

interface Serial 0

no description

no ip address

shutdown

!

router rip

version 2

network 10.0.0.0

network 192.168.250.0

no auto-summary

!

!

ip classless

no ip http server

snmp-server community public RO

no snmp-server location

no snmp-server contact

!

line console 0

exec-timeout 0 0

password silver

login

!

line vty 0 4

password silver

login

!

end

1 ACCEPTED SOLUTION

Accepted Solutions
New Member

Re: Newbie Needs help with frame-relay

The DLCI's on each end of the circuit should not be the same since they are local. Check with your provider on what the DLCI should be on each end of the circuit. Is it possible that these circuits are not provisioned for frame-relay? Try using HDLC or PPP and see what happens. Assuming that a show int serial shows up,down.

6 REPLIES
Gold

Re: Newbie Needs help with frame-relay

Ran the results of your "show frame-relay map" command through Cisco's Output Interpreter Tool. Here's what I got back:

*****************************************************

WARNING: Serial1.1 is DOWN, with a PVC state of DELETED.

Possible causes for a PVC state of DELETED:

1. There could be a cable, circuit, or CSU/DSU problem on one or more serial interfaces.

TRY THIS: Issue a 'show int' command for the main interface of which this is a subinterface.

If 'UP,DOWN', this is probably not a cable problem.

If 'DOWN,DOWN', this is probably a cable problem.

If 'DOWN,DOWN':

- Make sure that the cable is securely inserted into the fault serial interface.

- If you are using an external CSU/DSU, make sure that the cable is securely inserted and that the CSU/DSU is correctly configured to assert proper control signals (e.g. DCD, DSR, DTR).

- If you are using an integrated CSU/DSU, make sure the telco circuit is healthy (call your telco, do loopback testing, etc.).

- Move the connection to a different interface on this router to make sure the router interface is not faulty.

2. There could be a DLCI mismatch between you and the local frame-relay service provider. Either they are not using the DLCI that this router is using, or you have configured the wrong DLCI on your router.

TRY THIS: Check with your local frame-relay provider to insure your router's DLCI is the DLCI you should be using. If it is, make sure that the provider is using the same DLCI. If it is not, modify this router's DLCI accordingly.

3. Your connectivity is good, but your local frame-relay provider hasn't defined and/or activated your side of the PVC at all.

TRY THIS: Check with the local frame-relay provider to insure that the PVC is both defined correctly, and activated.

INFO: Your LMI type should always be set to the same value as your service provider. Your serial interface should never be looped.

INFO: On interfaces that are 'up', and 'defined, active', you may still have difficulty pinging the remote address. Do not try to ping the local address, as this does not provide any more information than is learned by pinging the remote address.

If this is a problem, there could be a problem with the service-provider's near and/or far end PVC definition, or with the remote end devices.

Make sure that you can ping the remote interface address. If you cannot, check the remote router's frame relay status, and then check with your frame-relay provider to insure the PVC is built correctly on both sides. If you can ping the remote interface address, but you cannot ping beyond it, there is likely a routing problem on either end. Make sure the next hop addresses are accurate in the routing tables.

*****************************************************

Personally, for a new circuit I would suspect that your provider hasn't provisioned it yet, or if they have then they haven't activated it. Give them a call as the feedback above suggests, confirm the DLCI numbers and LMI-type, etc. Then ask them to "turn the line up" if it's not already up.

Link to the Output Interpreter Tool:

https://www.cisco.com/cgi-bin/Support/OutputInterpreter/home.pl

Hope this helps.

New Member

Re: Newbie Needs help with frame-relay

Called Qwest they said from their side all looks well. So I must have something wrong in my config.

Bronze

Re: Newbie Needs help with frame-relay

Are you sure the DLCI's are correct? Is it supposed to be 20 on both sides?

New Member

Re: Newbie Needs help with frame-relay

yes we are sure. The T1 for the internet was 16 and this one between the stores is 20.

New Member

Re: Newbie Needs help with frame-relay

The DLCI's on each end of the circuit should not be the same since they are local. Check with your provider on what the DLCI should be on each end of the circuit. Is it possible that these circuits are not provisioned for frame-relay? Try using HDLC or PPP and see what happens. Assuming that a show int serial shows up,down.

Gold

Re: Newbie Needs help with frame-relay

DLCIs do not have to be the same at each end of the PVC since they are only locally significant; more often than not, they are NOT the same.

But they CAN be: I've been working with a customer who has about a dozen PVCs from Verizon. Each PVC has the same DLCI number assigned at both the local end and the remote end of the connection. The numbers are still only locally significant. But it's a useful coincidence that they are the same: when the customer uses the DLCI number to refer to a PVC, I know I know exactly which PVC he's talking about.

3111
Views
3
Helpful
6
Replies