Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Nightmare on MPP street.

Hello all,

I know that this should be a straight forward thing, but there is some very bizzare behavior going on with a couple of 2600's that I am trying to get MPP working properly. Both routers are identical.

BTW - If I just use straight PPP, everything is beautiful.

Router A can't do TCP to router B, however, Router B can TCP to Router A.

I can ICMP to both of them. Router is driectly connected to the Internet & router B is at a remote location.

Router A Config:

Building configuration...

Current configuration:

!

version 12.0

service config

service timestamps debug uptime

service timestamps log uptime

no service password-encryption

!

hostname !

enable secret

enable password wordpass

!

!

!

!

!

ip subnet-zero

!

no ip bootp server

!

!

!

process-max-time 200

!

interface Multilink1

ip address 192.168.1.17 255.255.255.240

no ip directed-broadcast

no cdp enable

ppp multilink

multilink load-threshold 2 either

multilink-group 1

!

interface Ethernet0/0

no ip address

no ip directed-broadcast

no ip mroute-cache

shutdown

no cdp enable

!

interface Serial0/0

no ip address

ip directed-broadcast

encapsulation ppp

no ip mroute-cache

no fair-queue

service-module t1 clock source internal

ppp multilink

multilink-group 1

!

interface Serial0/1

no ip address

no ip directed-broadcast

encapsulation ppp

no ip mroute-cache

no fair-queue

service-module t1 clock source internal

ppp multilink

multilink-group 1

!

interface FastEthernet1/0

ip address 209.17.93.17 255.255.255.240 secondary

ip address 209.17.95.129 255.255.255.0

no ip directed-broadcast

no cdp enable

!

ip classless

ip route 0.0.0.0 0.0.0.0 209.17.95.1

ip route 209.17.93.32 255.255.255.240 Multilink1

ip route 209.17.95.144 255.255.255.240 Multilink1

no ip http server

!

snmp-server community public RO

!

line con 0

exec-timeout 0 0

transport input none

line aux 0

line vty 0 4

password login

!

!

no scheduler allocate

end

Router B

Building configuration...

Current configuration:

!

version 12.0

service config

service timestamps debug uptime

service timestamps log uptime

no service password-encryption

!

hostname !

enable secret

enable password wordpass

!

!

!

!

!

ip subnet-zero

!

no ip bootp server

!

!

!

process-max-time 200

!

interface Multilink1

ip address 192.168.1.33 255.255.255.240

ip directed-broadcast

ip nat outside

no cdp enable

ppp multilink

multilink load-threshold 2 either

multilink-group 1

!

interface Serial0/0

ip unnumbered Multilink1

ip directed-broadcast

encapsulation ppp

no ip mroute-cache

no fair-queue

ppp multilink

multilink-group 1

!

interface Serial0/1

ip unnumbered Multilink1

ip directed-broadcast

encapsulation ppp

no ip mroute-cache

no fair-queue

ppp multilink

multilink-group 1

!

interface FastEthernet1/0

ip address 209.17.93.17 255.255.255.240 secondary

ip address 209.17.95.129 255.255.255.0

no ip directed-broadcast

no cdp enable

!

ip route 0.0.0.0 0.0.0.0 Multilink 1

Any clues to what I am doing wrong would be helpful.

Thansk

Rod

4 REPLIES

Re: Nightmare on MPP street.

Since there has been no response to your post, it appears to be either too complex or too rare an issue for other forum members to assist you. If you don't get a suitable response to your post, you may wish to review our resources at the online Technical Assistance Center (http://www.cisco.com/tac) or speak with a TAC engineer. You can open a TAC case online at http://www.cisco.com/tac/caseopen

If anyone else in the forum has some advice, please reply to this thread.

Thank you for posting.

New Member

Re: Nightmare on MPP street.

We had the same issues among others with MPP, between two 2600's and 2600 and 6500. It seems that when a multilink is created on a router and then removed or deleted, it is not really gone. If you then recreate it you have problems. Sometimes if you completely remove MPP configs, reboot routers and then recreate MPP all works fine.

I recommend you open a TAC case as we also had some IOS version issues that needed to be corrected before we were able to completely solve this.

New Member

Re: Nightmare on MPP street.

I dealt with this exact scenario. Instead I reconfigued the T1 controllers so that dumped all my serial interfaces. Doing that I was unable to add any interfaces to multilink-group 1 until I bounced the router.

New Member

Re: Nightmare on MPP street.

It appears that your multilink1 interfaces between the routers are not in the same subnet network. You have 192.168.1.17/28 on router A and 192.168.1.33/28 on router B. These are not within the same subnet. 192.168.1.30/28 is last usable host IP address in the subnet on router A. You are using host IP address .33 on router B. Change the router B multilink IP address to something within router A's subnet and you should be good to go.

191
Views
0
Helpful
4
Replies
CreatePlease login to create content