Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

szq
New Member

nm-8am dialout to w2kpro,need you help!

network diagram:

+-+-+-+-+-+-+ -+-+-+-+-+-+-+-+-+-+ -+-+-+-+-+-

| W2K pro | -----| rtr2621withNM-8AM|---- | W2K pro |

+-+-+-+-+-+-+ -+-+-+-+-+-+-+-+-+-+ -+-+-+-+-+-+

ftp client Ethernet PSTN ms ftp server

application requiement:

if ftp client start a connection to ftp server£¬rtr should init a modem call to ftp server£¬and idle time is 30 second

i try but failed£º

1¡¢ftp server cann't got a route to ftp client£¨cann't manual inject a route in W2KPRO)

2¡¢so i broadcast rip1 to ftp server £¬it got a route£¬

3¡¢when config rip trigged to the wan £¬ftp server lose the route to ftp client after 180 seconds£¬for W2K PRO

RIP listening route timeout is 180 seconds

need help£º

1¡¢who can tell me how can i inject a route to ftp server£¿

2¡¢or who can tell me what can i do £¿

pls help me£¬or I will be fired£¡

BOBOBO

4 REPLIES
Bronze

Re: nm-8am dialout to w2kpro,need you help!

The Win2K server that the router dials into, should have a route to the router's ip address. So what you can do is implement NAT on the router so the source ip address of the ftp connection is translated.

If you need help with this, post your config of the 2621.

hth

Herbert

szq
New Member

Re: nm-8am dialout to w2kpro,need you help!

herbert:

thank you very much

but it's not win2K server,must be win2k pro(for the cost),in china 800us$:200us$.

i have thought of nat or ask some one of ms.

config of 2621:

!

interface Async33

ip address negotiated

encapsulation ppp

dialer in-band

dialer string 088888888

dialer hold-queue 10 timeout 40

dialer-group 1

peer default ip address 172.16.1.1

ppp authentication chap callin

ppp chap hostname dialuser

ppp chap password 0 *******

line 33

modem InOut

modem autoconfigure discovery

transport input telnet

autoselect ppp

dialer-list 1 protocol ip permit

bobobo

Bronze

Re: nm-8am dialout to w2kpro,need you help!

ok, try this:

interface xxx (towards your ftp clients)

ip nat inside

interface Async33

ip nat outside

ip nat inside source list 10 interface Async33 overload

access-list 10 permit x.x.x.x (ftpclient1)

access-list 10 permit x.x.x.x (ftpclient2)

etc.

or

access-list 10 permit x.x.x.0 0.0.0.255 (network of ftpclients)

Let us know if it works?

Herbert

szq
New Member

Re: nm-8am dialout to w2kpro,need you help!

thanks

i have thought of this method,you mentioned me to do it in lab

bobobo

96
Views
0
Helpful
4
Replies
CreatePlease to create content