Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

no connection to hosts on either side of WAN

I have configured two 3620 routers with a serial connection. I can ping each router from the other router. I can ping local devices on the local networks but cannot ping to a device across the WAN connection.

Any suggestions?

17 REPLIES

Re: no connection to hosts on either side of WAN

Check if you have proper routing protocol or static routes configured to route between the sites. Also check the default gateway on the hosts. The test that you did is not enough to prove that your configuration is correct. Or paste the configs in your next reply for more analysis.

When you perform ping tests in scenarios like this, you should start from one end of the network (that is from a host) and then move outward.

Hope that helps!

New Member

Re: no connection to hosts on either side of WAN

Below are the configs. The default gateway is correct. I can ping the serial interface of local router but not the serial interface on other side of wan.

Router A Config

!

version 12.1

no service single-slot-reload-enable

service timestamps debug uptime

service timestamps log uptime

no service password-encryption

!

hostname routera

!

logging rate-limit console 10 except errors

!

ip subnet-zero

!

!

no ip finger

!

!

!

call rsvp-sync

!

!

!

!

!

!

!

!

interface FastEthernet1/0

no ip address

duplex auto

speed auto

!

interface FastEthernet1/0.1

encapsulation dot1Q 1 native

ip address x.x.x.x 255.255.255.0

!

interface FastEthernet1/0.2

encapsulation dot1Q 2

ip address x.x.x.x 255.255.255.0

!

interface FastEthernet1/0.3

encapsulation dot1Q 3

ip address x.x.x.x 255.255.255.0

!

interface Serial1/0

bandwidth 2048

ip address x.x.x.x 255.255.255.252

encapsulation ppp

clockrate 2000000

!

router eigrp 10

network x.x.x.0 0.0.0.3

network x.x.x.0 0.0.0.255

network x.x.x.0 0.0.0.255

network x.x.x.0 0.0.0.255

auto-summary

eigrp log-neighbor-changes

!

ip classless

no ip http server

!

!

ip access-list standard PBX

permit 137.223.156.5

!

dial-peer cor custom

routerB Config

service timestamps log uptime

no service password-encryption

!

hostname routerb

!

logging rate-limit console 10 except errors

!

ip subnet-zero

!

!

no ip finger

!

!

!

call rsvp-sync

!

!

!

!

!

!

!

!

interface FastEthernet1/0

no ip address

duplex auto

speed auto

!

interface FastEthernet1/0.1

encapsulation dot1Q 1 native

ip address x.x.x.x 255.255.255.0

!

interface Serial1/0

bandwidth 2048

ip address x.x.x.x 255.255.255.252

encapsulation ppp

!

router eigrp 10

network x.x.x.0 0.0.0.3

network x.x.x.0 0.0.0.255

auto-summary

eigrp log-neighbor-changes

!

ip classless

no ip http server

!

!

dial-peer cor custom

New Member

Re: no connection to hosts on either side of WAN

Hi,

kindly remove the auto summarization of eigrp..using "no auto-summary" command in both the routers and revert back.

Regards

Amit Shrivastava

Network Engineer(Reliance Infocomm)

New Member

Re: no connection to hosts on either side of WAN

I've now done this - What do you mean by revert back because I'm still having no success. I've attached the sh ip route and sh ip eigrp topology:

sh ip route

Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP

D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area

N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2

E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP

i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area

* - candidate default, U - per-user static route, o - ODR

P - periodic downloaded static route

Gateway of last resort is not set

137.223.0.0/16 is variably subnetted, 6 subnets, 3 masks

C 137.223.10.0/30 is directly connected, Serial1/0

C 137.223.10.2/32 is directly connected, Serial1/0

D 137.223.156.0/24 [90/1764352] via 137.223.10.2, 00:02:02, Serial1/0

C 137.223.157.0/24 is directly connected, FastEthernet1/0.1

D 137.223.154.0/24 [90/1764352] via 137.223.10.2, 00:02:02, Serial1/0

D 137.223.155.0/24 [90/1764352] via 137.223.10.2, 00:02:02, Serial1/0

routerB#sh ip eigrp top

IP-EIGRP Topology Table for AS(10)/ID(137.223.157.1)

Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply,

r - reply Status, s - sia Status

P 137.223.10.0/30, 1 successors, FD is 1761792

via Connected, Serial1/0

P 137.223.10.1/32, 0 successors, FD is Inaccessible

via 137.223.10.2 (2273792/1761792), Serial1/0

P 137.223.10.2/32, 1 successors, FD is 1761792

via Rconnected (1761792/0)

P 137.223.156.0/24, 1 successors, FD is 1764352

via 137.223.10.2 (1764352/28160), Serial1/0

P 137.223.157.0/24, 1 successors, FD is 28160

via Connected, FastEthernet1/0.1

P 137.223.154.0/24, 1 successors, FD is 1764352

via 137.223.10.2 (1764352/28160), Serial1/0

P 137.223.155.0/24, 1 successors, FD is 1764352

via 137.223.10.2 (1764352/28160), Serial1/0

routerB#

New Member

Re: no connection to hosts on either side of WAN

Kindly clarify ur earlier meassge" I can ping the serial interface of local router but not the serial interface on other side of wan."

Does this mean u are trying to ping from local host pc or router??

if its router then try to shutd and no shutd the serial interface at both ends of router and if its from Lan pc then try to shutd and no shutd all the fastethernet ports of both the routers.

I mean to say its better to restart the router at both end and then check.

Hoping for the best..

Amit

New Member

Re: no connection to hosts on either side of WAN

I've restarted both routers but still have the same problem.

If I telnet to the router I can ping any device on either side. However from a command prompt from the pc I can only ping devices on the local network.

New Member

Re: no connection to hosts on either side of WAN

be careful about the defaultgateway settings on your PCs at both sides of the WAN

New Member

Re: no connection to hosts on either side of WAN

The default gateway is the fastethernet address of the router.

New Member

Re: no connection to hosts on either side of WAN

try to ping(extended) the hosts of either side from router using source ip of the router fasethernet port.In ur case one router is connected to three vlans so u can use three ips one by one and perform the ping test. And the same thing u can do that or other router which is connected to one vlan only.

If u are succesful doing this then telnet to switch and try to ping hosts of either sides from switch and check if its happening.

If from switches on eiher side of the wan u are not able to ping the hosts of either side, then pls check the switch config.Are u using any layer 3 switch or layer 2 switch??

New Member

Re: no connection to hosts on either side of WAN

when I telnet to switch I can ping devices on local network, fastethernet int of router but not serial int of router

switch config

version 12.1

no service pad

service timestamps debug uptime

service timestamps log uptime

no service password-encryption

!

hostname srvswitch

!

enable secret xxxxxxx.

!

ip subnet-zero

ip routing

!

ip ssh time-out 120

ip ssh authentication-retries 3

!

spanning-tree mode pvst

spanning-tree extend system-id

!

!

!

interface FastEthernet0/1

switchport trunk encapsulation dot1q

switchport mode trunk

no ip address

!

interface FastEthernet0/2

switchport mode dynamic desirable

no ip address

!

interface FastEthernet0/3

switchport mode dynamic desirable

no ip address

!

interface FastEthernet0/4

switchport mode dynamic desirable

no ip address

!

interface FastEthernet0/5

switchport mode dynamic desirable

no ip address

!

interface FastEthernet0/6

switchport mode dynamic desirable

no ip address

!

interface FastEthernet0/7

switchport mode dynamic desirable

no ip address

!

interface FastEthernet0/8

switchport mode dynamic desirable

no ip address

!

interface FastEthernet0/9

switchport mode dynamic desirable

no ip address

!

interface FastEthernet0/10

switchport mode dynamic desirable

no ip address

!

interface FastEthernet0/11

switchport mode dynamic desirable

no ip address

!

interface FastEthernet0/12

switchport mode dynamic desirable

no ip address

!

interface FastEthernet0/13

switchport access vlan 2

switchport mode access

no ip address

!

interface FastEthernet0/14

switchport access vlan 2

switchport mode access

no ip address

!

interface FastEthernet0/15

switchport access vlan 2

switchport mode access

no ip address

!

interface FastEthernet0/16

switchport access vlan 2

switchport mode access

no ip address

!

interface FastEthernet0/17

switchport access vlan 2

switchport mode access

no ip address

!

interface FastEthernet0/18

switchport access vlan 3

switchport mode access

no ip address

!

interface FastEthernet0/19

switchport access vlan 3

switchport mode access

no ip address

!

interface FastEthernet0/20

switchport access vlan 3

switchport mode access

no ip address

!

interface FastEthernet0/21

switchport access vlan 3

switchport mode access

no ip address

!

interface FastEthernet0/22

switchport access vlan 5

switchport mode access

no ip address

!

interface FastEthernet0/23

switchport mode dynamic desirable

no ip address

!

interface FastEthernet0/24

switchport mode dynamic desirable

no ip address

!

interface GigabitEthernet0/1

switchport mode dynamic desirable

no ip address

!

interface GigabitEthernet0/2

switchport mode dynamic desirable

no ip address

!

interface Vlan1

ip address x.x.x.x 255.255.255.0

!

interface Vlan2

ip address x.x.x.x 255.255.255.0

!

interface Vlan3

ip address x.x.x.x 255.255.255.0

!

!

ip default-gateway 137.223.156.1

ip classless

ip http server

New Member

Re: no connection to hosts on either side of WAN

Hi,

Ur trunk port of the switch should be the part of all the three vlans u have configured. Pls do it and tell us the result.

Amit

New Member

Re: no connection to hosts on either side of WAN

Hi Amit

Is this done by the switchport trunk allowed vlan all?

If not how is this done?

thanks

Michael

New Member

Re: no connection to hosts on either side of WAN

Hi michael,

sorry,u don't need to do anything on trunk port since by default it allows all the vlans.The problem lies somewhere else in LAN only...need to think over..will get back to u soon.

New Member

Re: no connection to hosts on either side of WAN

Hi Amit

I have removed ip routing cmd on switch can now ping fastethernet int of router on other side of wan however cannot ping beyond.

New Member

Re: no connection to hosts on either side of WAN

Hi Michael,

U can remove the ip default-gateway command from the switches at both ends of WAN.U enable ip routing once again in both switches and give the default route as follows:

ip route 0.0.0.0 0.0.0.0 "ur respective router fastethernet port ip".

I hope this shd solve ur problem.

Amit

New Member

Re: no connection to hosts on either side of WAN

Hi Michael,

is ur problem solved?? waiting for ur reply ..

Amit

New Member

Re: no connection to hosts on either side of WAN

hi amit

yes thanks. I had to give an ip address to the fastethernet int of router and then use the subint for further ip addresses of the vlans. I originally thought that you only require ip addresses for subint but obviously not. Everything is now working. Thanks for your help

Michael

118
Views
0
Helpful
17
Replies